[CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Confirmed bugs that have been Fixed - Joomla 1.0.x



[New Threads cannot be started in this forum]
Locked
gimsot
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Jan 22, 2008 1:56 am
Location: Jakarta
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by gimsot » Tue Jan 22, 2008 1:58 am

Thanks for the patch Rob... :D

wishmaster22
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Fri Sep 29, 2006 8:48 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by wishmaster22 » Wed Jan 23, 2008 4:42 am

I want to try this patch.

What is the best way to back up my joomla site and database in case something goes wrong?

Thanks
My Sites

Get-Paid-At-Home.com
cliknsav.com
information-about-this.com

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18628
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by infograf768 » Wed Jan 23, 2008 6:59 am

Nothing will go wrong.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

heidi239
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Jan 18, 2008 10:11 am

Re: HELP ME!! I can't log in as administrator after this fix

Post by heidi239 » Wed Jan 23, 2008 8:31 am

I can't get into my account as an administrator after applying this fix.

I've cleared my cookies. I've used another browser.
ALL MY WORK IS DOWN THE DRAIN.....

heidi239
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Fri Jan 18, 2008 10:11 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by heidi239 » Wed Jan 23, 2008 8:43 am

HELP! I can't log into my site at all now as an administrator. Yes, I've cleared the cookies. Yes, I've tried another browser.
As a Joomla Newbie, I've spent weeks on this site, and now the work has gone up in smoke because of this fix.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18628
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: HELP ME!! I can't log in as administrator after this fix

Post by infograf768 » Wed Jan 23, 2008 8:44 am

heidi239 wrote: I can't get into my account as an administrator after applying this fix.

I've cleared my cookies. I've used another browser.
ALL MY WORK IS DOWN THE DRAIN.....
Cool. Nothing is out the drain.
Save your custom configuration.php, templates, etc.(always good to do) and ftp again or, better, unzip with Cpanel joomla 1.0.13 package, then apply the fix.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

row22
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Aug 27, 2007 1:46 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by row22 » Thu Jan 24, 2008 11:45 am

hi @ all,

i'm using joomla 1.0.13 with jacl and have added the changes from the hotfix to the files includes/joomla.php and administrator/index.php, which had already been changed by jacl. for me, it's working fine now, I'm not logged out any more. hope it helps some of you as well.
You do not have the required permissions to view the files attached to this post.

wishmaster22
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Fri Sep 29, 2006 8:48 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by wishmaster22 » Thu Jan 24, 2008 10:50 pm

I Tried it and its not working.

Should I upgrade to 1.0.14 ?

Or should I install the 1.0 - 1.013 stable patch ?
My Sites

Get-Paid-At-Home.com
cliknsav.com
information-about-this.com

row22
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Aug 27, 2007 1:46 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by row22 » Thu Jan 24, 2008 10:56 pm

@ wishmaster: which joomla version are you using?

the files i have uploaded are only for j! 1.0.13 + latest jacl version

wishmaster22
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Fri Sep 29, 2006 8:48 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by wishmaster22 » Thu Jan 24, 2008 11:30 pm

1.0.13 
My Sites

Get-Paid-At-Home.com
cliknsav.com
information-about-this.com

row22
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Mon Aug 27, 2007 1:46 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by row22 » Fri Jan 25, 2008 8:44 am

Hm. Sorry, if you have j! 1.0.13 with jacl 1.0.13 I have no idea why it isn't working...  ???

User avatar
LukeDouglas
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 175
Joined: Sat Dec 08, 2007 8:23 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by LukeDouglas » Fri Jan 25, 2008 10:06 pm

In an earlier post, someone recommended deleting the administrator/index2.php file first and then FTP up the hot-fixed administrator/index2.php.

Just a recommendation to everyone, do not delete the administrator/index2.php file.  Instead, rename it to administrator/index2.php.orig and THEN upload the hot-fixed administrator/index2.php.  Why?  Well, if something 'really' went wrong, you could simply delete the hot-fixed administrator/index2.php file, then rename the administrator/index2.php.orig file back to administrator/index2.php and viola, you are back where you started.  You should always use this procedure on any original files that are being replaced.

In my 35 years experience in application development, I can tell you, ALWAYS have a fall-back position in any type of program or file modification.  It has saved my butt more than once.....LOL

ScrapbookSupplies
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Thu Dec 13, 2007 10:48 pm
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by ScrapbookSupplies » Sun Jan 27, 2008 9:36 pm

infograf768 wrote: Nothing will go wrong.
With this fix it's extremely unlikely that you would have a problem, but I would suggest to you that you go into your c-panel with your web host and into your back ups and download a back up of your database.  I would back up every database that you have and do so on a regular basis, as you never know when something may happen.

Then, it's been my experience to back up the config or conguration files.  Between the database and that you can usually restore your site with a new copy of the program if something went really wrong.  I learned a hard way with my phpBB a couple years back.  Others, that are more familiar w/Joomla might recommend backing up other files in addition to these, but the database is 99.9% of it.  Keeping a list of all installed add ons to the core is a good idea as well.

Hope this is of some help,
Jeanne
ScrapbookSuppliesDirect.com

wishmaster22
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Fri Sep 29, 2006 8:48 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by wishmaster22 » Mon Jan 28, 2008 1:23 am

Thanks Jeanne :)
My Sites

Get-Paid-At-Home.com
cliknsav.com
information-about-this.com

wishmaster22
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Fri Sep 29, 2006 8:48 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by wishmaster22 » Mon Jan 28, 2008 4:22 am

Man I cannot get this to work, it still keeps logging me out.

I tried the hot fix that rob had posted awhile back, changing two files. Nothing changed.

This site has been working great for months and now all of a sudden it started kicking me out every time I am in the admin editing something. I click save or apply and blam! I'm kicked out.

Should I re install another working version?

I am soooo frustrated by this.. >:(
My Sites

Get-Paid-At-Home.com
cliknsav.com
information-about-this.com

ScrapbookSupplies
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Thu Dec 13, 2007 10:48 pm
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by ScrapbookSupplies » Mon Jan 28, 2008 4:30 am

wishmaster22 wrote: Man I cannot get this to work, it still keeps logging me out.

I tried the hot fix that rob had posted awhile back, changing two files. Nothing changed.

This site has been working great for months and now all of a sudden it started kicking me out every time I am in the admin editing something. I click save or apply and blam! I'm kicked out.

Should I re install another working version?

I am soooo frustrated by this.. >:(
Wishmaster,
I know this is frustrating.  Have you installed the other one file fix for index2.php?  Or, have you noticed, is it index2.php that you're on when you have the problem?

Jeanne
ScrapbookSuppliesDirect.com

WilliamTully
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Oct 24, 2007 9:23 pm
Location: Ontario, Canada
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by WilliamTully » Mon Jan 28, 2008 4:56 pm

Nope, didn't fix anything.. Ended up going back to 1.1.6 which still works brilliantly.

ScrapbookSupplies
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Thu Dec 13, 2007 10:48 pm
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by ScrapbookSupplies » Mon Jan 28, 2008 5:11 pm

WilliamTully wrote: Nope, didn't fix anything.. Ended up going back to 1.1.6 which still works brilliantly.
I'm sorry to hear that, but glad that you are up and running now! That (I know) is one heck of a relief.  I am on 1.0.13, still learning it and I know I'll have an upgrade before long - eeee!

Thanks for the update.  :)

Best wishes! 
ScrapbookSuppliesDirect.com

WilliamTully
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Oct 24, 2007 9:23 pm
Location: Ontario, Canada
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by WilliamTully » Mon Jan 28, 2008 5:23 pm

ScrapbookSupplies wrote:
WilliamTully wrote: Nope, didn't fix anything.. Ended up going back to 1.1.6 which still works brilliantly.
I'm sorry to hear that, but glad that you are up and running now! That (I know) is one heck of a relief.  I am on 1.0.13, still learning it and I know I'll have an upgrade before long - eeee!
Sorry, my fault. I arrived here for the fix from the JCE (WYSIWYG editor) site.. Their latest version, 1.1.8, triggers the death of the admin session and it was suggested that the fix provided here will solve the issue. For me at least, JCE 1.1.8 + Joomla 1.0.13 + this fix doesn't solve the issue (running Apache, PHP, MySQL - not IIS). Dropping back to JCE 1.1.6 + Joomla 1.0.13 works great in case anyone else is experiencing the same issue.

ScrapbookSupplies
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Thu Dec 13, 2007 10:48 pm
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by ScrapbookSupplies » Mon Jan 28, 2008 5:29 pm

Ok!  Gotcha!

I need to update phpBB someday soon and our Wordpress is outdated again (just installed it) - so I figured this one was too.  That makes me feel better to have some breathing room.  :)
ScrapbookSuppliesDirect.com

wishmaster22
Joomla! Apprentice
Joomla! Apprentice
Posts: 43
Joined: Fri Sep 29, 2006 8:48 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by wishmaster22 » Mon Jan 28, 2008 8:45 pm

I am in index2.php I believe.

Where is the fix for that ? I say robs fix. it was an index.php file and a joomla.php

Thanks again for helping.

ScrapbookSupplies wrote:
wishmaster22 wrote: Man I cannot get this to work, it still keeps logging me out.

I tried the hot fix that rob had posted awhile back, changing two files. Nothing changed.

This site has been working great for months and now all of a sudden it started kicking me out every time I am in the admin editing something. I click save or apply and blam! I'm kicked out.

Should I re install another working version?

I am soooo frustrated by this.. >:(
Wishmaster,
I know this is frustrating.  Have you installed the other one file fix for index2.php?  Or, have you noticed, is it index2.php that you're on when you have the problem?

Jeanne
My Sites

Get-Paid-At-Home.com
cliknsav.com
information-about-this.com

ScrapbookSupplies
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Thu Dec 13, 2007 10:48 pm
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by ScrapbookSupplies » Mon Jan 28, 2008 9:20 pm

wishmaster22 wrote: I am in index2.php I believe.

Where is the fix for that ? I say robs fix. it was an index.php file and a joomla.php

Thanks again for helping.

ScrapbookSupplies wrote:
wishmaster22 wrote: Man I cannot get this to work, it still keeps logging me out.

I tried the hot fix that rob had posted awhile back, changing two files. Nothing changed.

This site has been working great for months and now all of a sudden it started kicking me out every time I am in the admin editing something. I click save or apply and blam! I'm kicked out.

Should I re install another working version?

I am soooo frustrated by this.. >:(
Wishmaster,
I know this is frustrating.  Have you installed the other one file fix for index2.php?  Or, have you noticed, is it index2.php that you're on when you have the problem?

Jeanne
I am attaching the zipped file for fixing the index2.php - I tried to chase down the post for you to send the link for it but I have so many (from fixing my problem originally) that without spending a long time I am not going to find it too easy.  This, along with the two files in this post here fixed my probs though.  Hope it works.  :)
You do not have the required permissions to view the files attached to this post.
ScrapbookSuppliesDirect.com

kayisi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Mon Jan 28, 2008 8:45 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by kayisi » Mon Jan 28, 2008 10:13 pm

I have the same issue and fix files didnt solve the issue.

At first, I received index2.php error. I corrected the file with fix index2.php file. Then I received index.php error. I have changed that too. Nothing has changed. I cannot log in to site.

Please help

ScrapbookSupplies
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Thu Dec 13, 2007 10:48 pm
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by ScrapbookSupplies » Tue Jan 29, 2008 3:39 pm

kayisi wrote: I have the same issue and fix files didnt solve the issue.

At first, I received index2.php error. I corrected the file with fix index2.php file. Then I received index.php error. I have changed that too. Nothing has changed. I cannot log in to site.

Please help
Okay, the main problem is logging in, rather than staying logged in?  When you go to your admin panel how does the addy start?  Is it http:// or https://  and is there a www. or does it start just with your domain name?

And, have you made any changes to your configuration.php file?
ScrapbookSuppliesDirect.com

kayisi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Mon Jan 28, 2008 8:45 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by kayisi » Tue Jan 29, 2008 10:27 pm

[/quote]

Okay, the main problem is logging in, rather than staying logged in?  When you go to your admin panel how does the addy start?  Is it http:// or https://  and is there a www. or does it start just with your domain name?

And, have you made any changes to your configuration.php file?
[/quote]

Thanks for help.

That's right. I cannot log in. It gives an error msg for a sec then kicks me out.
I succeed to get a screen shot of the error message. I have attached the error msg.

The url address is
http://www.thequeenspoker.com/administr ... to%20login

I dont remember making any changes on configuration.php

I found 2 files on this forum to fix the issue. Index.php and index2.php files. I have uploaded both but I cannot log in yet.
What shall I do now?
You do not have the required permissions to view the files attached to this post.

ScrapbookSupplies
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Thu Dec 13, 2007 10:48 pm
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by ScrapbookSupplies » Tue Jan 29, 2008 11:53 pm

kayisi wrote:
Thanks for help.

That's right. I cannot log in. It gives an error msg for a sec then kicks me out.
I succeed to get a screen shot of the error message. I have attached the error msg.

The url address is
http://www.thequeenspoker.com/administr ... to%20login

I dont remember making any changes on configuration.php

I found 2 files on this forum to fix the issue. Index.php and index2.php files. I have uploaded both but I cannot log in yet.
What shall I do now?



Hi Kayisi,

That line deals with the session id, and if I understand the way Joomla works (I am still new with it, but understand the php some) - The problem is within the program and your webhost with the session id's.

In short, you have a problem similar to one I ran into:  run your main site using http://www.mysite.com and your back end from mysite.com (minus the www.) - Hopefully you shouldn't have any more issues, as long as you have installed those two 'fixes' that have been talked about earlier in this post.

*Remember to delete your IE address history & change the addy in your favorites because your existing ones will still point to the admin panel with www. in front.

Please let me know if this does it.  :P
ScrapbookSuppliesDirect.com

kayisi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Mon Jan 28, 2008 8:45 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by kayisi » Wed Jan 30, 2008 1:01 am

[/quote]

Hi Kayisi,

That line deals with the session id, and if I understand the way Joomla works (I am still new with it, but understand the php some) - The problem is within the program and your webhost with the session id's.

In short, you have a problem similar to one I ran into:  run your main site using http://www.mysite.com and your back end from mysite.com (minus the www.) - Hopefully you shouldn't have any more issues, as long as you have installed those two 'fixes' that have been talked about earlier in this post.

*Remember to delete your IE address history & change the addy in your favorites because your existing ones will still point to the admin panel with www. in front.

Please let me know if this does it.  :P
[/quote]

It didnt work and it gave me more error msgs. Please see the attachment.

The url is
http://thequeenspoker.com/administrator ... to%20login
You do not have the required permissions to view the files attached to this post.

ScrapbookSupplies
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Thu Dec 13, 2007 10:48 pm
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by ScrapbookSupplies » Wed Jan 30, 2008 1:56 am

eeeww kayisi,

There is something with the session id's, I do not know if that is a setting that you can control or if it's something with your host.  What I would suggest is copying this error and posting it in the installation part of the Joomla forum.  Because you should access that admin without the http://www., it appears that you're narrowing down the problem. 

I really wish I could answer it cut and dry, it sounded like it was (the way you were accessing it) but without it being my system files and my webhost to 'play with', if it's not a sure thing I best not put my foot in my mouth - BUT I sure would post this error in the installation forum.  You'll probably get a response asap.  ;)
ScrapbookSuppliesDirect.com

kayisi
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Mon Jan 28, 2008 8:45 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by kayisi » Wed Jan 30, 2008 10:24 am

ScrapbookSupplies wrote: eeeww kayisi,

There is something with the session id's, I do not know if that is a setting that you can control or if it's something with your host.  What I would suggest is copying this error and posting it in the installation part of the Joomla forum.  Because you should access that admin without the http://www., it appears that you're narrowing down the problem. 

I really wish I could answer it cut and dry, it sounded like it was (the way you were accessing it) but without it being my system files and my webhost to 'play with', if it's not a sure thing I best not put my foot in my mouth - BUT I sure would post this error in the installation forum.  You'll probably get a response asap.  ;)
Thanks for the reply. Will do,
Regards,

Jagabot
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Wed May 16, 2007 4:33 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by Jagabot » Wed Jan 30, 2008 1:36 pm

This started occurring after a recent Apache security hot-fix. (No idea which one, I don't admin my servers that's what the trained chimpanzees are for.) ;)

For my sites to work in the back end I MUST use http://www.domain.com/administrator and not domain.com/administrator

It's a pain in the ass if/when you don't notice that you've forgotten the WWW

What I did so I don't run into this again on the two servers I've noticed this occurring was: for each account on the server where I'm using Joomla I added a redirect in each site's .htaccess to redirect domain.com to http://www.domain.com

Code: Select all

RewriteCond %{HTTP_HOST} !^www\.domain\.com
RewriteRule ^(.*)$ http://www.domain.com/$1 [R=permanent,L]
or

Code: Select all

Options +FollowSymlinks
RewriteEngine on
rewritecond %{http_host} ^domain.com [nc]
rewriterule ^(.*)$ http://www.domain.com/$1 [r=301,nc]
tip: http://www.webconfs.com/how-to-redirect-a-webpage.php

The two fixes mentioned in this thread don't seem to apply to me at all (I'm using 1.0.13 from a few months ago). But I figured I'd share this in case it helps even one other frustrated person out there.
Last edited by Jagabot on Wed Jan 30, 2008 1:38 pm, edited 1 time in total.


Locked

Return to “Q&T 1.0.x Resolved”