[CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Confirmed bugs that have been Fixed - Joomla 1.0.x



[New Threads cannot be started in this forum]
Locked
pippo
Joomla! Intern
Joomla! Intern
Posts: 75
Joined: Wed Oct 05, 2005 5:10 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by pippo » Fri Aug 24, 2007 9:11 am

RobInk wrote: Hi netshine,
but people might as well download the fix here, instead of us releasing an entire new version.
yes but the people  have to know!!

how can they ,  if  there are no news  ...  in news !!!!

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by Robin » Fri Aug 24, 2007 9:28 am

That is something I can fix, I'll see if we can post something on the blog

pnobrega
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Aug 24, 2007 3:09 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by pnobrega » Fri Aug 24, 2007 5:28 pm

  ???

User avatar
Flavia Silveira
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 194
Joined: Thu Oct 06, 2005 10:30 pm
Location: Toronto, Ontario, Canada
Contact:

Re: [UNDER REVIEW] Joomla! 1.0.13 Admin session dies for certain $task values

Post by Flavia Silveira » Sat Aug 25, 2007 1:07 pm

RobS wrote: Hi all,

I'm sorry that I have taken so long to get back here but I have just been really busy and dealing with life.  I went through and tried to rework the problem so it doesn't have this problem and I think I found a way to deal with it that it is just as secure and possibly faster than the previous fix that was made.  I have attached a zip file to this post with two files in it.  The first file is index.php should replace administrator/index.php and joomla.php should replace includes/joomla.php  When you put these files in place, you will probably get logged out but once you get logged back in, the problem will hopefully be fixed.  Please do not test this on live sites though, I cannot guarantee that it works as I am working on a laptop and only have one environment to test against.
Got your fix and although it has solved other issues it has caused some more....after uploading the files I now get a completely blank screen when I try to edit or add forums on Fireboard.

FayeC
Flavia Silveira
Former Joomla! Bug Squad, Joomla! Evangelist
http://FlahDesign.com | http://twitter.com/FlahDesign

okhayat
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Dec 08, 2006 2:19 pm
Location: Kuwait
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by okhayat » Sat Aug 25, 2007 7:15 pm

I had this issue only when using JoomFish. I've used the patch from VirtueMart and now things are fine :) thanks alot!

pnobrega
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Aug 24, 2007 3:09 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by pnobrega » Sun Aug 26, 2007 12:38 am

and my problem? can't anyone help me?  ??? :-\

bipula
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Tue Aug 14, 2007 4:04 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by bipula » Sun Aug 26, 2007 9:54 am

hello
I am new to joomla and I came across this thread. Well I have downloaded the joomla! 1.0.13 and thats all that I have...I have begun working on joomla with this version. I find no problem regarding session till now, can you explain to me if I may i have any problem using this version...do I need any patch in future...what problems may I stumble through....???
By the conversation I could not figure out that is the patch needed only at the time of upgrade???

I need to work on a project where my client's site is built on joomla!1.0.11 and I have to upgrade that to joomla! 1.0.13. can you provide me details of how to upgrade??..the site even uses some components like akobook, letterman, googlemap etc

okhayat
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Dec 08, 2006 2:19 pm
Location: Kuwait
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by okhayat » Sun Aug 26, 2007 10:26 am

Most probably you'll not face any problem if you work with the main Joomla components and modules. This Session problem however will arise when you start using some add-ons like JoomFish (multilingual component) or VirtueMart (e-commerce). In that case, you'll need to apply the patch.
Now, to upgrade from one version to another, you'll just need to get the patch from the download site: http://joomlacode.org/gf/project/joomla/frs/ for example, if you're upgrading from 1.0.11 to 1.0.13 you'd get the file Joomla_1.0.11_to_1.0.13-Stable-Patch_Package.zip and extract its contents within your root folder.

Hope this helps!

DoctorMicro
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Wed Aug 30, 2006 11:12 pm
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by DoctorMicro » Mon Aug 27, 2007 3:36 am

Sobi 2 Business now working with categories again.

Thanks
;D

baschwar
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Sep 25, 2005 4:17 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by baschwar » Mon Aug 27, 2007 1:45 pm

okhayat wrote: Most probably you'll not face any problem if you work with the main Joomla components and modules. This Session problem however will arise when you start using some add-ons like JoomFish (multilingual component) or VirtueMart (e-commerce). In that case, you'll need to apply the patch.
Now, to upgrade from one version to another, you'll just need to get the patch from the download site: http://joomlacode.org/gf/project/joomla/frs/ for example, if you're upgrading from 1.0.11 to 1.0.13 you'd get the file Joomla_1.0.11_to_1.0.13-Stable-Patch_Package.zip and extract its contents within your root folder.

Hope this helps!
I'm new to Joomla as well and I have this same problem using Apache and do not have JoomFish or VirtueMart installed. Should I install the patch? Wouldn't this already be in the new install of 1.0.13 I did?

okhayat
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Dec 08, 2006 2:19 pm
Location: Kuwait
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by okhayat » Mon Aug 27, 2007 4:31 pm

No, it's not in 1.0.13, so you should patch it if you're having this problem. However, you'd better keep a copy of index2.php in administrator folder in case this doesn't solve your problem.

Sle@per
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Wed Aug 09, 2006 9:08 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by Sle@per » Tue Aug 28, 2007 10:11 am

Hi all,

It's late and I can't think straight.

All I know is this. On my install ( to 1.0.13 ) I get logged out when I click on anything from within the admin section.

So this is what I have done.

I copied the updated index2.php file over to my /administrator/ directory.
I try logging in and no change. Still being logged out when I try to click on anything from within the site.

So then I copy the old 1.0.12 joomla.php file back to the /includes/ directory and I can click on items but I cannot actually use any of the buttons.

I have no idea what I am doing wrong.

Here is some info from my htacccess file. (why i am posting this I have no idea)

php_flag magic_quotes_gpc on
php_flag register_globals off
Order allow,deny
Allow from all
Redirect shop http://www.belton.co.nz/index.php?optio ... &Itemid=44

Now I really have no idea how to proceed. I could not find RobS link to the "fix" he was talking about.

Am I going nuts? Can someone please post step by step what I am supposed to do to resolve this issue please please please.

wwwTHOMASBAUERcc
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Tue Aug 28, 2007 2:44 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by wwwTHOMASBAUERcc » Tue Aug 28, 2007 3:52 pm

i had uploaded the 2 data's but i have also the same problem...???

Sle@per
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Wed Aug 09, 2006 9:08 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by Sle@per » Tue Aug 28, 2007 7:56 pm

WHERE .. are the files that are spoken off in this thread?

User avatar
soeren
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 111
Joined: Mon Aug 29, 2005 10:58 am
Location: Germany
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by soeren » Tue Aug 28, 2007 8:00 pm

Hi,
Sle@per wrote: WHERE .. are the files that are spoken off in this thread?
They can be found in this message:
http://forum.joomla.org/index.php/topic ... #msg943504

Currently there's no other official download available.

ciao, Sören

User avatar
djacoby
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Tue May 08, 2007 1:46 pm
Location: Virginia USA
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by djacoby » Tue Aug 28, 2007 9:42 pm

Sle@per wrote: WHERE .. are the files that are spoken off in this thread?
They should be on page 3. Its a ZIP file posted by RobS. Whooops! soeren beat me to it.

Thanks for the fix, Rob. Solved all my problems I was having with the "Attend Event" component. Cheers,

D

User avatar
Shinu
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Aug 29, 2007 9:21 am
Location: Poland

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by Shinu » Wed Aug 29, 2007 10:04 am

Hi!
I dont'n read all post in this topic...

anyway, I find this hotfix to this problem:
http://virtuemart.net/index.php?option= ... ad&gid=371

/administrator/index2.php

Code: Select all

BEFORE

doGzip();
// if task action is 'save' or 'apply' redo session check
if ( $task == 'save' || $task == 'apply' ) {
	$mainframe->initSessionAdmin( $option, '' );
}


AFTER

// if task action is 'save' or 'apply' redo session check
if ( $task == 'save' || $task == 'apply' ) {
	$mainframe->initSessionAdmin( $option, '' );
}
doGzip();
and it works in my Joomla 1.0.13 IE pl

User avatar
Jenny
Joomla! Champion
Joomla! Champion
Posts: 6237
Joined: Sun Aug 21, 2005 2:25 pm
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by Jenny » Wed Aug 29, 2007 10:21 am

Can someone tell me what lines are changed from the original 1.0.13 files and the fix files?  I don't have a compare/diff prog.  I need to patch the jaclplus files that hack the these two files and need replace or add the actual lines of code. 
Co-author of the Official Joomla! Book http://officialjoomlabook.com
Marpo Multimedia http://marpomultimedia.com

Echooff3
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Aug 01, 2007 2:38 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by Echooff3 » Wed Aug 29, 2007 1:06 pm

I applied the hotfix that moves the doGzip(); function and I still am getting kicked out. Any other suggestions?

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by Robin » Wed Aug 29, 2007 5:33 pm

Jennifer,

Have a look at:

http://joomlacode.org/gf/project/joomla ... 78&r2=8388

and

http://joomlacode.org/gf/project/joomla ... 78&r2=8388

Those are the diff views for both fixed files.

User avatar
Shinu
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Wed Aug 29, 2007 9:21 am
Location: Poland

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by Shinu » Wed Aug 29, 2007 6:50 pm

Echooff3 wrote: I applied the hotfix that moves the doGzip(); function and I still am getting kicked out. Any other suggestions?
Hmm, try this:
http://virtuemart.net/index.php?option= ... &Itemid=57

neiruq
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Aug 29, 2007 7:46 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by neiruq » Wed Aug 29, 2007 9:11 pm

Hi, i was reading the post, I'm a newbie but i have install version 1.0.13 and was working fine but when a install Xplorer extension and i wanted to see the extension it asked about the fix of this topic, i install the fix (replace the files joomla and index2) and then i say yes in the pop up screen, but it logs me out i can enter my admin panel but when a want the make same process it again log me ...  ???

Then i install joomlaXplorer but it has 2 errors, sometime about a directory not created with my website name "c:/domain/my_domain_name", if somebody can help o give a hint what to do i really appreciate  ;)

Thanks
neiruq

User avatar
KobraSoft
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Aug 29, 2007 10:48 pm
Location: México
Contact:

Re: Joomla! 1.0.13: Admin session dies for certain $task values on IIS

Post by KobraSoft » Wed Aug 29, 2007 10:53 pm

Geraint wrote: Some insights (and a fix?)

The problem arises if you have a component that doesn't use a mosRedirect at the end of processing a 'save' or 'apply' task.  You can simulate the problem by commenting out the mosRedirct at line 789 in admin.content.php and then saving some content.

This is the warning you get:

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at C:\Documents and Settings\Geraint\Documents\joomlacode\Joomla1.0.x\includes\joomla.php:4145) in C:\Documents and Settings\Geraint\Documents\joomlacode\Joomla1.0.x\includes\joomla.php on line 800

This is caused by an attempt to set the session cookie (in initSessionAdmin) after the headers have already been sent via the doGzip() at the end of index2.php.  If you put the doGzip right at the end of the file (AFTER the call to $mainframe->initSessionAdmin( $option, '' );) then everything works.

Geraint
Thx!! This worked great for me.
I have virtuemart installed in my website, and I recently updated joomla to version 1.0.13.
Since then, everytime I modified any content in virtuemart component as admin I got kicked out.
I changed the doGzip(); at the end of index2.php and everything worked just fine!!

Thanks man! I owe you! ;D

deleted user

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by deleted user » Thu Aug 30, 2007 2:11 am

Thanks much for this super fix, Team Joomla rox!!!

I am blown away by the convenience of installing the latest stable release, in some cases via the ever-handy fantastico, and after only a month or so discovering this thread here later on.

I thought that stack of error messages and getting dumped from the backend was was a feature--that's what I told all my clients when they saw it--but OK--now I'm glad to know...

I also enjoy the nostalgia of jumping from thread link to thread link, remembering I have to log in and finding the official fix file patch thing prominently displayed here. It reminds me of the fun I had in the past negotiated Turkish 3PD extension developer sites written in a language my browser does not support.

This is why I recommend joomla to all my colleagues and clients. First rate!

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1422
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by fotisevangelou » Thu Aug 30, 2007 12:01 pm

RobInk wrote: That is something I can fix, I'll see if we can post something on the blog
IF you have 200.000 downloads so far, it shouldn't be an issue releasing a "silent" update, like a rev.1 to 1.0.13 and incorporate the patch. Cause in a month you're gonna have an additional 200.000 downloads, so it makes sense. Posting on the joomla.org is not the best thing to do in my opinion. The fact that there are only 4-5 pages with comments, does not mean that only these people dealt with that issue. Others did too and they probably reverted to 1.0.12. Or, to be honest, you know that many do not upgrade instantly on every new release... ;)

Plus, I never understood why you did not do the same thing with j1.0.11 and the mambot manager problem. It's like the distro is locked. How many people need to fix this? Sounds like the old joke... How many joomla devs are needed to fix the light bulb...

Come on j team... There's life after 1.5 you know. ;)
Fotis Evangelou / https://www.joomlaworks.net

User avatar
7echno7im
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Wed Dec 27, 2006 2:18 am
Location: Midwest, USA
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by 7echno7im » Thu Aug 30, 2007 1:06 pm

can someone repost the fix.zip, it has disappeared.... or my eyes are going bad.
===========================================

http://www.techtronic.us

===========================================

User avatar
7echno7im
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Wed Dec 27, 2006 2:18 am
Location: Midwest, USA
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by 7echno7im » Thu Aug 30, 2007 1:23 pm

nm, I found it.... I guess I had to be logged in to see it  :'(

confirmed to fix eXtplorer_2.0.0_RC1 on joomla 1.0.13
===========================================

http://www.techtronic.us

===========================================

AmyStephen
Joomla! Champion
Joomla! Champion
Posts: 7056
Joined: Wed Nov 22, 2006 3:35 pm
Location: Nebraska
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by AmyStephen » Thu Aug 30, 2007 1:35 pm

fotisevangelou wrote: IF you have 200.000 downloads so far, it shouldn't be an issue releasing a "silent" update, like a rev.1 to 1.0.13 and incorporate the patch. Cause in a month you're gonna have an additional 200.000 downloads, so it makes sense.
I don't disagree with that. But, then I start thinking that a release signals something to everyone. I imagine it is an industry standard to never change the distribution. And, if that is true, then we should comply to those expectations.
fotisevangelou wrote:Sounds like the old joke... How many joomla devs are needed to fix the light bulb...
Fotis - why be unkind? One one hand, you do seem to recognize the efforts of the developers are broadly appreciated worldwide as evidenced by the number of downloads, month after month, of their work. I guess if they are struggling with light bulb replacement, I am not overly concerned. Heck, I could help with that! We just don't need those comments, Fotis.  :P

Regardless, I am pleased to "see" you and I hope you are well.
Amy :)

User avatar
fire2006
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 111
Joined: Tue Jun 06, 2006 7:46 am
Location: Vancouver
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by fire2006 » Thu Aug 30, 2007 4:05 pm

If PHP can not write to the directory where sessions are supposed to be saved you will not be able to login.  Use google to find out more information about how to fix the problem.  This is not a Joomla! problem, this is a problem with your environment/setup.
Hi there, how can I find out where the session save path is, and how can I "clean up"?
I am having problems with invallid session too.. please advise
thanks!
Paul Preibisch - Educational Technologist
Fire Centaur - English Village - Secondlife
http://slurl.com/secondlife/English%20V ... %20Village&

okhayat
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Fri Dec 08, 2006 2:19 pm
Location: Kuwait
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by okhayat » Fri Aug 31, 2007 1:20 pm

fire2006 wrote:
Hi there, how can I find out where the session save path is, and how can I "clean up"?
I am having problems with invallid session too.. please advise
thanks!
You can find this out in one of two ways:
1. Using Joomla admin page, goto System -> System Info -> Permissions (tab) and scroll to the bottom of the page. You'll find 'Session Directory' and something like / or /home/user and to the write if it is Writable or Unwritable
2. In the same previous screen, click on PHP Info or create a PHP file with the following code and place in some where on your server:

Code: Select all

<?php phpinfo(); ?>
With looking at the second way, you should find a line under the Session title like:

Code: Select all

Session.save_path
which could show no value or the place where your PHP Session is saved.
What I've noticed though (from my little experience with PHP applications) is that it's not always an issue to set the Session.save_path variable for your sessions to work fine, as the default value might be suitable in most cases.


Locked

Return to “Q&T 1.0.x Resolved”