[CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Confirmed bugs that have been Fixed - Joomla 1.0.x



[New Threads cannot be started in this forum]
Locked
itlionat
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Dec 10, 2007 9:55 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by itlionat » Mon Dec 10, 2007 7:04 pm

Hi again,
I have many Joomla sites in different versions on my server and it would be very painful to patch now all sites and the main point it worked before.
I tried the latest patch on the Joomla 1.0.13 but I still had problems even with different settings.
However I played around now with the session.save_path and the last time I even removed totally the value (also no path at all) and I got this error that session is not writable.
Then I added again the value '/tmp' and I got then a incorrect username or password but on my unpatched Joomla1.5 I could surprisingly log in  :laugh: So i removed the patch from my 1.0.13 version and now I can login in all my sites without any problem.
I guess my problem was that the cPanel easy apache build script didn't saved the php.ini properly. Maybe wrong charset or the session values had some additional characters that were not visible. So should you have cPanel and your webhost just upgraded and your site worked before, then ask your webhost to retype the session values again.
I'm sooo happy  :D that everything works fine without any patch!
Last edited by itlionat on Mon Dec 10, 2007 7:07 pm, edited 1 time in total.

ulpo
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Dec 02, 2007 12:08 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by ulpo » Tue Dec 11, 2007 6:47 am

Shinu wrote: Hi!
I dont'n read all post in this topic...

anyway, I find this hotfix to this problem:
http://virtuemart.net/index.php?option= ... ad&gid=371

/administrator/index2.php

Code: Select all

BEFORE

doGzip();
// if task action is 'save' or 'apply' redo session check
if ( $task == 'save' || $task == 'apply' ) {
	$mainframe->initSessionAdmin( $option, '' );
}


AFTER

// if task action is 'save' or 'apply' redo session check
if ( $task == 'save' || $task == 'apply' ) {
	$mainframe->initSessionAdmin( $option, '' );
}
doGzip();
and it works in my Joomla 1.0.13 IE pl
Thank you so much, this little change in the index2.php has solved everything. After getting nuts almost you have saved my day and work.
It seemed to be that there was nothing which worked fo me with joomla 1.13 and Joomfish, but finally you found a simple way to get it done....
Thx again

ulpo

User avatar
steve2
Joomla! Intern
Joomla! Intern
Posts: 96
Joined: Tue Dec 20, 2005 12:52 am
Location: New Zealand
Contact:

Re: [UNDER REVIEW] Joomla! 1.0.13 Admin session dies for certain $task values

Post by steve2 » Tue Dec 11, 2007 8:42 am

RobS wrote: Hi all,

I'm sorry that I have taken so long to get back here but I have just been really busy and dealing with life.  I went through and tried to rework the problem so it doesn't have this problem and I think I found a way to deal with it that it is just as secure and possibly faster than the previous fix that was made.  I have attached a zip file to this post with two files in it.  The first file is index.php should replace administrator/index.php and joomla.php should replace includes/joomla.php  When you put these files in place, you will probably get logged out but once you get logged back in, the problem will hopefully be fixed.  Please do not test this on live sites though, I cannot guarantee that it works as I am working on a laptop and only have one environment to test against.
Appreciate your hard work guys, this fixed it for me...
Godfuel Media Ministries - www.godfuel.org
Web Dev - http://www.web.godfuel.net

User avatar
bulesz
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Mon Jul 02, 2007 10:28 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by bulesz » Wed Dec 12, 2007 5:57 am

Thansk for you work guyz!

I cant believe this, how could release it without this fix? I means without this its completeley useless! cant login etc...

Wasnt any test of it???? Strange!

joeleal
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Mon Mar 12, 2007 1:13 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by joeleal » Fri Dec 14, 2007 4:01 pm

Hi There,

Can you please tell me where the zip file (fix) for this problem is?

joeleal
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Mon Mar 12, 2007 1:13 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by joeleal » Fri Dec 14, 2007 4:04 pm

[quote="joeleal "]
Hi There,

Can you please tell me where the zip file (fix) for this problem is?


Sorry, I found it. Thanks

joehome
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Dec 16, 2007 8:41 pm

Re: [UNDER REVIEW] Joomla! 1.0.13 Admin session dies for certain $task values

Post by joehome » Sun Dec 16, 2007 9:16 pm

Nice! Thanks for this fix. it worked for me. Really, thank you sooooooo much.
-Joe
RobS wrote: Hi all,

I'm sorry that I have taken so long to get back here but I have just been really busy and dealing with life.  I went through and tried to rework the problem so it doesn't have this problem and I think I found a way to deal with it that it is just as secure and possibly faster than the previous fix that was made.  I have attached a zip file to this post with two files in it.  The first file is index.php should replace administrator/index.php and joomla.php should replace includes/joomla.php  When you put these files in place, you will probably get logged out but once you get logged back in, the problem will hopefully be fixed.  Please do not test this on live sites though, I cannot guarantee that it works as I am working on a laptop and only have one environment to test against.

User avatar
kgonyea
Joomla! Explorer
Joomla! Explorer
Posts: 398
Joined: Tue Dec 19, 2006 6:37 pm
Location: San Diego, CA
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by kgonyea » Tue Dec 18, 2007 3:40 pm

RobS wrote: For the people that are getting the "Invalid Session" message, could you please try to clear your browser cookies or try a different browser if you have access to one.

Thanks.
I was getting the Invalid Session error, until I found this:

http://tech.amikelive.com/node-41/compr ... omla-1013/

That solved the problem for me.  It is a combo fix for several issues discussed in this thread.  I'm sure it will be useful for others as well.

HansLee
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Jul 15, 2006 1:29 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by HansLee » Wed Dec 19, 2007 12:43 pm

alright.. I cant find the hotfix.. where can I find it?

User avatar
kgonyea
Joomla! Explorer
Joomla! Explorer
Posts: 398
Joined: Tue Dec 19, 2006 6:37 pm
Location: San Diego, CA
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by kgonyea » Wed Dec 19, 2007 2:41 pm

HansLee wrote: alright.. I cant find the hotfix.. where can I find it?
Here's a link to the patch I used:

http://dev.amikelive.com/joomla1/compon ... info/id,3/

And instructions from the link from my last post...

How to invoke this fix:

  1. Backup your joomla files
  2. Copy the files in the zip into their respective folders
  3. Create a folder named session in your joomla installation directory (the directory where index.php exists)
  4. Give Apache (or php handler) user permission to write into the directory (you can chmod the directory to 777 or alike)
  5. Test logging into joomla admin panel.

DaFish
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Aug 25, 2006 4:06 am

Re: [UNDER REVIEW] Joomla! 1.0.13 Admin session dies for certain $task values

Post by DaFish » Thu Dec 20, 2007 9:54 am

RobS wrote: Hi all,

I'm sorry that I have taken so long to get back here but I have just been really busy and dealing with life.  I went through and tried to rework the problem so it doesn't have this problem and I think I found a way to deal with it that it is just as secure and possibly faster than the previous fix that was made.  I have attached a zip file to this post with two files in it.  The first file is index.php should replace administrator/index.php and joomla.php should replace includes/joomla.php  When you put these files in place, you will probably get logged out but once you get logged back in, the problem will hopefully be fixed.  Please do not test this on live sites though, I cannot guarantee that it works as I am working on a laptop and only have one environment to test against.
RobS... my hero.... struggled for days with this... seems all good now, thank you!

olivewhite
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Sep 06, 2007 8:19 am

Re: HotFix for the admin session bug

Post by olivewhite » Thu Dec 20, 2007 2:42 pm

soeren wrote: Well,
VirtueMart is also affected by this bug.
The problem is indeed a wrong order of the calls to initSessionAdmin and doGzip at the end of the file /administrator/index2.php.
If we change

BEFORE

Code: Select all

103		doGzip();
104		
105		// if task action is 'save' or 'apply' redo session check
106		if ( $task == 'save' || $task == 'apply' ) {
107			$mainframe->initSessionAdmin( $option, '' );
108		}
to

Code: Select all

102		// if task action is 'save' or 'apply' redo session check
103		if ( $task == 'save' || $task == 'apply' ) {
104			$mainframe->initSessionAdmin( $option, '' );
105		}
106		doGzip();
the problem is gone.

I have posted a Hotfix for Joomla! 1.0.13 on the VirtueMart Homepage.
Feel free to try it. It just contains the updated index2.php file.

ciao, Sören
Sincerely thank you so much  :laugh:

User avatar
092098jvm
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 230
Joined: Wed Aug 09, 2006 5:59 pm
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by 092098jvm » Fri Dec 21, 2007 11:24 pm

I'm having the same issue with JoomlaPack. The fix above didn't fix though. Is there another problem maybe or a different patch?
Last edited by 092098jvm on Fri Dec 21, 2007 11:35 pm, edited 1 time in total.

ScrapbookSupplies
Joomla! Intern
Joomla! Intern
Posts: 61
Joined: Thu Dec 13, 2007 10:48 pm
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by ScrapbookSupplies » Sat Dec 22, 2007 1:08 am

:o FIXED MY PROBLEMS!!!    ;D ;D ;D ;D ;D
ScrapbookSuppliesDirect.com

jigoong
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Dec 23, 2007 5:34 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by jigoong » Sun Dec 23, 2007 6:07 pm

Thank you for every solutions!  :)

RZ112
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Tue Dec 25, 2007 10:22 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by RZ112 » Tue Dec 25, 2007 11:25 am

I did both proposed fixes.
No change, the problem remains, also after removing the cookies.
How can I remove eXtplorer?

User avatar
kgonyea
Joomla! Explorer
Joomla! Explorer
Posts: 398
Joined: Tue Dec 19, 2006 6:37 pm
Location: San Diego, CA
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by kgonyea » Fri Dec 28, 2007 12:20 am

RZ112 wrote: I did both proposed fixes.
No change, the problem remains, also after removing the cookies.
How can I remove eXtplorer?
You tried the fix here and no luck?

http://forum.joomla.org/index.php/topic ... msg1122800

And are you getting the admin login loop with the invalid session error?  Are there any other errors or symptoms?

You should be able to uninstall extplorer via Installers>Components > select the component, and the uninstall link should be at the top of the page.

User avatar
webasylum
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Dec 31, 2007 8:13 am
Location: LA

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by webasylum » Mon Dec 31, 2007 8:37 am

RobS,

JACL Modifies the existing Joomla.php file in the includes folder.

Does the re-worked Joomla.php file in the includes file cause problems with JACL ? if so, what lines of code do I have to update ?

Many thanks,

Webasylum.
Live Life on Purpose!

User avatar
muddauber
Joomla! Ace
Joomla! Ace
Posts: 1518
Joined: Thu Jun 08, 2006 11:26 pm

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by muddauber » Wed Jan 02, 2008 9:27 pm

Could someone explain the proper way to install this hotfix?

User avatar
greenarrow
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 196
Joined: Fri Aug 24, 2007 5:02 am

Where Can i find Hotfix for joomla

Post by greenarrow » Thu Jan 03, 2008 6:56 am

I need hotfix to run component eXtplorer. can anyone tell me where can i find HOTFIX ?

User avatar
webasylum
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Dec 31, 2007 8:13 am
Location: LA

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by webasylum » Thu Jan 03, 2008 9:36 am

The HotFix appears as a download link after you have registered on this Forum.  ;)
Live Life on Purpose!

User avatar
webasylum
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Dec 31, 2007 8:13 am
Location: LA

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by webasylum » Thu Jan 03, 2008 9:45 am

webasylum wrote: RobS,

JACL Modifies the existing Joomla.php file in the includes folder.

Does the re-worked Joomla.php file in the includes file cause problems with JACL ? if so, what lines of code do I have to update ?

Many thanks,

Webasylum.
As a foot note, I noticed that when JACL is installed - it provides clear statements of where it has hacked the Joomla.php file !  Excellent, so using any text editor it was easy to search through the working JACL'd Joomla.php file for its hack entries and copy those pieces of code over into the matching code points in the Hotfix's Joomla.php file.  Note! Always worth saving copies of existing files before merging such pieces of code so you can get back to the start if you mess things up!

Now I have the Hotfix working with eXtplorer and JACL as it should I think inside Joomla. :P
Live Life on Purpose!

User avatar
greenarrow
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 196
Joined: Fri Aug 24, 2007 5:02 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by greenarrow » Thu Jan 03, 2008 9:56 am

:) Thanks Bro But where Can i Find it Now ? Help Needed

katerina
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Dec 21, 2007 8:33 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by katerina » Thu Jan 03, 2008 10:10 am

Hi,
I have applied the fix and now I can log in the back end. But I find out that it is possible to activate the front end by
editing Joomla/components/com_extplorer/configuration.jx.php

Then I added it to the main menu and when I click on the link, I have a blanc page.
I cleared cache and tried another browser (IE instead of firefox).
I tried the other fix (which shifts the position of doGzip(); in index2.php.
Nothing worked.

I don't know if it is the bug or I have misconfigured the front end. Is there something else I could do?

User avatar
webasylum
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Dec 31, 2007 8:13 am
Location: LA

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by webasylum » Thu Jan 03, 2008 10:22 am

katerina wrote: Hi,
I have applied the fix and now I can log in the back end. But I find out that it is possible to activate the front end by
editing Joomla/components/com_extplorer/configuration.jx.php

Then I added it to the main menu and when I click on the link, I have a blanc page.
I cleared cache and tried another browser (IE instead of firefox).
I tried the other fix (which shifts the position of doGzip(); in index2.php.
Nothing worked.

I don't know if it is the bug or I have misconfigured the front end. Is there something else I could do?
Katerina....

Its not a good idea to be trying to get Extlorer working from the front end menu !!??!??  this poses a severe security risk as the public could rewrite your php files etc etc
Live Life on Purpose!

User avatar
webasylum
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Dec 31, 2007 8:13 am
Location: LA

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by webasylum » Thu Jan 03, 2008 10:36 am

greenarrow wrote: :) Thanks Bro But where Can i Find it Now ? Help Needed
http://forum.joomla.org/index.php/topic ... .html  - Its part of The first post a little zip file icon and link - but it clearly states that you have to be logged in to see the download icon ! ???
Live Life on Purpose!

katerina
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Dec 21, 2007 8:33 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by katerina » Thu Jan 03, 2008 10:39 am

What I really want is to display tree structure of some data and I thought it could be the way to do it.
Is there any other way?

User avatar
webasylum
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Mon Dec 31, 2007 8:13 am
Location: LA

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by webasylum » Thu Jan 03, 2008 11:16 am

katerina wrote: What I really want is to display tree structure of some data and I thought it could be the way to do it.
Is there any other way?
Good Question !  Not sure... will have a look around, but such a question is outside this particular threads scope.
Post a fresh question under General Questions section of the Forum and Be specific with the kind of information you wish to display within the front end (whether it be files, images, sitemap, etc) and I'm sure you will end up with the answer. :)
Live Life on Purpose!

User avatar
greenarrow
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 196
Joined: Fri Aug 24, 2007 5:02 am

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by greenarrow » Thu Jan 03, 2008 11:34 am

Help me to find hotfix anyone :( :( :( :(

User avatar
howdwegethere
Joomla! Intern
Joomla! Intern
Posts: 66
Joined: Tue Aug 23, 2005 7:34 am
Location: Brisbane, Australia
Contact:

Re: [CONFIRMED+FIX] Joomla! 1.0.13 Admin session dies for certain $task values

Post by howdwegethere » Thu Jan 03, 2008 10:41 pm

There is a link to a post with the fix and instructions to apply it just three posts above yours.
webasylum wrote:
greenarrow wrote: :) Thanks Bro But where Can i Find it Now ? Help Needed
http://forum.joomla.org/index.php/topic ... .html  - Its part of The first post a little zip file icon and link - but it clearly states that you have to be logged in to see the download icon ! ???


Locked

Return to “Q&T 1.0.x Resolved”