Page 1 of 3

Tagging the extensions as 1.0, 1.5 Legacy, Native or Full

Posted: Fri Jul 27, 2007 2:37 am
by andybezara
Hello

I want to suggest the following:

Is there any way to create a menu in extensions home page to choose the extension related with one of the joomla versions?

I suggest

Extensions for Joomla 1.0.x. Click here
Extensions for Joomla 1.5.x. Click here
Extension for both version. Click here

The same things with templates

It is a waste of time to looking for extension that are not compatible with a specific version, especially for 1.5

Andy

Re: Extension for 1.5 and for 1.0.x - logical order

Posted: Fri Jul 27, 2007 8:52 am
by Tonie
It will be easier to select extensions based on Joomla! version in the future.

Re: Extension for 1.5 and for 1.0.x - logical order

Posted: Mon Jul 30, 2007 11:04 pm
by Phi|
I have been looking for the same thing. At the moment its not even possible to see which version i supported by the extension, which I think would be a great improvement if there would be ;)

Re: Extension for 1.5 and for 1.0.x - logical order

Posted: Thu Aug 02, 2007 5:39 am
by Maury
This would be of great help. 1.0.x does not function properly on Yahoo based servers (permission issues, it seems), but 1.5 does. Desperately need an HTML site module to allow display of links ads, etc.

Any directory for 1.5 based extensions? Anywhere?...

Re: Extension for 1.5 and for 1.0.x - logical order

Posted: Sat Aug 11, 2007 12:17 pm
by Aegeus
The reason I have visited this forum was to suggest the same idea.

When I go to the extensions section, I want to see possible add ons for my site running on 1.5RC1. If I use the advanced search and choose 1.5 only, the coming results are too many and complicated to surf in.

I think the main concern for dividing the extensions should be the version numbers.

Regards.

Re: Extension for 1.5 and for 1.0.x - logical order

Posted: Sat Aug 11, 2007 1:21 pm
by Maury
Yes, this is server platform specific, but one of the main reasons those that use Yahoo for hosting need to differentiate between 1.5 and earlier versions deals with nasty permissions issues that have come up once selecting the Legacy plug-in. Plug-ins that run natively is about all I'll risk at this point (the permissions issues can get users into a state of being unable to access the Admin panel and only a full-blown re-install will rectify).

So, please, please, please... The need for a plug-ins library for 1.5 native would be most helpful.

Thanks,
Maury Brown
The Business of Sports Network

Re: Extension for 1.5 and for 1.0.x - logical order

Posted: Sat Aug 11, 2007 3:22 pm
by LorenzoG
Hi Maury,

We plan to differ between latest 1.0.x, 1.5 legacy and 1.5 native. IE you should in a close future be able to see which extensions that run in 1.5 legacy and which ones run 1.5 native.

I hope it helps.

Re: Extension for 1.5 and for 1.0.x - logical order

Posted: Mon Sep 24, 2007 8:39 am
by rogerco
Any news on When we might see this - it is becoming an increasing problem as time goes by.
RogerCO

Re: Extension for 1.5 and for 1.0.x - logical order

Posted: Sat Oct 06, 2007 9:44 pm
by trouble
Agreed.
Release candidate 3 is out the door, and I guess the final release of 1.5 is in sight, but the situation with 1.5 native extensions is still a real let down to the user-friendly Joomla! 1.5 imho.

Re: Extension for 1.5 and for 1.0.x - logical order

Posted: Tue Oct 23, 2007 12:05 pm
by dcbour
On the short term, would it at least be possible to display an icon on the listing page of extensions rather than having to open each one to see which it supports.  I would hope such a quick change wouldn't be hard to the web.
Also, as I see it, from my newbie perspective, there are only two categories right now...1.0 and 1.5 rather than 1.0, 1.5 legacy and 1.5 native support.  I suspect this would also be a quick database category add, add a new icon symbol and then faster to submit. 
More of us are gearing up at 1.5 level rather than changing over sites done a 1.0 and the current process as some have pointed out is not nearly as user friendly as the rest of Joomla is showing itself to be.

Re: Extension for 1.5 and for 1.0.x - logical order

Posted: Fri Nov 09, 2007 11:09 am
by melwade
This is really important!  It's been almost a month since the "very soon" statement.  Even if the version displayed on the page that lists the extension so I don't have to drill down to the details to know if the extension will work for me.  The current setup is a real waste of time for the end user.

Re: Extension for 1.5 and for 1.0.x - logical order

Posted: Fri Nov 09, 2007 11:39 am
by Tonie
It's running on the sandbox now, and we're testing it before going public.

Re: Extension for 1.5 and for 1.0.x - logical order

Posted: Fri Nov 09, 2007 5:42 pm
by melwade
Thanks.  The sooner the better...  The current system is driving me nuts trying to find 1.5 extensions.  I'm about ready to go hang out with the squirels!

This is how i wish the Extensions site looked...

Posted: Wed Dec 19, 2007 9:43 pm
by rw1
Hello,

I've just upgraded to 1.5 and trying to find extensions that go with it is proving quite a bother. 

I've also thought for a while that there is too much clicking involved in the Extensions site at the moment, when i go there, i pretty much want to click through to the demo straight away. 

So two things i would like to see straight up are Compatibility and a link to a Demo. 

Attached is screeny of a layout which could be achieved quite easily i think...

What do people think about this idea?

Re: This is how i wish the Extensions site looked...

Posted: Wed Dec 19, 2007 9:45 pm
by boltzy99
I agree there is too much extra clicking going on in the current extensions page. Good thoughts.

Re: This is how i wish the Extensions site looked...

Posted: Wed Dec 19, 2007 11:05 pm
by Jenny
I am going to move this to the Extensions site forum.

Re: This is how i wish the Extensions site looked...

Posted: Wed Dec 19, 2007 11:41 pm
by ot2sen
Hi rw1,

Thanks for sharing your ideas with us. Always welcomed.
We agree that currently there is too much clicking when it comes to learning about compatibility.
This will be changed at next update of JED (We have this working in sandbox already )

Not sure about the demo and other detail view links in general view. Could get too crowdy up front.

Re: This is how i wish the Extensions site looked...

Posted: Wed Dec 19, 2007 11:57 pm
by rw1
thanks ot2sen :) that's great news.  yeah i understand about crowdiness - perhaps just a wee demo button? :)

Re: This is how i wish the Extensions site looked...

Posted: Thu Dec 20, 2007 2:46 am
by horus_68
rw1 wrote: yeah i understand about crowdiness - perhaps just a wee demo button?
It would then require a Demo 1.5 and a demo 1.0 button.
I would prefer to see more info upfront (compatibility icons) to hel select the extensions to look up
.. links and details should only be on specific extension page

Its a store!
Don't waist time, but attract them inside for more info.

Thats why each listing should have an intro text to show on lintings and a main text into details pages.

As for now you had to reed all up to find if there are special features.
You could argue that each author can present more info at their sites, but it won't works and it means extra clicks.

So create a details page with a layout for:
- An area to present the special alterations on that version.
- Two features that the owner thinks the extensions stands for
- A list of two or three other extensions that the owner thinks that this extensions could be a good pair (suitable to.. good to use with.. )
- TAGS !!!!

Re: This is how i wish the Extensions site looked...

Posted: Thu Dec 20, 2007 3:59 am
by rw1
horus_68 wrote:
It would then require a Demo 1.5 and a demo 1.0 button.
haha - good point, my poor doomed demo button :( ....you will have victory one day!!

Abiliy to filter for 1.5 downloads

Posted: Wed Jan 09, 2008 6:53 pm
by danielck
hi,

It will be great if there is a direct link for us to view a list of J1.5 compatible downloads.

Re: Abiliy to filter for 1.5 downloads

Posted: Thu Jan 10, 2008 5:44 am
by steve1084
Hi everyone

Just like to add my vote for something that allows to search exclusively for 1.5 extentions.  Maybe its time to have two different extention directories.

Thanks
Steve

Re: Abiliy to filter for 1.5 downloads

Posted: Thu Jan 10, 2008 8:15 am
by LorenzoG
It's on its way.

We won't add different directories, but we will do it easier to differ and search between 1.0 Native, 1.5 Legacy and 1.5 Native extensions.

That includes moving compatibility icons forward at all lists, so you will be able to see compatibility in category view and not only in detail view like it is now. See a preview in this thread: http://forum.joomla.org/index.php/topic ... msg1133087

extensions directory

Posted: Fri Jan 11, 2008 6:42 pm
by oscar615
Does Joomla have any plans to split the extensions directory from one directory that has both 1.0 and 1.5 extensions?  It would be much nicer to have them split by platform.  I try to search by joomla 1.5 but end up with a ton of extensions that are for joomla 1.0.  This would be helpful for the people starting out with 1.5 or converting to 1.5.  It would be a real timesaver to only see the extensions that are 1.5 compatible.  Just a suggestion. :)

Robert

Re: Abiliy to filter for 1.5 downloads

Posted: Fri Jan 11, 2008 9:44 pm
by joatmon
I'd like to add that it'd be nice to filter by category type as well.  So, for example, I'd like to find all 1.5 native components that are in the Calendars category.  Is that doable?

Thanks!

Re: extensions directory

Posted: Fri Jan 11, 2008 11:37 pm
by Gergo Erdosi
Moderator note: Topic moved from 1.5 General Questions to Joomla! Extensions Directory Forum.

Look at this topic:
http://forum.joomla.org/index.php/topic,195246.0.html

Re: This is how i wish the Extensions site looked...

Posted: Tue Jan 15, 2008 4:40 pm
by Rafa3x
You guys are doing a fantastic job with this fantastic CMS.

I have one small Extensions section-specific request: I wish there was a way to view my Favourites by category, similar to the Joomla! Extensions Directory, except you would see the actual extension names below the categories, instead of a sub-category list.

small suggestion

Posted: Wed Jan 16, 2008 4:35 am
by gborislav
Hi,

I have a small suggestion for website

Its very difficult to find extensions with the  Compatibility for Joomla 1.5, and  it takes a long
time to find it.

What I'm suggestion is to put some filter that would be able to separate 1.0 from 1.5 version which would make finding the right compatibility a lot faster.


Thank you,

Re: small suggestion

Posted: Wed Jan 16, 2008 5:15 am
by Opie
Have you tried the Advanced Search page for the Extensions?

Re: small suggestion

Posted: Wed Jan 16, 2008 6:53 pm
by gborislav
Hi,

Yes, i tried the advanced search, but still when i go to 1.5 version i get Results " 681 pages "
because they are not separated into categories . What i meant was putting the filter before the categories.

Thank you.