Litespeed, APC & Zend Optimizer

Discussion regarding Joomla! Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Security and Performance FAQs
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
User avatar
dmcole
Joomla! Intern
Joomla! Intern
Posts: 92
Joined: Wed Aug 17, 2005 10:50 pm

Litespeed, APC & Zend Optimizer

Post by dmcole » Mon Oct 23, 2006 7:07 pm

In my never-ending quest to wring as much horsepower out of my various servers as possible, I have been experimenting with LiteSpeed Web Server (http://www.litespeedtech.com/). While not on OS product, the Standard Edition is free and the company claims a 50% increase in content delivery speed when compared to Apache and mod_php.

Once again, being on a Mac platform meant I had to do a number of things for myself. I couldn't use the LiteSpeed-installed PHP and had to recompile one of my own.

I also decided to try testing APC and/or Zend Optimizer and was successful in loading them onto the server. Plain vanilla HTML files and simple PHP pages worked fine.

But when I loaded J ! 1.0.11 on the machine, I couldn't get it to work. J pages came back with a 503 (temporarily out of service) message. Frequently when generating the 503 pages, either LiteSpeed or PHP crashed.

Removing either APC or ZO from the php.ini file made everything OK again -- it turns out that they don't play nicely with one another in this configuration, but only when serving Joomla! pages.

Anyway, here are my specific questions:

*A search in the forums for LiteSpeed returned zero mentions ... has anybody else tried LiteSpeed?

*Can anybody confirm the Joomla! successful use of APC *and* ZO on any server platform (Apache, et al.)?

*Do APC and the built-in Joomla cache fight one another?

And any other observations you might have.

Environment:

Mac G4 Gigabit Ethernet
400 MHz
768MB RAM
Mac OS X, 10.3.9 (client, latest build)
LIteSpeed 2.2.3
PHP 4.4.4
ZendOptimizer 3.0.6
APC 3.0.12p2

Thanks.

\dmc

 
c2h5oh
Joomla! Explorer
Joomla! Explorer
Posts: 317
Joined: Sat Nov 05, 2005 11:37 pm
Location: Warsaw

Re: Litespeed, APC & Zend Optimizer

Post by c2h5oh » Mon Oct 23, 2006 8:22 pm

It's APC or ZO, you can't use both (and why should you?). As far as I can tell it is true for all platforms.
I'm running APC with Joomla without a problem. This website (both forum.joomla.org and joomla.org) are running APC.
I will be testing litespeed on my development server so any info you can provide is more than welcome :-)
Having Joomla Performance Problems? Look here: http://forum.joomla.org/index.php/topic,106350.0.html

User avatar
dmcole
Joomla! Intern
Joomla! Intern
Posts: 92
Joined: Wed Aug 17, 2005 10:50 pm

Re: Litespeed, APC & Zend Optimizer

Post by dmcole » Tue Oct 24, 2006 1:49 am

c2h5oh:

Thanks for your insight.

Unfortunately, you didn't read my message carefully: when using anything except Joomla!, APC and ZO work together just fine.

You would want to use them together, because they do two different things: APC is a cache while ZO is a code optimizer.

\dmc

c2h5oh
Joomla! Explorer
Joomla! Explorer
Posts: 317
Joined: Sat Nov 05, 2005 11:37 pm
Location: Warsaw

Re: Litespeed, APC & Zend Optimizer

Post by c2h5oh » Tue Oct 24, 2006 7:01 am

I've double checked that: APC is not Zend Optimizer compatible (or the other way round :P ). You will not be able to use both. Zend Encoder works fine.
Having Joomla Performance Problems? Look here: http://forum.joomla.org/index.php/topic,106350.0.html

User avatar
finchwizard
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Mon Oct 24, 2005 1:49 am
Location: Australia
Contact:

Re: Litespeed, APC & Zend Optimizer

Post by finchwizard » Tue Oct 24, 2006 12:57 pm

He's right, APC and Zend Optimizer aren't meant to work together.

Zend yes, remember they make a couple of different products.

Honestly, I've had great success with Lighttpd, MySQL5, PHP5 and APC.

It will take a hell of a beating, could get more tricky with load balancing and proxys and things but that should keep your loads right down.

There are re-write rules for Lighttpd and Joomla somewhere too, can't remember where though, just a google search or these forums I'm sure will reveal it.
10 percent of computer users are Mac users, but remember, we are the top 10 percent.

User avatar
dmcole
Joomla! Intern
Joomla! Intern
Posts: 92
Joined: Wed Aug 17, 2005 10:50 pm

Re: Litespeed, APC & Zend Optimizer

Post by dmcole » Tue Oct 24, 2006 4:33 pm

Thanks.

I guess the fact that I could make them run together at all is therefore a mystery.

\dmc

mlerch
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Mon Jul 24, 2006 1:21 pm

Re: Litespeed, APC & Zend Optimizer

Post by mlerch » Fri Mar 12, 2010 12:34 am

Hello dmcole,

I am trying to get ZendOptimizer to work on my server( OS X 10.3.9 Server on PPC platform, PHP 4.4.9 ) and none of the new ZendOptimizer versions (3.2.x, 3.3.x) that I could find work. Simply won't install, and if I manually put it in and try to start Apache it won't start.

So, since you have ZendOptimizer 3.0.6 running on your server I thought I would ask you to see if you could please send me your ZendOptimizer.so file so that I may try it on my box.

I know that this is a long time since you posted this, and chances are that you may not even have it anymore, but I thought I would try.

Thank you,

Martin

 

Locked

Return to “Performance - 1.0.x”