Fatal error: Maximum execution time of 30 seconds exceeded

Discussion regarding Joomla! Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Security and Performance FAQs
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
djreason
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 107
Joined: Mon Jul 24, 2006 3:42 am

Fatal error: Maximum execution time of 30 seconds exceeded

Postby djreason » Tue Sep 25, 2007 2:54 pm

I am getting an error message on my page now due to too many products loading in my categories.

Fatal error: Maximum execution time of 30 seconds exceeded in D:\domains\discountperformanceautoparts.com\wwwroot\administrator\components\com_virtuemart\classes\ps_product_category.php on line 593

How do I fix this?


Also, my site is running extremely slow now and I am on a dedicated server.  How do I fix this as well?

Thanks
~ Brad
Sign up for the Best Joomla Hosting in My Opinion!
http://www.hostmonster.com

User avatar
ircmaxell
Joomla! Ace
Joomla! Ace
Posts: 1926
Joined: Thu Nov 10, 2005 3:10 am
Location: New Jersey, USA
Contact:

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby ircmaxell » Tue Sep 25, 2007 3:38 pm

Enable debug, and see how many queries are being run...
Anthony Ferrara - Core Team - Development Coordinator - Bug Squad - JSST

http://moovum.com/ - The Bird is in the air! Get Mollom Anti-Spam on your Joomla! website with Moovur...
http://www.joomlaperformance.com For All Your Joomla Performance Needs

enticer
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 110
Joined: Tue Oct 02, 2007 3:19 am

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby enticer » Mon Jan 28, 2008 6:41 am

I am also getting this

[Mon Jan 28 00:35:24 2008] [error] PHP Fatal error:  Maximum execution time of 30 seconds exceeded in /home/smscebu/public_html/components/com_fireboard/sources/interpreter.fireboard.inc.php on line 88

please advise!

avatar76
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Mar 27, 2008 2:12 am

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby avatar76 » Thu Mar 27, 2008 2:31 am

I've found that the php if running under windows needs to have the php.ini sit in the windows folder eg %systemroot%.
Once you've placed php.ini somewhere that the php.exe can find it (it won't find it in the C:\php folder) it's time out will be 60 seconds. 30 seconds means it's not reading the config file at all and using the default stored in the executable which is 30 seconds (60 is the default in the php.ini file if it's a number other then what's written in the php.ini file then it is not using that).
This definitely works.

papayamilkshake
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Feb 22, 2008 4:07 pm

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby papayamilkshake » Mon Apr 28, 2008 5:36 am

Hi,

I've got the same problem. However it was due to a bug in Joomla 1.5.2 (I think). It was caused by enabling filtering of for Filtering Options (Content >> Article Manager >> Parameters >> Filtering Options). What I did to resolve it was to disable the filtering and it's working again. :)

regards
papayamilkshake

avatar76
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Mar 27, 2008 2:12 am

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby avatar76 » Mon Apr 28, 2008 5:47 am

papayamilkshake wrote:Hi,

I've got the same problem. However it was due to a bug in Joomla 1.5.2 (I think). It was caused by enabling filtering of for Filtering Options (Content >> Article Manager >> Parameters >> Filtering Options). What I did to resolve it was to disable the filtering and it's working again. :)

regards
papayamilkshake

You've possibly just spead up the processing by disabling filtering which means that it doesn't fall over at the php system time out of 30 seconds. However if you encounter something which takes more then 30 seconds to run it'll fall over on you still.

kadded
Joomla! Explorer
Joomla! Explorer
Posts: 306
Joined: Sun Mar 23, 2008 9:54 pm

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby kadded » Tue May 06, 2008 4:32 am

I also had this issue and this was solved by chaning the 'intro' parameter of the category blog layout.

I choose a category blog layout, set the intro to the max (99999) and got the error. Changing it to 100 solved the problem.

avatar76
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Mar 27, 2008 2:12 am

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby avatar76 » Tue May 06, 2008 4:39 am

You're all working around the main issue which is that php is not setup properly on your web server.

T_Clauss
Joomla! Intern
Joomla! Intern
Posts: 60
Joined: Thu Nov 29, 2007 6:15 am
Location: Gettysburg, Pa

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby T_Clauss » Tue Jun 03, 2008 2:23 pm

Open your php.ini file

EDIT: max_execution_time = 30

Save and restart your server

otelo
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Mon Oct 09, 2006 4:28 pm

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby otelo » Tue Jul 08, 2008 11:39 pm

What if I don't have access to the php.ini file?

T_Clauss
Joomla! Intern
Joomla! Intern
Posts: 60
Joined: Thu Nov 29, 2007 6:15 am
Location: Gettysburg, Pa

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby T_Clauss » Sat Aug 09, 2008 10:47 pm

Contact your host and ask them if they can increase it for ya.

mslonik
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sun Dec 07, 2008 12:49 am

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby mslonik » Sun Dec 07, 2008 10:16 am

Small amendment to post of T_Clauss. If your host provides you configuration by means of .htaccess it is possible to change parameter max_execution_time as follows:

1. Create or edit .htaccess file.
2. Put into the file:
php_value max_execution_time xx

where xx stands for the new value of a parameter.

Regards,
mslonik

User avatar
jessiered
Joomla! Intern
Joomla! Intern
Posts: 66
Joined: Sat Jan 10, 2009 4:50 am

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby jessiered » Wed Jan 21, 2009 2:11 am

avatar76 wrote:
papayamilkshake wrote:Hi,

I've got the same problem. However it was due to a bug in Joomla 1.5.2 (I think). It was caused by enabling filtering of for Filtering Options (Content >> Article Manager >> Parameters >> Filtering Options). What I did to resolve it was to disable the filtering and it's working again. :)

regards
papayamilkshake

You've possibly just spead up the processing by disabling filtering which means that it doesn't fall over at the php system time out of 30 seconds. However if you encounter something which takes more then 30 seconds to run it'll fall over on you still.
D * Jessiered * Smile
:: Never Finish a Negative Statement ::

User avatar
jessiered
Joomla! Intern
Joomla! Intern
Posts: 66
Joined: Sat Jan 10, 2009 4:50 am

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby jessiered » Wed Jan 21, 2009 2:11 am

avatar76 wrote:
papayamilkshake wrote:Hi,

I've got the same problem. However it was due to a bug in Joomla 1.5.2 (I think). It was caused by enabling filtering of for Filtering Options (Content >> Article Manager >> Parameters >> Filtering Options). What I did to resolve it was to disable the filtering and it's working again. :)

regards
papayamilkshake

You've possibly just spead up the processing by disabling filtering which means that it doesn't fall over at the php system time out of 30 seconds. However if you encounter something which takes more then 30 seconds to run it'll fall over on you still.


Hi! Thanks for the answer! But how do I disable Filtering. The only options I have to choose is
Blacklist
Whitelist
html

What should I check.

Where should I disable it?

Please help!
Thanks in advance!
D * Jessiered * Smile
:: Never Finish a Negative Statement ::

User avatar
jessiered
Joomla! Intern
Joomla! Intern
Posts: 66
Joined: Sat Jan 10, 2009 4:50 am

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby jessiered » Wed Jan 21, 2009 2:15 am

T_Clauss wrote:Open your php.ini file

EDIT: max_execution_time = 30

Save and restart your server



In which part of the php.ini file can I find this.
Thank you very much :)
D * Jessiered * Smile
:: Never Finish a Negative Statement ::

User avatar
jessiered
Joomla! Intern
Joomla! Intern
Posts: 66
Joined: Sat Jan 10, 2009 4:50 am

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby jessiered » Wed Jan 21, 2009 2:18 am

mslonik wrote:Small amendment to post of T_Clauss. If your host provides you configuration by means of .htaccess it is possible to change parameter max_execution_time as follows:

1. Create or edit .htaccess file.
2. Put into the file:
php_value max_execution_time xx

where xx stands for the new value of a parameter.

Regards,
mslonik


in which part of the .htaccess should I put the file?
Thanks in advance
D * Jessiered * Smile
:: Never Finish a Negative Statement ::

User avatar
jessiered
Joomla! Intern
Joomla! Intern
Posts: 66
Joined: Sat Jan 10, 2009 4:50 am

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby jessiered » Wed Jan 21, 2009 2:21 am

ircmaxell wrote:Enable debug, and see how many queries are being run...


Hi!

I'm new to Joomla and would like to know how do I enable debug.
Thanks in advance
D * Jessiered * Smile
:: Never Finish a Negative Statement ::

Yorb
Joomla! Apprentice
Joomla! Apprentice
Posts: 22
Joined: Fri Jul 11, 2008 4:54 pm

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby Yorb » Fri Feb 06, 2009 9:49 pm

I'm getting this error during install of an extension (EventList, specifically). Running J! 1.5.9, and I've set my max_execution_time to 60 (which is correctly reported in the phpinfo() table), but I still get the error. What the dilly yo yo yo?

EDIT: fixed. my shared host only has add-on php.ini's affect the folder they're in (not subfolders), so even though index.php had the ini var set, administrator/index.php did NOT. you need 2 php.ini files, one in root and one in /administrator, to cover all the bases if you can't edit your master php.ini file. (i had also tried putting a php.ini in /libraries/joomla/filesystem/archive/, which is the location of the script that was erroring, but that didn't work either -- the ini has to be in the folder of the parent php file. in Joomla's case, this is always index.php or administrator/index.php.)

User avatar
exrace
Joomla! Explorer
Joomla! Explorer
Posts: 281
Joined: Tue Aug 23, 2005 4:55 am
Location: On my CBR 1000rr...

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby exrace » Sat Feb 07, 2009 1:51 pm

It is under the Joomla ACP under configuration.
jessiered wrote:
ircmaxell wrote:Enable debug, and see how many queries are being run...


Hi!

I'm new to Joomla and would like to know how do I enable debug.
Thanks in advance
Love, Live PHP.
Love, Live Joomla!
Super Sonic Man...do you want to buy a RockeTheme rocket? -Gary Jules

Lowlande
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Fri May 11, 2007 7:24 pm

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby Lowlande » Fri Feb 13, 2009 7:44 pm

I had the same problem with a frontend login and the file it referenced was emailcloak.php. I turned off cloaking and it's fixed.

In searching for a solution, it seems that lots of people have had this issue and that it's not necessarily tied to a specific plugin or setting, but to Joomla 1.5 conflicting with a PHP 5.0.3 upgrade.

This person references that issue:
http://joomlacode.org/gf/project/joomla ... m_id=10127

I disagree that upping the timeout will/should fix the issue, let's focus on what's causing the site to take more than 30 seconds to process a request.

Amy
Lowlande Web Design

Katmassive
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Sat Dec 02, 2006 6:38 am

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby Katmassive » Sat Apr 25, 2009 6:27 am

T_Clauss wrote:Open your php.ini file

EDIT: max_execution_time = 30

Save and restart your server


thanks i didnt wanna go digging through everything to find the settings i extended minez to 120 seems to be great for now
Last edited by ooffick on Tue Jan 05, 2010 3:46 pm, edited 1 time in total.
Reason: Mod Note: Deleted Manual Signature. Please read the Forum Rules for details

jamesmeijer1234
Joomla! Apprentice
Joomla! Apprentice
Posts: 36
Joined: Fri May 15, 2009 6:43 pm

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby jamesmeijer1234 » Fri May 15, 2009 8:56 pm

changing a bit of settings worked for me too ;) thanks.

Varsys
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Thu Sep 18, 2008 3:31 pm
Location: Chicago, IL
Contact:

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby Varsys » Sun Jun 21, 2009 8:53 pm

T_Clauss wrote:Open your php.ini file

EDIT: max_execution_time = 30

Save and restart your server


That worked. Thanks!

User avatar
toncmi
Joomla! Intern
Joomla! Intern
Posts: 76
Joined: Thu Feb 07, 2008 3:08 pm
Contact:

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby toncmi » Tue Oct 13, 2009 3:59 pm

Fatal error: Maximum execution time of 30 seconds exceeded in /home/www/virtual/chiangmaidee.com/paikad_com/htdocs/libraries/joomla/filter/filterinput.php on line 397

mslonik wrote:Small amendment to post of T_Clauss. If your host provides you configuration by means of .htaccess it is possible to change parameter max_execution_time as follows:

1. Create or edit .htaccess file.
2. Put into the file:
php_value max_execution_time xx

where xx stands for the new value of a parameter.

Regards,
mslonik



That good. thankyou
Signature rules: Literal URLs only - viewtopic.php?f=8&t=65

bhevan
Joomla! Apprentice
Joomla! Apprentice
Posts: 10
Joined: Fri Dec 04, 2009 8:28 am

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby bhevan » Fri Dec 04, 2009 9:33 am

HI...

Where can I find the php.ini file?
I searched all the apache folder and found nothing

User avatar
FidelGonzales
Joomla! Guru
Joomla! Guru
Posts: 584
Joined: Thu Nov 03, 2005 12:10 am
Location: Hesperia, California, USA
Contact:

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby FidelGonzales » Thu Apr 01, 2010 9:46 pm

Usually in your host root directory or cgi-bin. You may even need to create the file and install in one of those directories. I would recommend checking with your host to determine the details.
http://www.MediaArmory.com - WEB | PHOTO | WRITE | MARKETING | DESIGN
http://www.DirtArmory.com - Off Road Sports Lifestyle

zhukov
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Apr 06, 2010 8:35 am

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby zhukov » Sat Apr 10, 2010 8:16 pm

I had this error message come up and when I tried to return i looked in the article I had been modifying and all the changes i had made that day which had taken the best part of a day had been deleted. Gone totally, is there any way of retrieving them?

User avatar
FidelGonzales
Joomla! Guru
Joomla! Guru
Posts: 584
Joined: Thu Nov 03, 2005 12:10 am
Location: Hesperia, California, USA
Contact:

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Postby FidelGonzales » Sat Apr 10, 2010 11:47 pm

No. One of the greatest drawbacks for any writer using Joomla or even JoomlaWorks K2 is that there is no versioning or auto-save function. Wordpress excels at this, making it a much better platform for frequent production. JoomlaWorks K2 has said versioning/auto-save is in the works.

I recommend writing on Google Docs (real-time) or a desktop word processor (old school word) such as Word, Open Office or an email client such as Thunderbird.
http://www.MediaArmory.com - WEB | PHOTO | WRITE | MARKETING | DESIGN
http://www.DirtArmory.com - Off Road Sports Lifestyle

zhukov
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Apr 06, 2010 8:35 am

File not found

Postby zhukov » Tue Apr 13, 2010 12:42 pm

Hi there,

Thanks for the comments much appreciated. Another problem I seem to be having is when I click the apply or save button: File Not found

What could this be due to ?

zhukov
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Tue Apr 06, 2010 8:35 am

Error Message

Postby zhukov » Tue Apr 13, 2010 4:01 pm

File not found











This is the error message I'm often getting when i click apply or save??

Firefox can't find the file at http://174.132.147.130/~internet/admini ... /index.php.



* Check the file name for capitalisation or other typing errors.

* Check to see if the file was moved, renamed or deleted.


Return to “Performance - 1.0.x”

Who is online

Users browsing this forum: No registered users and 2 guests