Fatal error: Maximum execution time of 30 seconds exceeded

Discussion regarding Joomla! Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Security and Performance FAQs
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
User avatar
FidelGonzales
Joomla! Guru
Joomla! Guru
Posts: 584
Joined: Thu Nov 03, 2005 12:10 am
Location: Hesperia, California, USA
Contact:

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Post by FidelGonzales » Tue Apr 13, 2010 5:31 pm

I had two issues like that several years ago. Ounce was a bug in Mambo (or Joomla). The second was the files were not completely loaded onto the server via my FTP client.

If you have made any changes or perhaps have a new site, you may want to consider this. Otherwise, your database or files permissions may not be accepting the submission, which could be the case if you made any related changes.

I recommend starting a new thread.
http://www.MediaArmory.com - WEB | PHOTO | WRITE | MARKETING | DESIGN
http://www.DirtArmory.com - Off Road Sports Lifestyle

User avatar
travitzki
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sat Mar 06, 2010 5:42 pm
Location: São Paulo, Brasil
Contact:

Re: Fatal error: Maximum execution time of 30 seconds exceeded

Post by travitzki » Fri Apr 23, 2010 2:55 pm

Yorb wrote: you need 2 php.ini files, one in root and one in /administrator, to cover all the bases if you can't edit your master php.ini file.
Thanks!
It works for me.
Rodrigo Travitzki
http://rizomas.net

User avatar
iwankumara
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Tue Apr 29, 2008 9:08 am
Contact:

Re: Fatal error: Maximum execution time of 30 seconds exceed

Post by iwankumara » Mon Dec 27, 2010 9:19 am

jessiered wrote:
T_Clauss wrote:Open your php.ini file

EDIT: max_execution_time = 30

Save and restart your server

In which part of the php.ini file can I find this.
Thank you very much :)
Hi,

You can not acces php.ini through your web root. It is in your hosting provider server. It means you have to tell them to change the parameter. hey can do it easily through their WHM. But sometimes, small reseller/hosting provider has no idea where it is or how to change it.

cheers

Iwan

suntimmy
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Jan 26, 2011 2:08 pm
Contact:

Re: Fatal error: Maximum execution time of 30 seconds exceed

Post by suntimmy » Fri Feb 04, 2011 9:57 am

djreason wrote:I am getting an error message on my page now due to too many products loading in my categories.

Fatal error: Maximum execution time of 30 seconds exceeded in D:\domains\discountperformanceautoparts.com\wwwroot\administrator\components\com_virtuemart\classes\ps_product_category.php on line 593

How do I fix this?


Also, my site is running extremely slow now and I am on a dedicated server.  How do I fix this as well?

Thanks
maby try this - search php.ini and than find the line with
max_execution_time = 30
and change value

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Fatal error: Maximum execution time of 30 seconds exceed

Post by beededea » Sat Feb 05, 2011 1:40 pm

If you are on a dedicated server and the system is running slow then perhaps you need to start tuning the system, turn on cacheing &c.

You say the site is running slow but that is quite a big statement, it is like saying "I am ill, how do I fix it?" First of all you need to state what the site is doing when it runs slowly. If you had one simple page with nothing on it and the site ran slowly then it would be fairly easy to pinpoint. If every page runs slowly regardless of content or if specific pages with specific content are slow to load then it gives us an idea where the problem lies. More detail perhaps?
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

monje
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri Mar 11, 2011 11:16 am

Re: Fatal error: Maximum execution time of 30 seconds exceed

Post by monje » Tue Mar 22, 2011 4:48 am

T_Clauss wrote:Open your php.ini file

EDIT: max_execution_time = 30

Save and restart your server
this works for me. thank you. getting another error, but i guess its a different issue. thanks again

User avatar
murenti
Joomla! Intern
Joomla! Intern
Posts: 83
Joined: Sun Nov 13, 2011 3:27 am
Location: Adelaide, South Australia
Contact:

Re: Fatal error: Maximum execution time of 30 seconds exceed

Post by murenti » Wed Sep 05, 2012 6:39 am

I also have the 30 second timeout error, and I cant see my PHP.ini on my server but even if I change the timeout limit to 3o seconds and it goes over wont it still throw the error?
Also is there another fix for this issue, I have a document which is about 5500 characters and it allows it to be saved but wont let me reopen it to edit it later.
Enhance the look of your Joomla website with a Premium Template and Leave your customers with a Fresh new impression of your business.
http://www.planetbiz.com.au
http://www.planetinternetmarketing.com

vinthri
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Wed Apr 17, 2013 12:08 pm

Re: Fatal error: Maximum execution time of 30 seconds exceed

Post by vinthri » Fri May 03, 2013 4:17 am

travitzki wrote:
Yorb wrote: you need 2 php.ini files, one in root and one in /administrator, to cover all the bases if you can't edit your master php.ini file.
Thanks!
It works for me.
It works for me too. Thanks a ton :)


Locked

Return to “Performance - 1.0.x”