Page 1 of 1

Joomla ignoring upload_max_filesize override

Posted: Thu May 15, 2008 1:03 pm
by jgold723
My host defaults to an upload_max_filesize of 2M. Following the instructions of my host, I placed a php.ini file in the root directory (the same directory my Joomla 1.0.15 installation is living) with an upload_max_filesize of 5M. Joomla, however, ignores this. When I check the PHP info in the Joomla system area, it continues to read 2M.

How do I get Joomla to recognize the override?

Thanks,

John

Re: Joomla ignoring upload_max_filesize override

Posted: Thu May 15, 2008 1:17 pm
by ircmaxell
jgold723 wrote:My host defaults to an upload_max_filesize of 2M. Following the instructions of my host, I placed a php.ini file in the root directory (the same directory my Joomla 1.0.15 installation is living) with an upload_max_filesize of 5M. Joomla, however, ignores this. When I check the PHP info in the Joomla system area, it continues to read 2M.

How do I get Joomla to recognize the override?

Thanks,

John
That's because php is not recognizing the change... Contact your host, and tell them you've been having problems with it, and ask for their help...

Re: Joomla ignoring upload_max_filesize override

Posted: Thu May 15, 2008 1:27 pm
by jgold723
Well, that's the strange thing. If I run a php_info file (again, in the root directory) it does recognize the override. Is this still a host issue, or a Joomla issue?

Thanks,

John

Re: Joomla ignoring upload_max_filesize override

Posted: Thu May 15, 2008 1:33 pm
by ircmaxell
jgold723 wrote:Well, that's the strange thing. If I run a php_info file (again, in the root directory) it does recognize the override. Is this still a host issue, or a Joomla issue?

Thanks,

John
Go to System Info (under help) in the J! administrator interface... There's a phpinfo tab in there... what does that say?

Re: Joomla ignoring upload_max_filesize override

Posted: Thu May 15, 2008 1:58 pm
by jgold723
That sees the upload_max_filesize as 2M -- so it seems to be ignoring my override.

Re: Joomla ignoring upload_max_filesize override

Posted: Sat Sep 27, 2008 11:15 am
by annivas
I have exactly the same problem. I have put the php.ini files all over the place (www dir, joomla installation dir, administrator dir etc) but with no results.
Any ideas would be greatly appreciated!

Re: Joomla ignoring upload_max_filesize override

Posted: Tue Sep 30, 2008 8:11 pm
by jgold723
This was a while back, but I seem to remember that I had to ask the hosting company to set up the upload override.

John

Re: Joomla ignoring upload_max_filesize override

Posted: Fri Sep 24, 2010 4:24 pm
by ThePiston
to anyone else with this problem- if you are on VPS or dedicated server you need to change PHP settings in WHM by going to "PHP Configuration Editor". In there you can change both memory_limit and upload_max_filesize. both of these have no affect inside php.ini unless you chaneg them in WHM. If you are not using VPS or dedicated server you will need to ask your host to do this for you

Re: Joomla ignoring upload_max_filesize override

Posted: Wed Sep 21, 2011 5:11 pm
by muddauber
What size to you recommend to handle Joomla upgrades?

Re: Joomla ignoring upload_max_filesize override

Posted: Wed Sep 25, 2013 3:49 pm
by dermi
I've researched and searching this a little, I think with your help Reply to this post:
http://forum.joomla.org/viewtopic.php?f=615&t=820827