Each page on site taking 2 minutes to load

Discussion regarding Joomla! Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Security and Performance FAQs
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
swisspenelope
Joomla! Apprentice
Joomla! Apprentice
Posts: 39
Joined: Thu Apr 13, 2006 3:49 pm

Each page on site taking 2 minutes to load

Post by swisspenelope » Wed Oct 29, 2008 6:21 am

A while back I had this problem (since then I completely recreated the site from a newly-installed version of Joomla - after weeks of trying to find the reason why). All was working well, v1.13 with extensions/modules such as FacileForms and JEvents, also external feeds from 2 other websites and some google script for Google Analytics. That was about it - not a complicated site.

It worked fine for months, then one day, boom! 2 minutes+ to load the home page and every subsequent page. My provider said a script was running over and over and finally timing out. This was not my script! It didn't seem to be interrogating my db either.

I disactivated modules and extensions one by one till I had the bare bones of my site left, and still the problem continued. So I gave up and recreated the site.

Anyone else have the same kind of thing happen? I'd love to know what caused it.
sp

User avatar
madamsplash
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Wed Nov 05, 2008 10:35 am
Location: Australia
Contact:

Re: Each page on site taking 2 minutes to load

Post by madamsplash » Tue Nov 03, 2009 12:00 am

Yes we're having the same problem with one of our sites - this is the second experience, I'm wondering if it is some sort of Denial of Service attack ... we're using a Joomla Firewall which up to now has stopped this happening -

Its frustrating!

User avatar
garyjaybrooks
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Wed Feb 20, 2008 4:34 am
Location: Michigan
Contact:

Re: Each page on site taking 2 minutes to load

Post by garyjaybrooks » Thu Nov 26, 2009 5:32 am

You should be able to ask your host to look at the server and ask him what is causing the slow problem.

They can review the PHP scripts or they can review the mysql server.

You also might want to tell us what host your using.
Gary Brooks - Joomla Hosting with Phone Support http://www.CloudAccess.net Official host of http://demo.joomla.org

PietruS
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sun Jan 10, 2010 5:57 pm
Contact:

Re: Each page on site taking 2 minutes to load

Post by PietruS » Mon Jan 11, 2010 4:44 pm

I know it's a bit of an oldish topic, but many webmasters face the slow site problem eventually. In this case try this Yahoo tool:

http://developer.yahoo.com/yslow/

It helped me solve my issue.


Locked

Return to “Performance - 1.0.x”