Front page articles are not showing up

Discussion regarding Joomla! Performance issues.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Security and Performance FAQs
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
matchdesigns
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Jun 12, 2011 3:08 pm

Front page articles are not showing up

Post by matchdesigns » Thu Jun 16, 2011 9:20 pm

I have just been asked to have a look at why the front articles are not showing up on this website: http://www.mollieandmax.co.uk/

The joomla version is 1.0.15, I was told that it was working fine and then it has just stopped all of a sudden. Has anyone had this problem before?

User avatar
sone12
Joomla! Champion
Joomla! Champion
Posts: 5440
Joined: Wed Oct 11, 2006 1:12 pm
Location: Kristiansand, Norway
Contact:

Re: Front page articles are not showing up

Post by sone12 » Thu Jun 16, 2011 9:35 pm

matchdesigns wrote:I have just been asked to have a look at why the front articles are not showing up
See my screenshot here...what is the content in the bottom of your page? It was invisible until i "selected all" cmd+a
Skjermbilde 2011-06-16 kl. 23.33.34.png
You do not have the required permissions to view the files attached to this post.
Kristian P. Granrud - Global Moderator

matchdesigns
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Jun 12, 2011 3:08 pm

Re: Front page articles are not showing up

Post by matchdesigns » Thu Jun 16, 2011 9:57 pm

Thanks sone12, that's what I thought at first but this is on everypage. when you go to the front page manager in the back end of joomla the article that is published is not showing up. It should be in the middle... like on this page

http://www.mollieandmax.co.uk/index.php ... t&Itemid=1

User avatar
sone12
Joomla! Champion
Joomla! Champion
Posts: 5440
Joined: Wed Oct 11, 2006 1:12 pm
Location: Kristiansand, Norway
Contact:

Re: Front page articles are not showing up

Post by sone12 » Thu Jun 16, 2011 10:07 pm

Can you check in the article manager and see if all articles are published? To me it looks like every menu item that links to com_content miss the contents. Try also create a new menu item an link to e.g an article.

Is there any extensions installed that may have effect on the com_content?
Kristian P. Granrud - Global Moderator

matchdesigns
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Jun 12, 2011 3:08 pm

Re: Front page articles are not showing up

Post by matchdesigns » Thu Jun 16, 2011 10:19 pm

thanks sone12, Yeah there's one article published on the front page. I create a new one aswell and published it to show up but it does not. I think your right because all the other pages apart from the one that use virtuemart don't show up in the com_content. I think there's a few extensions How will I know if they are effecting the com_content?

User avatar
sone12
Joomla! Champion
Joomla! Champion
Posts: 5440
Joined: Wed Oct 11, 2006 1:12 pm
Location: Kristiansand, Norway
Contact:

Re: Front page articles are not showing up

Post by sone12 » Thu Jun 16, 2011 10:25 pm

matchdesigns wrote:I think there's a few extensions How will I know if they are effecting the com_content?
Normally by deactivate or delete one by one...ps...take full backup before you do anything. But personally I dont think that is the problem. So, let it be in this round.

Have you tested use another template for a second?
Kristian P. Granrud - Global Moderator

matchdesigns
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Jun 12, 2011 3:08 pm

Re: Front page articles are not showing up

Post by matchdesigns » Thu Jun 16, 2011 10:36 pm

Just tried using a new template same thing happens. Nothing shows in the com_content. Is that a last resort to delete the extensions?

User avatar
sone12
Joomla! Champion
Joomla! Champion
Posts: 5440
Joined: Wed Oct 11, 2006 1:12 pm
Location: Kristiansand, Norway
Contact:

Re: Front page articles are not showing up

Post by sone12 » Thu Jun 16, 2011 10:40 pm

matchdesigns wrote:Just tried using a new template same thing happens. Nothing shows in the com_content. Is that a last resort to delete the extensions?
No, i dont think an extension is the problem in this case. Maybe I was stupid that gave you this in mind. He he...

Can you take a screen shot of your articles in the article manager?
You can also try yo fix some of the erros on your site...there is 41 errors.
http://validator.w3.org/check?uri=http% ... ne&group=0
Kristian P. Granrud - Global Moderator

matchdesigns
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Jun 12, 2011 3:08 pm

Re: Front page articles are not showing up

Post by matchdesigns » Thu Jun 16, 2011 11:01 pm

Thanks yeah I have attached 2
screen02.jpg
screen01.jpg
files that show this. I did not do this site lol have just been asked to get it working. Will have a go at the errors though.
You do not have the required permissions to view the files attached to this post.

matchdesigns
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Jun 12, 2011 3:08 pm

Re: Front page articles are not showing up

Post by matchdesigns » Fri Jun 17, 2011 10:04 am

Does anyone have an idea why this is happening ?

matchdesigns
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Jun 12, 2011 3:08 pm

Re: Front page articles are not showing up

Post by matchdesigns » Wed Jun 22, 2011 5:36 pm

I open to any ideas why articles are not showing up in the com_content, has anyine else had this issue?

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Front page articles are not showing up

Post by beededea » Wed Jul 06, 2011 8:16 am

What has changed on the site on the PC and on the host? Browser, which version? Have you tested it on all the browsers?

On the site, what had changed around that time?

What host changes happened at that time?
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

matchdesigns
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Sun Jun 12, 2011 3:08 pm

Re: Front page articles are not showing up

Post by matchdesigns » Wed Jul 06, 2011 2:09 pm

Hi I did not do the original site put I have asked the person that did and he said that nothing had changed on the site or hosting. He said he thinks it could be since internet explorer changed. I have tried to view it in Chrome and Firefox and they do just the same. Thanks for you help ;)

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Front page articles are not showing up

Post by beededea » Wed Jul 06, 2011 2:20 pm

His advice is junk, if it occurs on all browsers on all machines, then it is a change on the site itself or on the host.

Do you have a backup prior to the problem occurring?

What is the PHP version? - see system info.
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

themc
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Tue Jun 03, 2008 7:17 pm

Re: Front page articles are not showing up

Post by themc » Mon Oct 17, 2011 12:11 am

I am having the same problem and no content is showing up on the site. It was working fine like 2 hours ago and I know I did not change anything. 1.0.12 was the last up grade i did because everything was working and I worked so hard on the look of the site. the template is still the same, I change it just to see if it would fix the problem but the same, No front pages.

Some one was helping but I was in the 1.7 or more section by mistake.

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Front page articles are not showing up

Post by beededea » Mon Oct 17, 2011 12:23 am

@themc - You are running an old and insecure version of Joomla 1.0, You should at the very least have upgraded it to 1.0.15. Not to have done so is foolish.

You will have backups, get hold of them and you should prepare to ask the host to restore the most recent backup.

First though, ask the host whether they have changed the version of PHP. Return the answer here.

Asking for help in the 1.7 section was a bit dumb too... you need to get your head screwed on straight if you want to fix this problem so, brain on!
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

themc
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Tue Jun 03, 2008 7:17 pm

Re: Front page articles are not showing up

Post by themc » Mon Oct 17, 2011 12:30 am

lol.... I was rushing and looking for answer, I never look to see where I was posting. I thought Joomla was Joomla.... So you are saying if I upgrade to 1.0.15, this may fix my problem? I am running 1.0.12 and if I up grade to 1.0.15, can I still use the same template? take a look at my site please. www.theworldslargestrapcontest.com

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Front page articles are not showing up

Post by beededea » Mon Oct 17, 2011 12:50 am

I will not be visiting your site. Your descriptions will have to suffice.
Joomla version is critical, you need to get to know your software. It is your site.

I did not say upgrading would fix your problem.
You need to stay on track and not get diverted by what you think I'm saying. Just read the words... Now, answer my questions re: backup and PHP and I will try to help.
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

themc
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Tue Jun 03, 2008 7:17 pm

Re: Front page articles are not showing up

Post by themc » Mon Oct 17, 2011 1:39 am

I am waiting for a response back from the host. How do I find witch version of PHP i am running?
or Maybe I need to talk to the host first. I never said, you said it would fix the problem, I was just asking. and your (re: backup and PHP and I will try to help) is a little confusing. should it read, backup the PHP files and then you will help?

I am going to bed, thanks for the help

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Front page articles are not showing up

Post by beededea » Mon Oct 17, 2011 8:23 am

Gosh - You are the one who is confusing, not me! Just read the words - I will make sure there is no ambiguity. :)

Firstly, - "ask the host whether they have changed the version of PHP" - Go and do that.

My email does not say or imply that you should backup and I will help. It states that you need to get hold of your backup, to quote:

"backups, get hold of them and you should prepare to ask the host to restore the most recent backup"

So, go and find your backups, find the most recent and get ready to ask your host to restore it, you may need to in order to get your site back. Make sure you are ready.

Now, if there is stuff you don't understand don't try and interpret what I mean, just ask. I know it was late...
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

themc
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Tue Jun 03, 2008 7:17 pm

Re: Front page articles are not showing up

Post by themc » Mon Oct 17, 2011 10:30 am

Thanks you, I did what you told me, I talk to the host and you was right. They made changes to the PHP, but we are back working.

Now, I know yes I should up- grade to 1.0.15 because I would be foolish not to. Do I need to install the 1.0.14 first then install the 1.0.15? And the site should still LOOK them same right?

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Front page articles are not showing up

Post by beededea » Mon Oct 17, 2011 11:48 am

OK, good.

First. Backup site, transfer to your PC and store.

Second. Create new site as a test and perform the upgrade there. Creating a new site is beyond the scope of this post... You need to find out how. Upgrading a test site means you won't screw up the live site.

Alternatively, now you have a backup of the live safely in your hand then you could upgrade the live site and if it works, it works.

Find the upgrade patch from 1.0.12 to 1.0.15 and read the associated documentation. These will tell you what the effects on your site will be, if any. No need to ask me, they will all be stated clearly.

When you are done upgrading then take a backup immediately, so you will have one before and one after.

Then start switching hosting to a host that will not muck around with PHP without telling you first.
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

themc
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Tue Jun 03, 2008 7:17 pm

Re: Front page articles are not showing up

Post by themc » Mon Oct 17, 2011 12:30 pm

Ok and thanks again

themc
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Tue Jun 03, 2008 7:17 pm

one log in problem

Post by themc » Tue Oct 18, 2011 2:04 pm

I have had this problem for some time. Each time I create a new content or edit one, no one can log in the front end for about 6 to 8 hours. each time we all have to just log in the next day and everything is working.

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Front page articles are not showing up

Post by beededea » Tue Oct 18, 2011 2:35 pm

Raise the new problem in a new post.
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

gtenus
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Fri Sep 03, 2010 1:50 am

Re: Front page articles are not showing up

Post by gtenus » Fri Oct 21, 2011 6:05 pm

helo beededea, am having the same ''front page article not showing'' issue on my site that was working perfectly before since about two days now and i have contacted my host and there response was that they did modify the DNS Servers settings 2 days ago, but have reversed that change yesterday to restore the original DNS Server settings. but no changes to the issue. tried creating some new articles to see if it will open when clicked on the front page but it still having a missing link not or link not available display. please what do you think i should do now?

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Front page articles are not showing up

Post by beededea » Sat Oct 22, 2011 10:06 am

@gtenus, info. please first, is this a Joomla 1.0 installation?
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

gtenus
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Fri Sep 03, 2010 1:50 am

Re: Front page articles are not showing up

Post by gtenus » Sun Oct 23, 2011 7:17 pm

@beededea, its a joomla 1.5 installation.

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Front page articles are not showing up

Post by beededea » Sun Oct 23, 2011 7:31 pm

@gtenus - see this part of the forum? it is for Joomla 1.0.
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

gtenus
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Fri Sep 03, 2010 1:50 am

Re: Front page articles are not showing up

Post by gtenus » Mon Oct 24, 2011 11:20 am

ok thanks... will go to joomla 1.5


Locked

Return to “Performance - 1.0.x”