some errors in the first using of joomla after installing it

بیان مباحث و مشکلات در مودر قالبهای وملا

Moderator: joomlalearn

ofoghtalaee
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sun Oct 04, 2015 7:04 am

some errors in the first using of joomla after installing it

Postby ofoghtalaee » Sun Oct 04, 2015 7:17 am

hello Dear managers and users
I have some problems with my joomla! I've installed my joomla persian version successfully and when my website loaded, I see some errors in my "Error_log" file in my host. these are the errors:


[03-Oct-2015 10:23:44 Asia/Tehran] PHP Warning: ini_set() has been disabled for security reasons in /home/ofoghtal/public_html/test/libraries/joomla/session/session.php on line 122
[03-Oct-2015 10:23:44 Asia/Tehran] PHP Warning: ini_set() has been disabled for security reasons in /home/ofoghtal/public_html/test/libraries/joomla/session/session.php on line 125
[03-Oct-2015 10:23:44 Asia/Tehran] PHP Warning: ini_set() has been disabled for security reasons in /home/ofoghtal/public_html/test/libraries/joomla/session/session.php on line 938


please advise me to clear those errors, because I can't install some other plugins correctly.
thank you.

User avatar
toivo
Joomla! Exemplar
Joomla! Exemplar
Posts: 8739
Joined: Thu Feb 15, 2007 5:48 am
Location: Nottingham, UK
Contact:

Re: some errors in the first using of joomla after installin

Postby toivo » Sun Oct 04, 2015 10:36 am

Here is a topic about the same PHP warning from a few years back:
viewtopic.php?t=319477
Toivo Talikka, Global Moderator
my first programs were assembled and run in 16KB :)
http://archive.computerhistory.org/resources/text/GE/GE.GE-115SystemSoftware.1967.102646096.pdf#zoom=100

ofoghtalaee
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sun Oct 04, 2015 7:04 am

Re: some errors in the first using of joomla after installin

Postby ofoghtalaee » Mon Oct 05, 2015 11:53 am

thank you very much. I communicated with my host managers about this, but they said: this disabling has been consciously because of security reasons!
any way... my other question is why errors below are occurring continuously after every loading of website just after errors, mentioned previously?

/home/ofoghtal/public_html/plugins/content/word2link/word2link.php on line 256
[05-Oct-2015 14:57:02 Asia/Tehran] PHP Strict Standards: Only variables should be assigned by reference in /home/ofoghtal/public_html/modules/mod_joominastat/mod_joominastat.php on line 32
[05-Oct-2015 14:57:02 Asia/Tehran] PHP Strict Standards: Only variables should be assigned by reference in /home/ofoghtal/public_html/modules/mod_joominastat/mod_joominastat.php on line 58
[05-Oct-2015 14:57:02 Asia/Tehran] PHP Notice: Undefined variable: n in /home/ofoghtal/public_html/modules/mod_joominastat/mod_joominastat.php on line 95
[05-Oct-2015 14:57:02 Asia/Tehran] PHP Notice: Undefined variable: y in /home/ofoghtal/public_html/modules/mod_joominastat/mod_joominastat.php on line 153
[05-Oct-2015 14:57:02 Asia/Tehran] PHP Strict Standards: Only variables should be assigned by reference in /home/ofoghtal/public_html/modules/mod_joominastat/mod_joominastat.php on line 196
[05-Oct-2015 14:57:02 Asia/Tehran] PHP Notice: Undefined variable: ylip in /home/ofoghtal/public_html/modules/mod_joominastat/mod_joominastat.php on line 202
[05-Oct-2015 14:57:02 Asia/Tehran] PHP Strict Standards: Only variables should be assigned by reference in /home/ofoghtal/public_html/modules/mod_slicebox_slider/mod_slicebox_slider.php on line 34
[05-Oct-2015 14:57:02 Asia/Tehran] PHP Strict Standards: Only variables should be assigned by reference in /home/ofoghtal/public_html/modules/mod_slicebox_slider/helper.php on line 31
[05-Oct-2015 14:57:02 Asia/Tehran] PHP Strict Standards: Non-static method ModSlicebox_sliderHelper::getImagesFromFolder() should not be called statically in /home/ofoghtal/public_html/modules/mod_slicebox_slider/mod_slicebox_slider.php on line 63
[05-Oct-2015 14:57:02 Asia/Tehran] PHP Strict Standards: Only variables should be assigned by reference in /home/ofoghtal/public_html/modules/mod_slicebox_slider/mod_slicebox_slider.php on line 84
[05-Oct-2015 14:57:02 Asia/Tehran] PHP Notice: Undefined variable: sscss in /home/ofoghtal/public_html/modules/mod_slicebox_slider/mod_slicebox_slider.php on line 102
[05-Oct-2015 14:57:02 Asia/Tehran] PHP Strict Standards: Declaration of ArticleMetatagsContainer::saveKeywords() should be compatible with MetatagsContainer::saveKeywords($keywords, $itemId, $itemTypeId) in /home/ofoghtal/public_html/administrator/components/com_seoboss/classes/ArticleMetatagsContainer.php on line 15

User avatar
toivo
Joomla! Exemplar
Joomla! Exemplar
Posts: 8739
Joined: Thu Feb 15, 2007 5:48 am
Location: Nottingham, UK
Contact:

Re: some errors in the first using of joomla after installin

Postby toivo » Mon Oct 05, 2015 6:52 pm

why errors below are occurring continuously after every loading of website just after errors
Assigning non-variables by reference and undefined variables indicate that those modules are not following the coding standards of later versions of PHP.

Those functions may still work and you could filter all those messages from being logged by either turning off error reporting completely in Global Configuration or by fine tuning the error_reporting value of the php.ini in a local php.ini or a .htaccess file.

The authors of those extensions may have later versions where their PHP code has been cleaned up.
Toivo Talikka, Global Moderator
my first programs were assembled and run in 16KB :)
http://archive.computerhistory.org/resources/text/GE/GE.GE-115SystemSoftware.1967.102646096.pdf#zoom=100

ofoghtalaee
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sun Oct 04, 2015 7:04 am

Re: some errors in the first using of joomla after installin

Postby ofoghtalaee » Tue Oct 06, 2015 5:25 am

Therefore there is no worrying about these errors?

User avatar
toivo
Joomla! Exemplar
Joomla! Exemplar
Posts: 8739
Joined: Thu Feb 15, 2007 5:48 am
Location: Nottingham, UK
Contact:

Re: some errors in the first using of joomla after installin

Postby toivo » Tue Oct 06, 2015 8:07 am

If your site works and you are not concerned about the space used by the log file, there is nothing to worry. But it would be good to check with the authors of those extensions if they have a later version where the code triggering those notices has been cleaned up.
Toivo Talikka, Global Moderator
my first programs were assembled and run in 16KB :)
http://archive.computerhistory.org/resources/text/GE/GE.GE-115SystemSoftware.1967.102646096.pdf#zoom=100

ofoghtalaee
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Sun Oct 04, 2015 7:04 am

Re: some errors in the first using of joomla after installin

Postby ofoghtalaee » Tue Oct 06, 2015 9:09 am

thanks a lot dear Toivo!


Return to “قالب ها”

Who is online

Users browsing this forum: No registered users and 1 guest