Page 1 of 1

civicrm installed but gives parsing error

Posted: Wed Apr 04, 2007 10:08 pm
by mylesorme
Hi,

I've installed manually by ftp'ing the files and was delighted with a successful installation message.

When I go to civicrm Home, or any option under components > civicrm I get the following message:

Parse error: syntax error, unexpected ';', expecting '(' in /home/quarterd/public_html/administrator/components/com_civicrm/civicrm/CRM/Core/BAO/CustomField.php on line 912

Which is a line in...

  //get the $customOptionValueId if entity id is passed
        if ( !$customOptionValueId && $entityId ) {
            //get the entity table for the custom field
            require_once "CRM/Core/BAO/CustomQuery.php";
            $entityTable = CRM_Core_BAO_CustomQuery::$extendsMap[$customFieldExtend];

            $query = "
SELECT id
FROM civicrm_custom_value
WHERE custom_field_id = {$customFieldId} AND entity_table='{$entityTable}' AND entity_id={$entityId}";

            $customOptionValueId = CRM_Core_DAO::singleValueQuery( $query, $GLOBALS['_CRM_CORE_DAO']['_nullArray'] );
        }

the line begining $entityTable = Crm_ etc...

Here's some information about the installation i'm running:

Database Version:  4.1.21-standard
PHP Version: 4.4.4
Web Server: Apache/1.3.37 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_bwlimited/1.4 FrontPage/5.0.2.2635.SR1.2 mod_ssl/2.8.28 OpenSSL/0.9.7a
WebServer to PHP interface: cgi
Joomla! Version: Joomla! 1.0.12 Stable [ Sunfire ] 25 December 2006 01:00 UTC

I have installed the php4 version of civicrm...


ps - my hosts have been good to me in the past and I don't want to use the hosting solution lobo usually recommends.

Re: civicrm installed but gives parsing error

Posted: Fri Apr 06, 2007 3:51 am
by lobo
This was a bug in prior releases of v1.7 (rev 9101 and before) for php4. It is fixed in the latest beta release (rev 9184)

lobo