MySQL server has gone away

Discuss and receive support for the integration of CiviCRM and Joomla!
sappiajk
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Apr 08, 2007 9:45 am

MySQL server has gone away

Postby sappiajk » Tue Apr 10, 2007 12:41 pm

I had civicrm 1.5 installed on my php4 server, but my server was just recently upgraded to php5.  I had civicrm 1.5 uninstalled and double checked there were no files lingering around in any directory.  Since then I have tried to install civicrm 1.7 beta or 1.6  On both these I continuously get the same error no matter how I try to install the program.

Upload component - Failed 
DB function failed with error number 2006
MySQL server has gone away SQL=INSERT INTO jos_components VALUES( '', 'CiviCRM', 'option=com_civicrm', 0, 0, 'option=com_civicrm', 'CiviCRM', 'com_civicrm', 0, 'js/ThemeOffice/component.png', 0, '' )
SQL =
INSERT INTO jos_components
VALUES( '', 'CiviCRM', 'option=com_civicrm', 0, 0, 'option=com_civicrm', 'CiviCRM', 'com_civicrm', 0, 'js/ThemeOffice/component.png', 0, '' )

[ Continue ... ] 

Fatal error: Maximum execution time of 30 seconds exceeded in /home/siamncom/public_html/teamisaan/components/com_installer/installer.class.php on line 497

PLease help.  I have been trying on two different joomla installations on the same server with the same error.  I can't find anyone else who wrote about this error.  All other components install with out any problems.

Thanks

lobo
Joomla! Guru
Joomla! Guru
Posts: 502
Joined: Tue Aug 23, 2005 5:45 am

Re: MySQL server has gone away

Postby lobo » Tue Apr 10, 2007 11:04 pm

Most likely the below error is a php timeout error. Can u increase your php timeout for the install process to soemthing like 300 seconds. The forums have information on various ways u could increase the timeout

lobo

sappiajk
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Apr 08, 2007 9:45 am

Re: MySQL server has gone away

Postby sappiajk » Wed Apr 11, 2007 2:46 am

THank you for your quick response.

I searched the forums and found information about adding the timeout lines.

- I cant find a php.ini file in the joomla root or anywhere else.

- I can't figure out where to put it in .htaccess

- I tried to put it in config.php but that didn't make any difference.

**** Instead ****
I installed it using the manual install as instructed in the forum.  This time I get this:

Install Successful

CiviCRM has been successfully installed. 
Installation: Succesful 

Cannot execute DROP TABLE IF EXISTS civicrm_domain: DB Error: constraint violation


When I try to go to civicrm I get:

Fatal error: require_once() [function.require]: Failed opening required 'CRM/Core/Config.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/siamncom/public_html/teamisaan/administrator/components/com_civicrm/admin.civicrm.php on line 11

I am excited to have made some progress... but would love to get this component working.

Thanks for your help.

sappiajk
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Apr 08, 2007 9:45 am

Re: MySQL server has gone away

Postby sappiajk » Wed Apr 11, 2007 1:28 pm

Well I deleted the civi tables from the database and reinstalled.  Now everything is working.  Thanks


Return to “CiviCRM Support”

Who is online

Users browsing this forum: No registered users and 1 guest