3.0 Technical requirements doc page

Joomla! Documentation Workgroup

Moderator: Documentation

Locked
User avatar
PhilD
Joomla! Hero
Joomla! Hero
Posts: 2734
Joined: Sat Oct 21, 2006 10:20 pm
Location: Wisconsin USA
Contact:

3.0 Technical requirements doc page

Post by PhilD » Wed Aug 08, 2012 9:06 pm

The technical requirements document page at
http://www.joomla.org/technical-requirements.html

lists the requirements for J! 3.0 as:
Software Recommended Minimum
PHP 5.3.1 + 5.3.1 +
MySQL 5.1 + 5.1 +
(InnoDB support required)

I have installed a default install of Joomla! 3.0.0_Alpha1 for testing the FPA scripts functionality with J! 3.0 on a host reported as running
mysql 5.0.87-community with innodb support and it appears to work fine both with myISAM and innoDB.

(php is at 5.3.6)

I am trying to update the FPA (forum post assistant) script and would like to know the true minimum of both the mysql version and the php version in order to make the FPA script more accurate in it's reporting.
PhilD -- Unrequested PM's and/or emails may not get a response.
Security Moderator

User avatar
Chris Davenport
Joomla! Ace
Joomla! Ace
Posts: 1385
Joined: Thu Aug 18, 2005 8:57 am
Location: Shrewsbury, Shropshire, United Kingdom

Re: 3.0 Technical requirements doc page

Post by Chris Davenport » Wed Aug 08, 2012 9:49 pm

As far as I'm aware the minimum requirements are as per the page to which you refer. Since we don't yet know what features will be merged into 3.0 the minimum requirements shown are simply those inherited from the Platform. But even if 3.0 can be shown to work with earlier versions of MySQL at the time of launch, it is unlikely that we would want to officially support 3.0 on any earlier versions than those supported by the underlying Platform.

Chris.
Chris Davenport

Davenport Technology Services http://www.davenporttechnology.com/
Lion Coppice http://www.lioncoppice.org/

User avatar
PhilD
Joomla! Hero
Joomla! Hero
Posts: 2734
Joined: Sat Oct 21, 2006 10:20 pm
Location: Wisconsin USA
Contact:

Re: 3.0 Technical requirements doc page

Post by PhilD » Thu Aug 09, 2012 8:22 pm

I know it is Alpha but the version check during install passed it and hence the reason for the question. I also saw hard coded in the setup (installation/models/database.php) is 5.1.6 as a minimum but it apparently is not yet being used as a check for minimum.
Anyway, it is easy enough to change the code, but I didn't want to be fielding a bunch of questions about it after 3 is officially released.
PhilD -- Unrequested PM's and/or emails may not get a response.
Security Moderator


Locked

Return to “docs.joomla.org - Feedback/Information”