Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Need help with the Administration of your Joomla! 1.5 site? This is the spot for you.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
Cecil
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Apr 19, 2008 6:26 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by Cecil » Mon Apr 21, 2008 6:43 am

cyclist2918 wrote:What does the output of testmailer.php look like? I included it in the 1.0.x patch.

http://<your joomla site>/testmailer.php
Dear Cyclist, if you meant testmailer.php, i already put in /public_html/ (am i right?). After executing, then it comes up with several warnings.
Warning: main(libraries/phpmailer/phpmailer.php) [function.main]: failed to open stream: No such file or directory in /home/himpun/public_html/testmailer.php on line 6

Warning: main(libraries/phpmailer/phpmailer.php) [function.main]: failed to open stream: No such file or directory in /home/himpun/public_html/testmailer.php on line 6

Warning: main(libraries/phpmailer/phpmailer.php) [function.main]: failed to open stream: No such file or directory in /home/himpun/public_html/testmailer.php on line 6

Warning: main() [function.include]: Failed opening 'libraries/phpmailer/phpmailer.php' for inclusion (include_path='.:/usr/php4/lib/php:/usr/local/php4/lib/php') in /home/himpun/public_html/testmailer.php on line 6

Warning: main(libraries/phpmailer/smtp.php) [function.main]: failed to open stream: No such file or directory in /home/himpun/public_html/testmailer.php on line 7

Warning: main(libraries/phpmailer/smtp.php) [function.main]: failed to open stream: No such file or directory in /home/himpun/public_html/testmailer.php on line 7

Warning: main(libraries/phpmailer/smtp.php) [function.main]: failed to open stream: No such file or directory in /home/himpun/public_html/testmailer.php on line 7

Warning: main() [function.include]: Failed opening 'libraries/phpmailer/smtp.php' for inclusion (include_path='.:/usr/php4/lib/php:/usr/local/php4/lib/php') in /home/himpun/public_html/testmailer.php on line 7

Fatal error: Cannot instantiate non-existent class: jconfig in /home/himpun/public_html/testmailer.php on line 8
-------------
I got myself confused where as I uploaded your joomla-1.0.15-securemail.zip (with back-end modification.
Please feel free to c

 
Cecil
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Apr 19, 2008 6:26 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by Cecil » Mon Apr 21, 2008 8:02 am

dear cyclist please feel free to check it http://perhimpunanlink.or.id

khandu
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue Mar 25, 2008 11:02 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by khandu » Wed Apr 23, 2008 5:20 am

Hi man

still waiting for the Joomla 1.5.2RC3 + Gmail Hack

thanks

khandu
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue Mar 25, 2008 11:02 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by khandu » Wed Apr 23, 2008 12:58 pm

Hey guys

what I have just realised is that if u give SMTP server as

Code: Select all

gmail-smtp-in.l.google.com
it works.. no ssl required..

Cecil
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Apr 19, 2008 6:26 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by Cecil » Thu Apr 24, 2008 5:47 am

[quote="khandu"]Hey guys

what I have just realised is that if u give SMTP server as

Code: Select all

gmail-smtp-in.l.google.com
it works.. no ssl required..[/

I still don't get it. Where should I change it? in configuration.php ?

khandu
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue Mar 25, 2008 11:02 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by khandu » Thu Apr 24, 2008 7:37 am

what i did was simply put it in administrator panel

goto administrator --> Global Configuration --> server

Under mail settings here is what I have

Mailer SMTP Server
Mail from anyemailaddress@email.com
From Name whatuwant
Sendmail Path anything
SMTP Authentication anything as we are using SMTP
SMTP Username urusername@gmail.com
SMTP Password urpassword
SMTP Host gmail-smtp-in.l.google.com

Remember POP should be enabled in your gmail account..

that's it..

its working fine for me for last couple of days.. and the mail is not even going into the user's spam.. tested on couple of accounts..

:)

khandu
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue Mar 25, 2008 11:02 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by khandu » Fri Apr 25, 2008 2:20 am

Hey cyclist

have u made the 1.5.2 Gmail SSL patch?? still want to try it out :)

Cecil
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Apr 19, 2008 6:26 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by Cecil » Fri Apr 25, 2008 1:17 pm

khandu wrote:what i did was simply put it in administrator panel

goto administrator --> Global Configuration --> server

Under mail settings here is what I have

Mailer SMTP Server
Mail from anyemailaddress@email.com
From Name whatuwant
Sendmail Path anything
SMTP Authentication anything as we are using SMTP
SMTP Username urusername@gmail.com
SMTP Password urpassword
SMTP Host gmail-smtp-in.l.google.com

Remember POP should be enabled in your gmail account..

that's it..

its working fine for me for last couple of days.. and the mail is not even going into the user's spam.. tested on couple of accounts..

:)
Khamdu, i follow your instruction above, but i still received error warning:

Warning: fsockopen() [function.fsockopen]: unable to connect to gmail-smtp-in.l.google.com:25 in /home/himpun/public_html/includes/phpmailer/class.smtp.php on line 105
what's wrong with that?
cec

khandu
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue Mar 25, 2008 11:02 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by khandu » Fri Apr 25, 2008 2:11 pm

Hi

I have no idea.. hope U didnt edit any file manually..

all i did was put that config in the joomla admin and its working. no space nothing..

EDIT Now the mails are going in Junk Folder so this way is not very good but still is working for me as I am just doing testing...

khandu
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue Mar 25, 2008 11:02 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by khandu » Fri Apr 25, 2008 2:16 pm

Cecil wrote:
khandu wrote:what i did was simply put it in administrator panel

goto administrator --> Global Configuration --> server

Under mail settings here is what I have

Mailer SMTP Server
Mail from anyemailaddress@email.com
From Name whatuwant
Sendmail Path anything
SMTP Authentication anything as we are using SMTP
SMTP Username urusername@gmail.com
SMTP Password urpassword
SMTP Host gmail-smtp-in.l.google.com

Remember POP should be enabled in your gmail account..

that's it..

its working fine for me for last couple of days.. and the mail is not even going into the user's spam.. tested on couple of accounts..

:)
Khamdu, i follow your instruction above, but i still received error warning:

Warning: fsockopen() [function.fsockopen]: unable to connect to gmail-smtp-in.l.google.com:25 in /home/himpun/public_html/includes/phpmailer/class.smtp.php on line 105
what's wrong with that?
cec
I forgot. Put SMTP authentication as YES. Mine is working.. just check the last four options they should be correct..

Cecil
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sat Apr 19, 2008 6:26 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by Cecil » Fri Apr 25, 2008 6:59 pm

khandu wrote:
Cecil wrote:
khandu wrote:what i did was simply put it in administrator panel

goto administrator --> Global Configuration --> server

Under mail settings here is what I have

Mailer SMTP Server
Mail from anyemailaddress@email.com
From Name whatuwant
Sendmail Path anything
SMTP Authentication anything as we are using SMTP
SMTP Username urusername@gmail.com
SMTP Password urpassword
SMTP Host gmail-smtp-in.l.google.com

Remember POP should be enabled in your gmail account..

that's it..

its working fine for me for last couple of days.. and the mail is not even going into the user's spam.. tested on couple of accounts..

:)
Khamdu, i follow your instruction above, but i still received error warning:

Warning: fsockopen() [function.fsockopen]: unable to connect to gmail-smtp-in.l.google.com:25 in /home/himpun/public_html/includes/phpmailer/class.smtp.php on line 105
what's wrong with that?
cec
I forgot. Put SMTP authentication as YES. Mine is working.. just check the last four options they should be correct..
-----
Here is my setting in global con-mail
b] Mailer [/b] SMTP Server
Mail from LInk
From Name
Sendmail Path /usr/sbin/sendmail
SMTP Authentication Yes
SMTP Username link.jombang@gmail.com
SMTP Password *******
SMTP Host gmail-smtp-in.l.google.com
It still doesn't work. It surely will work with joomla.1.0.15, won't it? cause I use that version.
Still looking forward getting help from you and anyone else.

khandu
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue Mar 25, 2008 11:02 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by khandu » Sat Apr 26, 2008 7:33 am

Cecil wrote: Here is my setting in global con-mail
b] Mailer [/b] SMTP Server
Mail from LInk
From Name
Sendmail Path /usr/sbin/sendmail
SMTP Authentication Yes
SMTP Username link.jombang@gmail.com
SMTP Password *******
SMTP Host gmail-smtp-in.l.google.com
It still doesn't work. It surely will work with joomla.1.0.15, won't it? cause I use that version.
Still looking forward getting help from you and anyone else.
Well, I have from name given and I am using Joomla 1.5.2 ..

greenkoi
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Sun Jun 17, 2007 4:28 am

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by greenkoi » Mon Apr 28, 2008 10:55 pm

Gosh all mighty.

I've read over every post in this thread and am still banging my head over this one.

I have Google Hosted Apps for the domain: http://www.nashvillelearninggroup.com

As I've read over the posts, I followed some of the steps outlined to resolve this issue including installing the testmailer.php to the root. Feel free to check out the goods at: http://www.nashvillelearninggroup.com/testmailer.php

I'm running 1.0.15 and have applied the patch files but am at a loss to explain what the errors are and what to do to resolve.

Any help would be most appreciated.

greenkoi
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Sun Jun 17, 2007 4:28 am

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by greenkoi » Mon May 05, 2008 3:27 pm

cyclist2918 wrote:I sent an email to you....
bambaaacha wrote:doesn't work... :(

"SMTP Error. Connection with SMTP Server failed"
Can you provide a sample of the code which would enable SSL ?

I think I may be running into this issue and would like to give this a try. .

Thanks in advance,

greenkoi
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Sun Jun 17, 2007 4:28 am

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by greenkoi » Mon May 05, 2008 3:37 pm

cyclist2918 wrote:Make sure that ssl is enabled in your php.ini. That's why it wasn't working for bambaaacha.
What's the best way to accomplish this?

khandu
Joomla! Apprentice
Joomla! Apprentice
Posts: 21
Joined: Tue Mar 25, 2008 11:02 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by khandu » Wed May 14, 2008 11:33 am

Hey Cyclist?

Are you still going to be coming out with a new script for 1.5.3 for gmail SSL use?? waiting urgently for it

Thank You

User avatar
relaxssl
Joomla! Apprentice
Joomla! Apprentice
Posts: 35
Joined: Mon May 05, 2008 7:27 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by relaxssl » Mon May 19, 2008 6:18 pm

It's great!
Thank you very much.
Ubuntu 9.10+Vmware workstation 7 (winxp)+LAMP+phpMyAdmin+OpenVPN+OpenSSL+OpenWebMail
Website: http://www.sourcextra.com

bignellrp
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Fri Mar 21, 2008 1:00 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by bignellrp » Wed May 21, 2008 7:58 am

Hi guys,

I'm having a similar problem to that mentioned in the first post where all my registration emails to hotmail addresses are being blocked.

I am using Joomla 1.0.13 with CB 1.1 with the standard phpmailer.

I noticed a post in this thread that mentioned using gmail smtp without ssl. Can you do this without patching phpmailer? I need some way of getting registration mails to hotmail and aol users without them being blocked, as they dont even arrive in junk when sent to hotmail at the moment.

I tried gmail-smtp-in.l.google.com with smtp set to YES and my @googlemail.com username and password but no emails arrived to anyone, hotmail or otherwise.

So my questions:
1. Can you do this without patching phpmailer?
2. Is there an alternative email method when using joomla1.0.13 and cb1.1 to get round hotmail blocking registration emails?

buxpayer
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Tue May 27, 2008 2:52 am

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by buxpayer » Tue May 27, 2008 3:25 am

khandu wrote:Hey Cyclist?

Are you still going to be coming out with a new script for 1.5.3 for gmail SSL use?? waiting urgently for it

Thank You
Me too... I put the previous patch but dont work

ttdwd
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Fri May 30, 2008 8:36 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by ttdwd » Mon Jun 02, 2008 9:41 pm

I would also love a 1.5.2 patch 8) what happened to posting it on that particular monday :eek:

mastkalandar
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Fri May 23, 2008 10:04 am

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by mastkalandar » Tue Jun 17, 2008 12:20 pm

hi,
for joomla 1.0.15
i have given the following config:

Mailer: SMTP Server
Mail From: somename@somemail.com
From Name: myname
Sendmail Path: /usr/bin/senmail
SMTP Auth: Yes
SMTP User: my gmail Id
SMTP Pass: my password (gmail)
SMTP Host: smtp.gmail.com

but i get the following error:

fsockopen() [function.fsockopen]: unable to connect to smtp.gmail.com:25 (A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. ) in C:\xampp\htdocs\joomla\includes\phpmailer\class.smtp.php on line 105

Your email failed to send! Please try again.

Is there anything wrong in my setting or do i need some hack?

mknz
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Tue May 01, 2007 9:38 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by mknz » Wed Jun 18, 2008 7:52 pm

SMTP Host: smtp.gmail.com

should be

SMTP Host: gmail-smtp-in.l.google.com

BUT BEWARE!!!

My new Joomla 1.15 site which already has 4000+ members (all wanting to know their passwords now) got flagged as spamming by the google bulk filters ("temporarily"...which in my world is WAY too long).

just be careful

mastkalandar
Joomla! Intern
Joomla! Intern
Posts: 71
Joined: Fri May 23, 2008 10:04 am

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by mastkalandar » Thu Jun 19, 2008 5:45 am

well i still get the same error:
Warning: fsockopen() [function.fsockopen]: unable to connect to gmail-smtp-in.l.google.com:25 (A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. ) in C:\xampp\htdocs\joomla\includes\phpmailer\class.smtp.php on line 105
Your email failed to send! Please try again.

Is this a problem not concerning joomla,i mean some external settings are causing this?My php is not that good and i cannot figure it out but i need new registrants to be sent mail when their accounts are approved and am not able to get it done.

Tried sendmail.It says the email is sent but no mail is received by the recipient.
php mail is also not working.

Zjooj
Joomla! Apprentice
Joomla! Apprentice
Posts: 18
Joined: Mon Mar 03, 2008 11:37 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by Zjooj » Thu Jun 19, 2008 10:58 am

Had to throw my two cents in on this...

This does work for me in Joomla1.5.2 (Not sure of the RC# at the moment) but it only allows me to send to other GMail accounts. Anytime I send an email (new user back end and when requesting/signing up a user account on the front end) to any other domain @yahoo; @msn etc it responds with an error that states:

PHPMAILER_RECIPIENTS_FAILEDusername@domain.com

My settings match perfectly to the original settings that include gmail-smtp-in.l.google.com in the SMTP host under global config\server.

If I am missing something please let me know but I cannot get this to work for any other domain except GMail.

Jack (Zjooj) Hunter

P.S. my POP3 and IMAP are enabled in the GMail account being used as the SMTP server



***************
Best File Compression Around
DEL *.* = 100% Compression

sea
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Sun Jun 22, 2008 5:49 pm

SMTP via SSL and PHP.ini--help?

Post by sea » Sun Jun 22, 2008 11:29 pm

I need to get SMTP mail working. PHPmail and Sendmail work fine, but I am having difficulty with the recommended patch and can't find what changes need to be made to that PHP.ini file only that others have been told to check and fix their php.ini file.

I have tested the SMTP directly and it is working fine
I have tested sending mail through Joomla using PHPmail and Sendmail and those work fine.

I attempted usign SMTP without the ssl mod and it failed, with an "SMTP Error! Could not connect to SMTP host."

My SMTP host is not gmail... it will accept secure and unsecure connections. However this seemed to be a valid test of an unsecure connection and it failed.

I am running:
Joomla 1.5.3
MySQL is 14.7 Distribution 4.1.20
PHP is PHP/4.3.9

Multiple entries on this forum suggest that there is a problem with the SMTP configuration in the PHP.ini file, but I could not find and entry that tells me what it should be. This is all that is in my PHP.ini file regarding SMTP:
[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25
I then attempted the patch suggested in "Fixes to allow using ssl/tls enabled mailservers (gmail.com)"
http://forum.joomla.org/viewtopic.php?f=304&t=268623

I replace all the files provided, but my joomla administrator control pannel lost its templates and the site went down, so I reverted back.--I may have done this too quickly... I should have cleared the cached mysql queries and local cache first... I'm ready to give it another shot... but would like to kwow what my php.ini file should look like first.

Can anyone suggest how to update the PHP.ini file so that the SSL / SMTP patch will work?
Last edited by sea on Mon Jun 23, 2008 3:50 am, edited 1 time in total.

bignellrp
Joomla! Apprentice
Joomla! Apprentice
Posts: 27
Joined: Fri Mar 21, 2008 1:00 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by bignellrp » Mon Jun 23, 2008 2:32 am

Me too, i've now upgraded to 1.0.15 installed the patch and tried the testmailer, but get errors similar to those above saying:

Warning: include(libraries/phpmailer/phpmailer.php) [function.include]: failed to open stream: No such file or directory in /usr/local/www/joomla/testmailer.php on line 6

Warning: include() [function.include]: Failed opening 'libraries/phpmailer/phpmailer.php' for inclusion (include_path='.:/usr/local/share/pear') in /usr/local/www/joomla/testmailer.php on line 6

Warning: include(libraries/phpmailer/smtp.php) [function.include]: failed to open stream: No such file or directory in /usr/local/www/joomla/testmailer.php on line 7

Warning: include() [function.include]: Failed opening 'libraries/phpmailer/smtp.php' for inclusion (include_path='.:/usr/local/share/pear') in /usr/local/www/joomla/testmailer.php on line 7

Fatal error: Class 'JConfig' not found in /usr/local/www/joomla/testmailer.php on line 8


Will it matter that my gmail address is @googlemail.com . I guess at this stage it wont, as the errors look like they cant find files that the patch may have changed. Maybe like the post above suggests it could be my php.ini. Where do i find the file php.ini?

Madhumal
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Sun Jun 22, 2008 6:25 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by Madhumal » Wed Jun 25, 2008 4:32 am

Hi all...

I've tried to get the patch working, but soon as I've unpacked it into the Joomal directory, it gives this error.

Fatal error: Call to undefined method JFactory::getdate() in C:\wamp\www\Copy of SCIFlex\components\com_content\models\frontpage.php on line 178


Any ideas on whats causing this?

Thanks!

mitigated
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Mon Dec 17, 2007 1:20 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by mitigated » Sun Jul 06, 2008 11:34 pm

Beautiful! Worked great for 1.0.15, had to recompile php --with-openssl

User avatar
baijianpeng
Joomla! Guru
Joomla! Guru
Posts: 516
Joined: Mon Mar 20, 2006 3:17 pm
Location: China
Contact:

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by baijianpeng » Fri Aug 01, 2008 1:46 pm

I just wonder why Joomla! 1.5.5 still has no built-in suport for SSL SMTP such as Gmail server?

We should not use patch any more, this feature need to be inside Joomla! Core !
JoomlaGate - Chinese Joomla Users' Portal

http://www.joomlagate.com

llucop
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Wed Mar 05, 2008 10:50 pm

Re: Fixes to allow using ssl/tls enabled mailservers (gmail.com)

Post by llucop » Tue Aug 12, 2008 12:00 am

Hi everyone,

Has anybody succesfully implemented this hack on joomla 1.5.5? I've made all necessary changes but don't get the expected results. In fact I don't get anything at all no message to recipient, no copy to sender; upon submitting a contacts' message from the form, it does some proccesing (presumably, at least the progress bar fills up for a couple of seconds) and then back to a blank form. No messages though...

Perhaps I'm leaving something behind, Now that I think of firewall blocking 465 port?

Cheers, Lluco.

 

Locked

Return to “Administration 1.5”