Page 1 of 1

Editing special characters like ë,.. with JCE

Posted: Mon Jun 25, 2007 8:29 pm
by Koensan
Recently I moved my joomla-site from my localhost to a webhosts: dymka.syscom.be. On my localhost I never had any problems with characters like ë and é. I used a default installation. I could add these characters in my editors. I could see them appear exactly as I edited them in the html, on my site and in the database. Now on the new server I imported the same database. But now all these characters looked weird. I solved this by replacing them in my database by html code like ë  But when I try using these characters in the admin editors I experience things I  do not understand. When I add these characters in the Tiny_WYSIWYg editor, they are translated to code in the html, and I can properly save them and see them om my site. So essentially this works fine, but why did this ame editor not translate these characters into html on my localhost? When I try adding these characters with JCE, they are not translated into html code, and I cannot save or apply them. When I try to save contents with JCE containing such a character, only everything in front of that character is saved, the rest after the special character is lost.
So far I haven't changed any charset, so everthing is still in iso-8859-1 as installed. My database collation and chararcterset is utf-8_general (as my old local database) Anyone with an explanaition?

Re: Editing special characters like ë,.. with JCE

Posted: Fri Jul 06, 2007 10:17 am
by FrankA2
I just installed JC|E and set the charset to UTF-8 but it still stores the characters as &euml etc.

You have to get the JCE to output in RAW according to a reply in another thread but so far not found out how to do this...

Re: Editing special characters like ë,.. with JCE

Posted: Mon Jul 09, 2007 6:22 am
by Koensan
well, in the jce.php file I changed the setting from "raw" to "named", and now I get the proper html coding which I can save. So my problem is solved, allthough I still do not understand why I cannot save things with the "raw" setting.

Re: Editing special characters like ë,.. with JCE

Posted: Tue Jul 06, 2010 5:20 pm
by shoaibbd
I have the same problem with the character £ ' etc.... It doesn't save anything after special character. Could anyone please suggest me what to do? I am using joomla 1.5.11 and 1.15.18.
Many Thanks,
Shoaib

Re: Editing special characters like ë,.. with JCE

Posted: Tue Dec 18, 2012 10:04 am
by rezap
Is there a simple way in objective c to convert all special characters like ë,à,é,ä to the normal characters like e en a?