Dates displaying in wrong language!!

General questions regarding the use of languages and encoding issues in Joomla! 1.0.x. Multi-lingual site solutions can be discussed in the child board. Translation discussions are now separate and can be found in the Working Groups Area.
Locked
Aranzamendi
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Tue Feb 05, 2008 7:43 pm

Dates displaying in wrong language!!

Post by Aranzamendi » Thu Apr 24, 2008 1:34 am

I have an issue with dates. They are not displaying in Spanish anymore. I have Spanish installed, published, selected as default, and I have Country Locale set to es_ES@euro, as with my other Spanish Joomla installations, but it stopped working. Somehow, dates changed back to English and I have tried to fix it, but they won't change back to Spanish.

I have even checked the PHP configuration file, and all appears to be fine. Same as in admin panel.

I need to solve this, for this is a problem with a live site. Can anyone please help me? I posted a message some days ago, but nobody has answered me. So I posted a 2nd time. :(

User avatar
ot2sen
Joomla! Master
Joomla! Master
Posts: 10425
Joined: Thu Aug 18, 2005 9:58 am
Location: Hillerød - Denmark
Contact:

Re: Dates displaying in wrong language!!

Post by ot2sen » Thu Apr 24, 2008 6:23 am

Hi Aranzamendi,

When things suddenly stops working, perhaps your host made an update of their software.
Try changing the country locale to another value to see if this helps, like es_ES or es or ...

Should there be no change from that then you could try adding an extra line before the closing ?> in spanish.php
Like this:

Code: Select all

setlocale(LC_ALL,'es_ES');
?>
or perhaps the same locale value you used succesfully so far:

Code: Select all

setlocale(LC_ALL,'es_ES@euro');
?>
Ole Bang Ottosen
Dansk frivillig Joomla! support websted - joomla.dk
OpenTranslators Core Team opentranslators.org

Aranzamendi
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Tue Feb 05, 2008 7:43 pm

Re: Dates displaying in wrong language!!

Post by Aranzamendi » Sat Apr 26, 2008 12:17 am

I thank you for taking your time to comment on this post.

I tried your recommendation, but the problem still the same. Actually, I remember that my hosting company sent a message warning a PHP shift to PHP5, discontinuing PHP4 use and/or support. Maybe this has to do; I will try to check when this change was to take place so I can comment here.

Anyway, I tried changing to both values in Spanish.php, as you recommended, but still the same. The date is partially in Spanish, for it displays "Wednesday, 23 de April de 2008". As you can see, the "de" is part of the Spanish date format, but the day and the month get displayed in English.

Also, I host other sites in the same root folder and hosting account, and I just noticed that the problem is with the server, since those other sites now have the same problem with the date. So this, definitely should have to do with version change from PHP4 to PHP5, I guess.

My Joomla version for both sites is 1.0.8; would this also have anything to do?

Do you have any suggestions?

User avatar
PhilD
Joomla! Hero
Joomla! Hero
Posts: 2734
Joined: Sat Oct 21, 2006 10:20 pm
Location: Wisconsin USA
Contact:

Re: Dates displaying in wrong language!!

Post by PhilD » Wed Apr 30, 2008 3:18 pm

I would contact your hosts tech support and explain what is happening to your sites after their upgrade to php5. Give them the examples you provided here. There may have been a setting they forgot about.
PhilD -- Unrequested PM's and/or emails may not get a response.
Security Moderator

Aranzamendi
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Tue Feb 05, 2008 7:43 pm

Re: Dates displaying in wrong language!!

Post by Aranzamendi » Wed Apr 30, 2008 9:15 pm

I will try to contact them to see if they can help me. I am not sure if the update took place, but I will check now and re-post.


Locked

Return to “Language - 1.0.x”