Content is not shown after move to another server

General questions relating to Joomla! There are other boards for more specific help on Joomla! features and extensions.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
sgentil
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Jan 28, 2008 6:00 pm

Content is not shown after move to another server

Post by sgentil » Thu Aug 06, 2015 8:36 pm

Hi,
I have a problem with my Joomla 1.0.14 Site. I know I probably shouldn't use this version anymore but I'm hosting the site for a friend and he doesn't want to upgrade to a new version :-(

Anyway .. I recently moved all my domains and sites to a new server.

Old Server:
Ubuntu 10.04.4 LTS
Apache/2.2.14
PHP 5.3.2-1ubuntu4.18 with Suhosin-Patch

New Server:
Ubuntu 14.04.2 LTS
Apache/2.4.7
PHP 5.5.9-1ubuntu4.9

Additionaly installed PHP 5.3.2 since Joomla 1.0 does not work with php 5.5
The Joomla1.0 site is served by php5.3.2 using the fastcgi module.
I followed this instruction ( http://zgadzaj.com/how-to-install-php- ... buntu-1204)

The site http://www.hutturmadler.com is displayed and the admin interface also works, but no content is shown.
I can't figure out what is the problem and hope someone can help me.

The old site is still online http://s15561098.onlinehome-server.info/ to compare the content.

I really would apreciate any help :-)

Thanks
Sebastian

itoctopus
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4026
Joined: Mon Nov 25, 2013 4:35 pm
Location: Montreal, Canada
Contact:

Re: Content is not shown after move to another server

Post by itoctopus » Thu Aug 06, 2015 9:15 pm

There must be an error due to compatibility issues between Joomla 1.x and newer environments. Max out your error reporting and post back the errors that you see on the website once you do that here.
http://www.itoctopus.com - Joomla consulting at its finest
https://twitter.com/itoctopus - Follow us on Twitter

sgentil
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Jan 28, 2008 6:00 pm

Re: Content is not shown after move to another server

Post by sgentil » Fri Aug 07, 2015 8:04 am

These errors are reported in the apache error log. Does this help?

[Fri Aug 07 08:02:46.639323 2015] [cgi:error] [pid 6921] [client 194.25.30.13:65406] AH01215: PHP Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0, referer: http://www.hutturmadler.com//index.php? ... &Itemid=11
[Fri Aug 07 08:02:46.642190 2015] [cgi:error] [pid 6921] [client 194.25.30.13:65406] AH01215: PHP Deprecated: Assigning the return value of new by reference is deprecated in /home/www/htdocs/hutturmadler/DEFAULT/includes/joomla.php on line 836, referer: http://www.hutturmadler.com//index.php? ... &Itemid=11
[Fri Aug 07 08:02:46.724439 2015] [cgi:error] [pid 6921] [client 194.25.30.13:65406] AH01215: PHP Warning: Parameter 2 to frontpage() expected to be a reference, value given in /home/www/htdocs/hutturmadler/DEFAULT/includes/Cache/Lite/Function.php on line 100, referer: http://www.hutturmadler.com//index.php? ... &Itemid=11
[Fri Aug 07 08:02:46.727827 2015] [cgi:error] [pid 6921] [client 194.25.30.13:65406] AH01215: PHP Deprecated: Function ereg() is deprecated in /home/www/htdocs/hutturmadler/DEFAULT/components/com_joomlastats/joomlastats.inc.php on line 309, referer: http://www.hutturmadler.com//index.php? ... &Itemid=11
[Fri Aug 07 08:02:46.763585 2015] [cgi:error] [pid 6921] [client 194.25.30.13:65406] AH01215: PHP Warning: preg_match(): Delimiter must not be alphanumeric or backslash in /home/www/htdocs/hutturmadler/DEFAULT/includes/pathway.php on line 280, referer: http://www.hutturmadler.com//index.php? ... &Itemid=11
[Fri Aug 07 08:02:46.763739 2015] [cgi:error] [pid 6921] [client 194.25.30.13:65406] AH01215: PHP Warning: preg_match(): Delimiter must not be alphanumeric or backslash in /home/www/htdocs/hutturmadler/DEFAULT/includes/pathway.php on line 313, referer: http://www.hutturmadler.com//index.php? ... &Itemid=11
[Fri Aug 07 08:02:46.765950 2015] [cgi:error] [pid 6921] [client 194.25.30.13:65406] AH01215: PHP Deprecated: Function split() is deprecated in /home/www/htdocs/hutturmadler/DEFAULT/modules/mod_mainmenu.php on line 52, referer: http://www.hutturmadler.com//index.php? ... &Itemid=11
[Fri Aug 07 08:02:46.848749 2015] [cgi:error] [pid 6921] [client 194.25.30.13:65406] AH01215: PHP Deprecated: Function ereg_replace() is deprecated in /home/www/htdocs/hutturmadler/DEFAULT/components/com_jcalpro/config.inc.php on line 364, referer: http://www.hutturmadler.com//index.php? ... &Itemid=11
[Fri Aug 07 08:02:46.858431 2015] [cgi:error] [pid 6921] [client 194.25.30.13:65406] AH01215: PHP Deprecated: mktime(): The is_dst parameter is deprecated in /home/www/htdocs/hutturmadler/DEFAULT/components/com_jcalpro/include/functions.inc.php on line 843, referer: http://www.hutturmadler.com//index.php? ... &Itemid=11
[Fri Aug 07 08:02:46.858911 2015] [cgi:error] [pid 6921] [client 194.25.30.13:65406] AH01215: PHP Deprecated: Function ereg_replace() is deprecated in /home/www/htdocs/hutturmadler/DEFAULT/components/com_jcalpro/include/functions.inc.php on line 1309, referer: http://www.hutturmadler.com//index.php? ... &Itemid=11
[Fri Aug 07 08:02:46.859007 2015] [cgi:error] [pid 6921] [client 194.25.30.13:65406] AH01215: PHP Deprecated: mktime(): The is_dst parameter is deprecated in /home/www/htdocs/hutturmadler/DEFAULT/components/com_jcalpro/include/functions.inc.php on line 843, referer: http://www.hutturmadler.com//index.php? ... &Itemid=11
[Fri Aug 07 08:02:46.859093 2015] [cgi:error] [pid 6921] [client 194.25.30.13:65406] AH01215: PHP Deprecated: mktime(): The is_dst parameter is deprecated in /home/www/htdocs/hutturmadler/DEFAULT/components/com_jcalpro/include/functions.inc.php on line 843, referer: http://www.hutturmadler.com//index.php? ... &Itemid=11
[Fri Aug 07 08:02:46.859190 2015] [cgi:error] [pid 6921] [client 194.25.30.13:65406] AH01215: PHP Deprecated: mktime(): The is_dst parameter is deprecated in /home/www/htdocs/hutturmadler/DEFAULT/components/com_jcalpro/include/functions.inc.php on line 843, referer: http://www.hutturmadler.com//index.php? ... &Itemid=11

sgentil
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Jan 28, 2008 6:00 pm

Re: Content is not shown after move to another server

Post by sgentil » Fri Aug 07, 2015 8:09 am

... the same errors are reported in the apache log on the old server on which the site was displayed correctly

westwing
Joomla! Intern
Joomla! Intern
Posts: 68
Joined: Mon May 01, 2006 7:31 pm

Re: Content is not shown after move to another server

Post by westwing » Thu Aug 13, 2015 9:52 pm

I recently moved Joomla 1 to a new server too. We installed a (Cpanel) plugin called 'PHP Selector' which allows you to use different PHP versions for different folders! I'm running mine with NO errors on PHP 5.2.

sgentil
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Jan 28, 2008 6:00 pm

Re: Content is not shown after move to another server

Post by sgentil » Fri Aug 14, 2015 5:47 am

For me the solution was also to downgrade to php5.2.17!


Locked

Return to “General Questions - 1.0.x”