Page 1 of 1

Can't post a new page

Posted: Fri Dec 07, 2018 6:47 pm
by mjc0501
I am using version 1.0.15, yes we realize this is way outdated. We will address that later. Right now, I am trying to post a new page to the web site. I'm logged in as a super admin, and have control over the site. BUT when I publish the page, it shows up with a lock on it and says it was never fully finished publishing.

Am I missing something? Or is there an issue with our joomla? If I am missing something, please, tell me what that is.

Thank you.

Re: Can't post a new page

Posted: Fri Dec 07, 2018 7:03 pm
by sozzled
There is an issue with **your** Joomla yes. 8)

J! 1.0.15 became obsolete and unsupported nearly eleven years ago (see https://www.cmswire.com/cms/web-cms/pro ... 005071.php). Perhaps you've been asleep at the wheel?

Re: Can't post a new page

Posted: Fri Dec 07, 2018 10:04 pm
by Per Yngve Berg
The lock means that someone editing the article closed the window. Do a check in.

Re: Can't post a new page

Posted: Sat Dec 08, 2018 12:06 pm
by mjc0501
I did a global check in and the page is still not showing up on the front end of the site, also went back and published it again. When I go the the front of the site, and run a site search on the page the page comes up in the search but when you click on the link, you get this message instead of the page

"You are not authorised to view this resource.
You need to login."

Re: Can't post a new page

Posted: Sat Dec 08, 2018 5:31 pm
by Per Yngve Berg
A Check In makes the padlock go away and you can edit the article again. Check what access level you have set.

Re: Can't post a new page

Posted: Sat Dec 08, 2018 11:21 pm
by mjc0501
Per Yngve Berg wrote:
Sat Dec 08, 2018 5:31 pm
A Check In makes the padlock go away and you can edit the article again. Check what access level you have set.
I have super admin access. I went back to it and posted it, saved it, applied it, and posted and it is still not showing up.

Re: Can't post a new page

Posted: Sun Dec 09, 2018 11:00 am
by Per Yngve Berg
1) Is the article set to Public?

2) Is the article marked as Frontpage?

Re: Can't post a new page

Posted: Sun Dec 09, 2018 11:36 am
by mjc0501
Per Yngve Berg wrote:
Sun Dec 09, 2018 11:00 am
1) Is the article set to Public?

2) Is the article marked as Frontpage?
Yes it is set as public, and no it is not set as front page. We have a section of products and this is an added product and it won't show up once we publish it. It's there but you have to be logged in to see it.

Re: Can't post a new page

Posted: Mon Feb 11, 2019 5:16 pm
by feeling1
This is quite an old issue. I encountered the same problem, although my Joomla is on version 3.8.

You may check the source of the problem by setting error reporting to maximum in the Global Configuration via Global Configuration > Server Tab > Error Reporting. From there, I saw that the problem was caused by a plugin, which was not used. I deactivated the plugin- this fixed the problem.

This is how I determined the source of the problem. On the administration, I raised the error reporting to maximum: Global Configuration > Server tab > Error Reporting (changed from System Default to Maximum)

I saw the following errors: Notice: Undefined variable: plugin in */home5//public_html/plugins/system/connectdaily/connectdaily.php on line 42

Fatal error: Call to a member function logError() on null in
luxury watches/home5//public_html/plugins/system/connectdaily/connectdaily.php on line 42*

I deactivated the connectdaily plugin. The fix worked. I am now able to add and edit articles again.

I am still not sure where the connectdaily plugin is used for. If ever the website will need it, I will just reinstall the plugin.

Re: Can't post a new page

Posted: Mon Feb 11, 2019 5:59 pm
by sozzled
feeling1 wrote:
Mon Feb 11, 2019 5:16 pm
This is quite an old issue. I encountered the same problem, although my Joomla is on version 3.8.
Your problem has absolutely nothing in common with this discussion topic. Perhaps you can't "post a new page" but look at the first post in this discussion. This discussion relates to someone who is using J! 1.0.8, not J! 3.8.something!

Perhaps you have not heard of topic hijacking?

Anyway, J! 3.8.whatever is also outdated. J! 3.8.0 was released in September 2017. How about you update your website to the current version of J! (i.e. 3.9.2) and, in future, look more carefully where you post your questions and read the forum rules.

Re: Can't post a new page

Posted: Mon Feb 11, 2019 6:03 pm
by gws
@sozzled its word press spam from feeling1.....

Re: Can't post a new page

Posted: Mon Feb 11, 2019 6:09 pm
by sozzled
Thanks, @gws, a quick check of the "connectdaily" thing shows a relationship to WP. Damn nuisance these forum grafittists, eh?

The OP hasn't returned to the topic in over two months. Maybe we should just ask the forum moderators to lock this damn thing?