Page 1 of 1

[réglé] Message d'erreur après installation sur serveur FREE

Posted: Sun Sep 23, 2007 6:05 pm
by Happycastor
Bonjour à tous et toutes,

Je biens de faire ma première installation sur les pages perso de free. J'ai suivi le guide Joomla pour les nuls et tout c'est bien déroulé (j'ai bien supprimé le répertoire /installation/). Le seul hic c'est que j'ai bien accès à mon back-office mais quand je tape l'url du site pour voir le site par défaut j'ai un message d'erreur qui s'affiche (cf. ci dessous).

Ma version de Joomla est 1.0.13

Merci par avance pour votre aide
Bonne soirée

Message d'erreur :
Warning: call_user_func_array() [function.call-user-func-array]: First argumented is expected to be a valid callback, 'HTML_content::show' was given in /mnt/113/free.fr/8/4/d.saugeon/JOOOMLAAAA/includes/Cache/Lite/Function.php on line 92

Warning: call_user_func_array() [function.call-user-func-array]: First argumented is expected to be a valid callback, 'HTML_content::show' was given in /mnt/113/free.fr/8/4/d.saugeon/JOOOMLAAAA/includes/Cache/Lite/Function.php on line 92

Warning: call_user_func_array() [function.call-user-func-array]: First argumented is expected to be a valid callback, 'HTML_content::show' was given in /mnt/113/free.fr/8/4/d.saugeon/JOOOMLAAAA/includes/Cache/Lite/Function.php on line 92

Fatal error: Undefined class name 'html_content' in /mnt/113/free.fr/8/4/d.saugeon/JOOOMLAAAA/components/com_content/content.php on line 1319

Re: Message d'erreur après installation sur serveur FREE

Posted: Fri Sep 28, 2007 4:09 pm
by ouly
Bonjour Happycastor,
Vérifiez que tous les fichiers aient été correctement transférés. Notamment le fichier /components/com_content/content.html.php (pour ce qui concerne l'erreur).

Il y a ensuite probablement (non vérifié) un couac dans le fichier /components/com_content/content.php ligne 1731 (pour ce qui concerne les avertissements) :

Code: Select all

	$cache->call( 'HTML_content::show', $row, $params, $access, $page );
à remplacer par :

Code: Select all

	$cache->call( array( 'HTML_content', 'show' ), $row, $params, $access, $page );
Ouly

Re: Message d'erreur après installation sur serveur FREE

Posted: Sun Sep 30, 2007 3:32 pm
by Happycastor
Merci ça fonctionne !
Effectivement le fichier : content.html.php affichait 0 Ko

Maintenant tout va bien !
Bonne journée

Happycastor

Re: Message d'erreur après installation sur serveur FREE

Posted: Tue Oct 02, 2007 9:55 am
by HiTman77
ouly wrote: Bonjour Happycastor,
Vérifiez que tous les fichiers aient été correctement transférés. Notamment le fichier /components/com_content/content.html.php (pour ce qui concerne l'erreur).

Il y a ensuite probablement (non vérifié) un couac dans le fichier /components/com_content/content.php ligne 1731 (pour ce qui concerne les avertissements) :

Code: Select all

	$cache->call( 'HTML_content::show', $row, $params, $access, $page );
à remplacer par :

Code: Select all

	$cache->call( array( 'HTML_content', 'show' ), $row, $params, $access, $page );
Ouly
Thanks for this you are a ninja. I could not find this in English anywhere.

In the end all I did was over write the /components/com_content/ folder with the new version and every thisng worked fine.

Thanks again..
HiTman77