URLs vers les catégories depuis une page de contenu de section incorrects

Support et utilisation de Joomla! 1.0.x : gérer le contenu, les menus et les extensions natives.

Moderators: Aidan38, sarki

Forum rules
Règles du forum
Locked
slasher-fun
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Oct 03, 2007 5:55 pm
Location: à Montréal jusque fin décembre, retour à Paris après
Contact:

URLs vers les catégories depuis une page de contenu de section incorrects

Post by slasher-fun » Fri Oct 26, 2007 5:45 pm

Bonjour,

Le topo est assez simple : j'ai une section "blog" dans laquelle se trouvent plusieurs catégories. Lorsque je vais sur la page de catégorie de contenu de la section "blog", j'ai bien les derniers articles publiés, et la liste des catégories dans le menu de gauche avec entre parenthèses le bon nombre d'articles de chaque catégorie.

Problème : Le lien vers les catégories est de la forme http://mon.site.com/content/category/1/ ... catégorie/ . Il y a un "/1" en trop, ce qui fait que quelle que soit la catégorie que je demande je tombe systématiquement sur celle qui a l'ID #1, je ne vois absolument pas d'où vient ce "/1" en trop...

Si ça peut aider, page où se pose le problème : http://beta.iteam.org/site/blogcategory/
Vue depuis l'interface d'administration : http://img266.imageshack.us/my.php?imag ... ratwv0.png

Merci d'avance de l'aide que vous pourriez m'apporter :)
Last edited by slasher-fun on Fri Oct 26, 2007 5:48 pm, edited 1 time in total.

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18881
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: URLs vers les catégories depuis une page de contenu de section incorrects

Post by infograf768 » Sat Oct 27, 2007 8:53 am

Vous avez des soucis avec une extension tierce-partie SEF.
Merci de la spécifier si vous désirez une aide éventuelle.
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

User avatar
dec
Joomla! Guru
Joomla! Guru
Posts: 502
Joined: Mon Apr 03, 2006 2:06 pm

Re: URLs vers les catégories depuis une page de contenu de section incorrects

Post by dec » Sun Oct 28, 2007 3:30 pm

Effectivement, ça sent le SEF  ;)

slasher-fun
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Oct 03, 2007 5:55 pm
Location: à Montréal jusque fin décembre, retour à Paris après
Contact:

Re: URLs vers les catégories depuis une page de contenu de section incorrects

Post by slasher-fun » Sun Oct 28, 2007 6:31 pm

Il semblerait que le SEF utilisé soit OpenSEF version 2.0.0-RC5_SP2 (je ne suis pas le concepteur du site, donc c'est ce que j'ai trouvé dans la section "composants installés")  :)

User avatar
dec
Joomla! Guru
Joomla! Guru
Posts: 502
Joined: Mon Apr 03, 2006 2:06 pm

Re: URLs vers les catégories depuis une page de contenu de section incorrects

Post by dec » Mon Oct 29, 2007 9:34 am

Essaye en desativant, pour voir si tes liens sont Ok.
Ensuite, vois dans les réécritures si tu n'as pas un "1" qui s'est glissé quelquepart.
Un membe de ce forum a eu un problème un peu identique; de mémoire, cela a été réglé en changeant de SEF.

slasher-fun
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Oct 03, 2007 5:55 pm
Location: à Montréal jusque fin décembre, retour à Paris après
Contact:

Re: URLs vers les catégories depuis une page de contenu de section incorrects

Post by slasher-fun » Sun Nov 25, 2007 1:55 am

Bonjour,

Pas eu le temps d'avancer dans le problème d'où le temps à répondre  :-[

Même après désactivation d'OpenSEF, le problème perdure : il y a toujours un "/1" de trop... Le problème vient donc d'ailleurs, mais je ne vois pas d'où après avoir parcouru une bonne partie des menus...

User avatar
mejean
Joomla! Hero
Joomla! Hero
Posts: 2714
Joined: Thu Aug 18, 2005 12:28 pm
Location: viewforum.php?f=19
Contact:

Re: URLs vers les catégories depuis une page de contenu de section incorrects

Post by mejean » Wed Nov 28, 2007 6:04 pm

Désactive également le SEF dans "Configuration globale" par défaut de Joomla! et renomme le fichier .htaccess en htaccess.txt
Jérôme Bussière - simple utilisateur
www.cardabelle.net

slasher-fun
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Oct 03, 2007 5:55 pm
Location: à Montréal jusque fin décembre, retour à Paris après
Contact:

Re: URLs vers les catégories depuis une page de contenu de section incorrects

Post by slasher-fun » Wed Nov 28, 2007 6:20 pm

Sans tout ça les liens en questions deviennent du type http://beta.iteam.org/site/blogcategory ... d=99999999
(j'ai remplacé l'id par "un_id" dans l'URL exemple)
Donc j'imagine que le "/1" de trop  vient du "sectionid", après comment lui faire "oublier" ça...

slasher-fun
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Oct 03, 2007 5:55 pm
Location: à Montréal jusque fin décembre, retour à Paris après
Contact:

Re: URLs vers les catégories depuis une page de contenu de section incorrects

Post by slasher-fun » Wed Nov 28, 2007 6:46 pm

Ah un autre problème est apparu avec la désactivation du SEF : lorsque je clique sur le nom d'une catégorie dans "Blog", j'ai donc bien maintenant le contenu de cette catégorie, mais le titre de la page (à coté du nom du navigateur dans le titre de la fenêtre) est alors "trombinoscope" qui est le titre d'une autre section...

User avatar
infograf768
Joomla! Master
Joomla! Master
Posts: 18881
Joined: Fri Aug 12, 2005 3:47 pm
Location: **Translation Matters**

Re: URLs vers les catégories depuis une page de contenu de section incorrects

Post by infograf768 » Wed Nov 28, 2007 7:05 pm

Je me trompe où c'est résolu?
Titres et contenus OK ici
Jean-Marie Simonet / infograf · http://www.info-graf.fr
---------------------------------
ex-Joomla Translation Coordination Team • ex-Joomla! Production Working Group

slasher-fun
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Wed Oct 03, 2007 5:55 pm
Location: à Montréal jusque fin décembre, retour à Paris après
Contact:

Re: URLs vers les catégories depuis une page de contenu de section incorrects

Post by slasher-fun » Wed Nov 28, 2007 7:07 pm

J'ai désactivé le SEF et les titres dynamiques là, donc le titre n'est plus dynamique (titre faux dans certains cas sinon) et j'ai perdu l'avantage du SEF (puisqu'il est désactivé)
Problème pas résolu selon moi...


Locked

Return to “1.0 - Questions générales”