Page 1 of 1

Optimisation de mon site...trop lent!!

Posted: Thu Nov 29, 2007 6:52 pm
by sofia
Bonjour
J'ai bcp de problemes d'optimisation d'un site sous joomla.
Les temps d'acces sont super long...le serveur croule sous des requetes qui font des time out, il y a trop de process et la bdd a l'air vraiment pas optimisée.

Vu que je n'y connait rien en developpement & mysql j'ai besoin de votre aide pour voir d'ou vient le probleme (identification du composant/module ou autre qui déconne) et le corriger.
Voici un screenshot du  tableau de bord mysql. Bcp de points sont en rouges notemment :

Voici les points en rouge a corriger :

Code: Select all

Slow_queries : 26
Innodb_buffer_pool_reads  	12
Handler_read_rnd  	6 209 k
Handler_read_rnd_next  	106 M
Qcache_lowmem_prunes  	62 k
Created_tmp_disk_tables  	8 930  	
Select_full_join  	9 093  	
Select_range_check  	5
Opened_tables  	911 
Table_locks_waited  	15 k 

Image
Comment identifier la source des problemes?
Comment optimser tout ce bazard d'une maniere assez simple (mes connaissances dans ce domaine sont light)

le site [url=http://"http://generationsfm.com"]http://generationsfm.com[/url]

Re: Optimisation de mon site...trop lent!!

Posted: Sun Dec 02, 2007 3:42 pm
by Pachat
A mon avis, tout tient dans la première ligne : Server : localhost

Les performances devraient être complètement différentes sur un vrai serveur LAMP

Re: Optimisation de mon site...trop lent!!

Posted: Mon Dec 03, 2007 5:06 pm
by sofia
ok ..merci de ta réponse..mais que veux tu dire exactement?
Le serveur qui heberge n'est pas bon?
ce serait un meilleur si ct lamp ? et qu'est ce : un os, un logiciel, .?

Par ailleurs je ne pense pas que je changerai de serveur comme ca.. Comment donc dans un premier temps améliorer les points en rouge?

ca vous dit quelquechose?

Re: Optimisation de mon site...trop lent!!

Posted: Mon Dec 03, 2007 6:38 pm
by Pachat
Server : localhost ici désigne la version qui est sur mon PC et qui est très lente par rapport au serveur distant

Re: Optimisation de mon site...trop lent!!

Posted: Mon Dec 03, 2007 7:35 pm
by sofia
je comprends pas..
C'est ce que m'affiche le mysql du serveur distant...je ne suis pas en local.  ??? ???

Re: Optimisation de mon site...trop lent!!

Posted: Mon Dec 03, 2007 8:46 pm
by Pachat
Ok.

J! 1.0 n'est pas optimisé au niveau des requêtes. C'est pour cela que tout a été réécrit dans J! 1.5 (je crois me souvenir qu'ils ont divisé par 3 les requêtes) C'est dire que ça a été un sacré boulot.

je suis allé voir ton site. Il y a beaucoup de multi-media. Est-ce que ça ne serait pas cela qui mettrai le serveur à genoux.
Moi, je mettrai tout le téléchargement en streaming sur un autre serveur et ne laisserais que Joomla et sa base sur celui-là.