Problème d'affichage des caractères accentués

Support et utilisation de Joomla! 1.0.x : gérer le contenu, les menus et les extensions natives.

Moderators: sarki, Aidan38

Forum rules
Règles du forum
El Doctor
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Jul 16, 2009 10:43 am

Problème d'affichage des caractères accentués

Postby El Doctor » Thu Sep 24, 2009 7:25 am

Bonjour,
j'ai un site sous joomla 1.0.13 qui fonctionnait très bien, jusqu'à ce que je cherche a installer un composant de gestion de calendrier. Après plusieurs installation et désinstallation de divers composants, j'ai fini par trouvé mon bonheur avec Google Calendar.

Cependant, j'ai depuis un problème d'affichage des caractères accentués sur tout le site (remplacés par: �), dans les articles, dans le forum (fireboard), dans l'interface d'administration ...

Il semblerait que se soit un problème de format d'encodage, mais je ne sais pas quel est le fichier qui a été modifié et donc comment corriger le problème.

En regardant la BDD je vois qu'un bonne partie des tables (environ 2/3) est en interclassement "latin1_swedish_ci", et les autres sont en "latin_general_ci", est-ce normal ?!


Merci de votre aide

User avatar
sebiseb
Joomla! Guru
Joomla! Guru
Posts: 696
Joined: Fri Aug 19, 2005 1:04 pm
Location: IdF - Centre
Contact:

Re: Problème d'affichage des caractères accentués

Postby sebiseb » Thu Sep 24, 2009 5:32 pm

Il faut que tu accordes le codage de ta bdd avec la configuration du codage de caractères dans l'administration.
Sébastien Pillias - french forum moderator

Vous êtes sur un forum d'entre aide : aidez les autres, les autres vous aideront !
Aidez-les à vous aidez en utilisant le fichier jtspost_fr.php : http://forum.joomla.org/viewtopic.php?t=272866 !

El Doctor
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Jul 16, 2009 10:43 am

Re: Problème d'affichage des caractères accentués

Postby El Doctor » Thu Sep 24, 2009 5:54 pm

Merci pour ta réponse, je me doutais que cela avait un rapport avec le format d'encodage, mais comme je l'ai indiqué dans mon premier post, je ne sais pas comment solutionner ce problème.

Est ce qu'il faut que je change le codage des tables dans la base de donnée, pour les mettre en "latin_general_ci" ?

Si vous pouviez me préciser un peu la démarche a suivre, cela m'aiderai bien.

Merci

El Doctor
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Thu Jul 16, 2009 10:43 am

Re: Problème d'affichage des caractères accentués

Postby El Doctor » Thu Sep 24, 2009 8:10 pm

Je viens de convertir toutes les tables de ma base de données en charset UTF8 et interclassement utf8_general_ci ...
cela n'a en rien solutionné mon problème, je suppose donc qu'il faut que je définisse le jeu de caractère utilisé dans un fichier de configuration de joomla, mais lequel ?!?

User avatar
sebiseb
Joomla! Guru
Joomla! Guru
Posts: 696
Joined: Fri Aug 19, 2005 1:04 pm
Location: IdF - Centre
Contact:

Re: Problème d'affichage des caractères accentués

Postby sebiseb » Fri Sep 25, 2009 8:26 pm

Je ne sais plus très bien comment on le fait dans joomla 1.x ? :-[
Sébastien Pillias - french forum moderator

Vous êtes sur un forum d'entre aide : aidez les autres, les autres vous aideront !
Aidez-les à vous aidez en utilisant le fichier jtspost_fr.php : http://forum.joomla.org/viewtopic.php?t=272866 !


Return to “1.0 - Questions générales”

Who is online

Users browsing this forum: No registered users and 1 guest