Probléme template multiple sur un site

Support et assistance sur les templates Joomla! 1.0.x, design html et css.

Moderators: Aidan38, sarki

Forum rules
Règles du forum
Locked
Guillaume 974
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Jul 28, 2008 11:40 am

Probléme template multiple sur un site

Post by Guillaume 974 » Mon Jul 28, 2008 11:42 am

Bonjour

Voilà j'ai un problème concernant mon site (en local pour l'instant).
J'ai assigné un template par défaut à mon site et pour une partie de celui-ci j'ai assigné le même template mais que j'ai cloné pour afficher une autre couleur (le template d'origine propose 5 couleurs mais je ne sais pas comment assigner celle ci à différente partie de mon site, je n'y arrive seulement qu'avec le sélecteur de couleur qui ce trouve dan la partie supérieur, mais ce que je veux c'est assigner automatiquement une couleur à une partie.

Mon soucis c'est que le template ce modifie bien lorsque je clic sur le menu qui améne sur une partie géré par le template 2 mais la couleur et le header ne change pas.
Je me suis aperçu qu'en fait si je clic sur le bouton de rechargement (firefox) le changement de couleur et header ce fait. Si je reclic sur un autre menu qui me ramène sur une partie géré par le template 1, je retrouve le même problème. Le template 1 ce met en place mais pas la couleur ni le header, si je recharge ça s'affiche.

Je n'y comprend rien, la couleur par défaut ce change dans l'index html je mets bien les couleurs par défaut que je désire sur chaque template

Cependant je viens de m'apercevoir que lorsque j'arrive sur cette fameuse page il suffit que je clic sur un lien inscrit dans la page en elle même, en fait sur mon site en cliquant sur le menu cela m'ouvre un lien de catégorie, ces catégorie apparaisse donc sur la page et ensuite il suffit de cliquer sur un des liens pour arriver à la liste d'article concerné par le liens. Donc comme je le disais je me suis apercu qu'il suffisait de cliquer sur un de ces liens de catégorie sur la page pour bien évidement accédez à la liste d'article vers laquelle pointent ce lien mais en même temps la couleur change ainsi que sur le header.

Comment faire pour que cette "mise à jour arrive" aussitôt que l'on clic sur le liens inscrit dans le menu gauche et non une fois que l'on a cliqué sur un lien de la page???

Merci de votre aide, il ne reste plus grand chose pour finir mon site!

User avatar
sebiseb
Joomla! Guru
Joomla! Guru
Posts: 700
Joined: Fri Aug 19, 2005 1:04 pm
Location: IdF - Centre
Contact:

Re: Probléme template multiple sur un site

Post by sebiseb » Mon Jul 28, 2008 5:36 pm

Peut-être en désactivant la cache !? ..enfin, c'est ce que j'essaierai :-[
Sébastien Pillias - french forum moderator

Vous êtes sur un forum d'entre aide : aidez les autres, les autres vous aideront !
Aidez-les à vous aidez en utilisant le fichier jtspost_fr.php : http://forum.joomla.org/viewtopic.php?t=272866 !

Guillaume 974
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Jul 28, 2008 11:40 am

Re: Probléme template multiple sur un site

Post by Guillaume 974 » Tue Jul 29, 2008 3:29 am

Merci pour ton aide!

Désactivé le cache je l'ai fait dans la configuration de joomla, d'ailleurs il n'était pas activé. :(

User avatar
mejean
Joomla! Hero
Joomla! Hero
Posts: 2716
Joined: Thu Aug 18, 2005 12:28 pm
Location: viewforum.php?f=19
Contact:

Re: Probléme template multiple sur un site

Post by mejean » Tue Jul 29, 2008 6:40 am

Je pense plutôt au cache du navigateur. Essaie de vider le cache de celui-ci avant de passer d'une page à une autre.
Jérôme Bussière - simple utilisateur
www.cardabelle.net

Guillaume 974
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Jul 28, 2008 11:40 am

Re: Probléme template multiple sur un site

Post by Guillaume 974 » Tue Jul 29, 2008 6:53 am

Oui bien sur si je fait ctrl F5 cela fonctionne, mais c'est une action manuel de la part du visiteur!
J'ai essayé avec IE ça fait le même problème :(

User avatar
mejean
Joomla! Hero
Joomla! Hero
Posts: 2716
Joined: Thu Aug 18, 2005 12:28 pm
Location: viewforum.php?f=19
Contact:

Re: Probléme template multiple sur un site

Post by mejean » Tue Jul 29, 2008 8:32 am

Cela se passe-t-il uniquement pour des images ?

Quel template utilises-tu ? Un lien pour voir peut-être ?
Jérôme Bussière - simple utilisateur
www.cardabelle.net

Guillaume 974
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Jul 28, 2008 11:40 am

Re: Probléme template multiple sur un site

Post by Guillaume 974 » Tue Jul 29, 2008 11:46 am

Non ce n'est pas un probléme d'image seulement mais de couleur de menu!

Mon template est absolute flush.
Il donne notamment la possibilité d'afficher 5 couleurs différentes grâce à un sélecteur affiché en haut de page.

J'ai trouvé la solution pour mettre en défaut une couleur, il suffit d'éditer le fichier html et de mettre la couleur par défaut que l'on veut.J'ai aussi remplacé dans le fichier couleur le header d'origine par le miens. Ensuite j'ai cloné le template avec un nouveau nom pour pouvoir l'installer et l'assigner à un menu particulier du site.
Une fois installé je fait la même procédure que pour le template 1 avec une couleur par défaut différente et un autre header.
Celà fonctionne le template 2 apparait bien quand je clic sur le menu mais il n'apparait pas dans la bonne couleur ni avec le bon header, en fait la couleur et le header ne ce change pas par rapport au template 1 tant que je n'ai pas forcé le rafraichissement de la page. Par contre si je cli sur un lien de la page, la nouvelle page qui apparait est parfaitement ok.
Maintenant si je reclic sur un lien d'un menu qui doit me rammener sur une page template 1 rebelotte, le template change 2 vers 1 mais la couleur reste 2 et header 2 tant que je n'ai pas rafraichi ou activé un de la nouvelle page.
Désolé c'est un peu long mais j'ai l'inpression que je m'explique mal :(

Pour voir le site ce n'est pas possible car il est en local, pour un démo c'est ici :
http://www.joomlajunkie.com/help/guides ... flush.html

Guillaume 974
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Jul 28, 2008 11:40 am

Re: Probléme template multiple sur un site

Post by Guillaume 974 » Tue Jul 29, 2008 11:50 am

Je suis une grosse bille ne anglais et en info mais peut être que ma solution est là:
http://www.joomlajunkie.com/members-for ... ectly.html

Mais je ne pige rien, quelqu'un pourrai me traduire dans un langage bluebite??

Guillaume 974
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Jul 28, 2008 11:40 am

Re: Probléme template multiple sur un site

Post by Guillaume 974 » Tue Jul 29, 2008 11:54 am

En fait non ça n'a pas directment rapport avec moi, je n'ai pas les modules dont ils parlent :(
Mais je n'ai pas compris l'histoire des cookies

Guillaume 974
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Mon Jul 28, 2008 11:40 am

Re: Probléme template multiple sur un site

Post by Guillaume 974 » Tue Jul 29, 2008 2:15 pm

Je viens de m'apercevoir d'une chose, celà mettra peut être quelqu'un sur une piste.

Par accident j'ai appuyé deux fois de suit sur le liens du menu.
Donc je clic une première fois sur le lien du menu gauche qui doit m'amener sur la page avec le template 2 la couleur et le header assosier, là comme je l'ai déjà dit seul le template s'affiche, la couleur reste celle du T1 ainsi que le header.
Je reclis sur le même menue et là tout s'affiche correctement comme si il fallait charger 2x la page pour que cela fonctionne

Je vais devenir chèvre :(


Locked

Return to “1.0 - Templates et design”