Page 1 of 1

[solved] Pressing edit only opens new (PHP 5.2 unstable version)

Posted: Sat Jun 03, 2006 11:14 pm
by Jinnis
I have just installed a new local system of Joomla 1.0.8 on Win XP SP2, PHP 5, MySQL 5 and Apache 2.2 and i have found a lot of help on the forum on issues i encountered on the way.

Now i have ended up with a peculiar problem. I can add new sections, categories and all the other entities but when i want to edit them i get the "new xxxxxx" page instead.

For example i have added a section that I later want to edit. I check the box on the section and then press edit. Now i only get an empty New Section page instead of getting the edit page for the section I want to edit.

What is wrong with my installation??

Please help me before i go bold out of frustration

Martin

Re: Pressing edit only opens new

Posted: Sun Jun 04, 2006 10:03 am
by Robin
Hi Martin,

I have seen this problem reported the other day, I'm looking for the topic to see what's the status on that one.

Regards Robin

Re: Pressing edit only opens new

Posted: Sun Jun 04, 2006 2:20 pm
by Robin
Hi Martin,

What php version are you using? This might be the same problem as http://forum.joomla.org/index.php/topic,66182.0.html

Re: Pressing edit only opens new

Posted: Sun Jun 04, 2006 5:47 pm
by Jinnis
Seems like i use 5.2.0-dev release. (found it in the snapshot txt) so probably the same error as in the other thread. I will keep an eye on the other thread.

Thank you very much!

br

Martin, still got some hair left

Re: Pressing edit only opens new

Posted: Sun Jun 04, 2006 6:23 pm
by Jinnis
Success!

I tried to back down to PHP 5.1.4 but the problem is that the PHP 5.1.4 does not work with apache 2.2 (I do this in Windows XP)

What i did was to backup my php.ini and then copied in the files of PHP 5.1.4. However there is one file missing and that is php5apache2_2.dll. I copied that file from the PHP 5.2 release and restarted the apache server and voila, I can edit my contents, sections, categories, menuitems etc.

(It should be said that i also copied libmysql from the mysql installation into my PHP folder and i copied the php_mysqli from ext folder to the PHP root folder, but this is to get it to work with the newest mySQL  release, 5.1)

Oh happy days

Thank you for your help!

br

/Martin

Re: Pressing edit only opens new

Posted: Sun Jun 04, 2006 6:25 pm
by Robin
Thanks for the feedback Martin. Glad it is working for you now. Have fun with Joomla!

Re: [solved] Pressing edit only opens new (PHP 5.2 unstable version)

Posted: Tue Jul 24, 2007 7:46 pm
by ddmobley
I am having this exact same problem, however it isn't related to PHP 5.2.  This is a brand new install, out of the box, and is using PHP 4.4.4.  AND, it only happens in Internet Explorer 7, but it works fine in Firefox 2.0.  Ideas?