Am I mad to be still creating new sites in Joomla 1.0.15?

Joomla version 1.0 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Am I mad to be still creating new sites in Joomla 1.0.15?

Post by beededea » Tue Oct 05, 2010 8:34 pm

That's my question? Am I mad to be still creating new sites in Joomla 1.0.15? Are there any reasons why this could actually be a good idea? Any particularly strong reasons for NOT doing it... both sides of the argument please!
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

User avatar
dhuelsmann
Joomla! Master
Joomla! Master
Posts: 19658
Joined: Sun Oct 02, 2005 12:50 am
Location: Omaha, NE
Contact:

Re: Am I mad to be still creating new sites in Joomla 1.0.15

Post by dhuelsmann » Tue Oct 05, 2010 8:37 pm

Because all support including support for issues that might facilitate hacking in Joomla 1.0.x series have ceased after July 22, 2009. Whereas Joomla 1.5.x is a continued development version.
Regards, Dave
Past Treasurer Open Source Matters, Inc.
Past Global Moderator
http://www.kiwaniswest.org

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Am I mad to be still creating new sites in Joomla 1.0.15

Post by beededea » Tue Oct 05, 2010 8:53 pm

Righto, got that one! - and to mitigate the risk the sites are regularly backed up on good secure servers.
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

User avatar
dhuelsmann
Joomla! Master
Joomla! Master
Posts: 19658
Joined: Sun Oct 02, 2005 12:50 am
Location: Omaha, NE
Contact:

Re: Am I mad to be still creating new sites in Joomla 1.0.15

Post by dhuelsmann » Tue Oct 05, 2010 10:22 pm

How are you mitigating risk? None of the developers are updating their Joomla 1.0.x extensions. If you are even using one, you may have opened a door into your "secure servers".
Regards, Dave
Past Treasurer Open Source Matters, Inc.
Past Global Moderator
http://www.kiwaniswest.org

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Am I mad to be still creating new sites in Joomla 1.0.15

Post by beededea » Tue Oct 05, 2010 10:46 pm

Point taken.
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Am I mad to be still creating new sites in Joomla 1.0.15

Post by beededea » Thu Oct 07, 2010 12:18 pm

So, if I check all the extensions I use are not on the vulnerable list and ensure that any vulnerabilities are fixed ( I recently patched MMSblog to tighten up a vulnerability ) then I can assume some level of security? I understand that joomla 1.0.15 was pretty secure by the end.
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

User avatar
dhuelsmann
Joomla! Master
Joomla! Master
Posts: 19658
Joined: Sun Oct 02, 2005 12:50 am
Location: Omaha, NE
Contact:

Re: Am I mad to be still creating new sites in Joomla 1.0.15

Post by dhuelsmann » Thu Oct 07, 2010 2:36 pm

You are simply rolling the dice. There are 126 possible combinations. Out of that there are 6 ways to throw a 7 and two ways to throw an 11. That leaves 118 possible ways to lose. Do you really believe that there are people/companies evaluating the current security status of extensions for 1.0.x? Why would they since support stopped in 2009?
Regards, Dave
Past Treasurer Open Source Matters, Inc.
Past Global Moderator
http://www.kiwaniswest.org

User avatar
lindant
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 110
Joined: Wed Jul 09, 2008 8:25 pm
Location: Amman - Jordan
Contact:

Re: Am I mad to be still creating new sites in Joomla 1.0.15

Post by lindant » Thu Oct 07, 2010 2:39 pm

Thats a funny question. i think yes you are mad :p
actually, i never used 1.0.15, when i knew joomla i started directly with 1.5.. i have no idea why people stick to 1.0.15, in my local business all my competitors are using 1.0.15 till now!
We are blessed with Joomla!
http://www.mazajnet.com

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Am I mad to be still creating new sites in Joomla 1.0.15

Post by beededea » Thu Oct 07, 2010 3:05 pm

It was meant to be an entertaining post... I never actually said I was creating 'brand new' sites in Joomla 1.0.15, I just want to know what you think.

I have to admit to having created new 1.0.15 sites on client request when they want a duplication/clone of an existing site (for a new function) and they don't want to go through the migration route. They see it as too much of a cost for no/little gain. They have multiple sites and are fully trained on the back end and all extensions. They don't want to retrain as they see that they've been trained once already. I can see their point.

So far I have only had one Joomla 1.0.15 site hacked and that wasn't the site itself but through a PC backdoor trojan stealing passwords. I have had a J1.5 site hacked and so my personal experience tells me that if I do regular backups and check/scan sites regularly then having a J1.0.15 site it is a risk they can accept. Remember, some of these have existed for years in a stable fashion. Please comment.
Last edited by beededea on Thu Oct 07, 2010 5:04 pm, edited 1 time in total.
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

User avatar
lindant
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 110
Joined: Wed Jul 09, 2008 8:25 pm
Location: Amman - Jordan
Contact:

Re: Am I mad to be still creating new sites in Joomla 1.0.15

Post by lindant » Thu Oct 07, 2010 3:26 pm

yes, i know what you mean about the training part... most people just cant absorb information or dont have time to learn...

i had several 1.5 sites hacked... i didnt know about security then... i had to learn the hard way :'(
i hope now they are secured :geek:
We are blessed with Joomla!
http://www.mazajnet.com

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Am I mad to be still creating new sites in Joomla 1.0.15

Post by beededea » Thu Oct 07, 2010 3:51 pm

I'm also looking for positive reasons why I should build in Joomla 1.0.15? Not just negative ones. Can anyone think of any?
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

User avatar
lindant
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 110
Joined: Wed Jul 09, 2008 8:25 pm
Location: Amman - Jordan
Contact:

Re: Am I mad to be still creating new sites in Joomla 1.0.15

Post by lindant » Thu Oct 07, 2010 4:02 pm

i heard from so many that 1.0.15 is in fact more secure...
We are blessed with Joomla!
http://www.mazajnet.com

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Am I mad to be still creating new sites in Joomla 1.0.15

Post by beededea » Fri Oct 15, 2010 3:16 pm

It seems that Joomla 1.0 sites will not survive the transition to PHP 5.3 unless a few changes are made to the core... My host will be running 5.3 in parallel with 5.2 for a good year or so, therefore no problem for me, at least not just yet.
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar

User avatar
beededea
Joomla! Hero
Joomla! Hero
Posts: 2809
Joined: Wed Oct 31, 2007 3:48 pm
Location: Victorian England 1885

Re: Am I mad to be still creating new sites in Joomla 1.0.15

Post by beededea » Fri Oct 15, 2010 3:18 pm

lindant wrote:i heard from so many that 1.0.15 is in fact more secure...
I heard this too, no vulnerabilites found in the last version for a few hundred days, at least in the quote I read. Perhaps it is just the extensions that need to be checked/tested.
Yereverluvinunclebert
Steampunk widgets. Platforms of choice: Joomla 1.0/1.5, Joostina 1.2, OSCommerce
Site aims: Optimisation, Security and Solidity
http://widgets.yahoo.com/widgets/steamp ... k-calendar


Locked

Return to “Installation - 1.0.x”