Fatal error: set_magic_quotes_runtime(): magic_quotes_runtime is not supported anymore in Unknown on line 0

Joomla version 1.0 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
vyankarla
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Apr 30, 2021 10:40 pm

Fatal error: set_magic_quotes_runtime(): magic_quotes_runtime is not supported anymore in Unknown on line 0

Post by vyankarla » Fri Apr 30, 2021 10:45 pm

Our site http://www.hawttemple.org is hosted with hostgator running on Joomla . Our PHP version is 7.4
We believe Joomla upgrade sometime in Jan 10 or Jan 11 , 2021 caused our site failed to load .

I currently see below error on browsing to the site. I have this line of code in joomla.php file
@set_magic_quotes_runtime(0);
Looks like this is not compatible with new versions. I tried commenting out , but it didn't help the site to load.

Fatal error: set_magic_quotes_runtime(): magic_quotes_runtime is not supported anymore in Unknown on line 0

Can you please advise ?

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 28075
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Fatal error: set_magic_quotes_runtime(): magic_quotes_runtime is not supported anymore in Unknown on line 0

Post by Per Yngve Berg » Sat May 01, 2021 7:35 am

Please post your FPA.

See red framework above.

vyankarla
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Apr 30, 2021 10:40 pm

Re: Fatal error: set_magic_quotes_runtime(): magic_quotes_runtime is not supported anymore in Unknown on line 0

Post by vyankarla » Sat May 01, 2021 11:16 am

Thank you . Here is the output from FPA php file.

on browsing to https://www.hawttemple.org/fpa-en.php , I first got

Fatal error: Uncaught exception 'Exception' with message 'DateTime::__construct(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.' in /home2/admin/public_html/fpa-en.php:189 Stack trace: #0 /home2/admin/public_html/fpa-en.php(189): DateTime->__construct('01-05-2021') #1 {main} thrown in /home2/admin/public_html/fpa-en.php on line 189

I fixed this by adding "date.timezone = "US/Central" in php.ini file .

After this , I got below message
Fatal error: Class 'JConfig' not found in /home2/admin/public_html/fpa-en.php on line 1403

I fixed it by changing configuration file code to have class JConfig at the top
<?php
class JConfig {

After this , on browsing to https://www.hawttemple.org/fpa-en.php , it says

This page isn’t working
www.hawttemple.org is currently unable to handle this request.
HTTP ERROR 500

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 28075
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Fatal error: set_magic_quotes_runtime(): magic_quotes_runtime is not supported anymore in Unknown on line 0

Post by Per Yngve Berg » Sat May 01, 2021 12:04 pm

What version of Joomla are you running? It can't be 3.9.

vyankarla
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Apr 30, 2021 10:40 pm

Re: Fatal error: set_magic_quotes_runtime(): magic_quotes_runtime is not supported anymore in Unknown on line 0

Post by vyankarla » Sat May 01, 2021 2:26 pm

I'm new to Joomla , so don't know where to look for . I found this in version.php file . Is this helpful ?


class joomlaVersion {
/** @var string Product */
var $PRODUCT = 'Joomla!';
/** @var int Main Release Level */
var $RELEASE = '1.0';
/** @var string Development Status */
var $DEV_STATUS = 'Stable';
/** @var int Sub Release Level */
var $DEV_LEVEL = '12';
/** @var int build Number */
var $BUILD = '$Revision: 6086 $';
/** @var string Codename */
var $CODENAME = 'Sunfire';
/** @var string Date */
var $RELDATE = '25 December 2006';
/** @var string Time */
var $RELTIME = '01:00';
/** @var string Timezone */
var $RELTZ = 'UTC';
/** @var string Copyright Text */
var $COPYRIGHT = "Copyright (C) 2005 - 2006 Open Source Matters. All rights reserved.";
/** @var string URL */
var $URL = '<a href="http://www.joomla.org">Joomla!</a> is Free Software released under the GNU/GPL License.';
/** @var string Whether site is a production = 1 or demo site = 0: 1 is default */
var $SITE = 1;
/** @var string Whether site has restricted functionality mostly used for demo sites: 0 is default */
var $RESTRICT = 0;
/** @var string Whether site is still in development phase (disables checks for /installation folder) - should be set to 0 for package release: 0 is default */
var $SVN = 0;

gws
Joomla! Virtuoso
Joomla! Virtuoso
Posts: 4347
Joined: Tue Aug 23, 2005 1:56 pm
Location: South coast, UK
Contact:

Re: Fatal error: set_magic_quotes_runtime(): magic_quotes_runtime is not supported anymore in Unknown on line 0

Post by gws » Sat May 01, 2021 2:49 pm

You appear to be running version 1 of joomla and that is at least 25 yrs old....
I guess that whatever version of php your server is running will not be compatible with such an old version of joomla.

vyankarla
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Fri Apr 30, 2021 10:40 pm

Re: Fatal error: set_magic_quotes_runtime(): magic_quotes_runtime is not supported anymore in Unknown on line 0

Post by vyankarla » Sat May 01, 2021 3:04 pm

What is the best way to upgrade Joomla version ? Should I reach out to HostGator ( our site hosting company) to take care of this ?

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 28075
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Fatal error: set_magic_quotes_runtime(): magic_quotes_runtime is not supported anymore in Unknown on line 0

Post by Per Yngve Berg » Sat May 01, 2021 3:04 pm

Mod. Note: Relocated the topic to the J1.0 Forum.

User avatar
Per Yngve Berg
Joomla! Master
Joomla! Master
Posts: 28075
Joined: Mon Oct 27, 2008 9:27 pm
Location: Romerike, Norway

Re: Fatal error: set_magic_quotes_runtime(): magic_quotes_runtime is not supported anymore in Unknown on line 0

Post by Per Yngve Berg » Sat May 01, 2021 3:15 pm



Locked

Return to “Upgrading - 1.0.x”