Page 1 of 3

List of extensions needing upgrading for 1.0.13 compatibility

Posted: Wed Jul 25, 2007 6:42 am
by infograf768
To developers & users

Please list here the extensions you experience problems with in 1.0.13.
Please 3pd devs post here when available upgrades (and also in your JED description)

It is suggested to all to subscribe to this thread to be kept informed.

EDIT (August 12, 2007): An official fix is available for 1.0.13
http://forum.joomla.org/index.php/topic ... #msg944268

It should fix a number of issues with admin session.
It may not fix all specific extension problems.

1.0.13 compatibility- CB 1.0.2•JCE 1.1.5

Posted: Wed Jul 25, 2007 6:44 am
by infograf768
The 2 I am sure of for now.

Community Builder 1.0.2

JCE 1.1.5

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Wed Jul 25, 2007 7:00 am
by leolam
Comprehensive overview for clarity If solution or hotfix please post in this thread (with Link!)  so i update the list

See this post by Infograf  regarding official patch for Joomla-core 1.0.13 Also note it fixes Joomla and most extensions but some will need fixing by 3rd party developers!

Community Builder please see new release fixing all issues as posted and more COOL! Kudos Team Joomlapolis!!!
Joomlahack Bridge
X SMF-Bridge  >> discontinued
Virtuemart >> Fixed
JCE 1.1.5 >> Fixed
Joomfish 1.7
JoomlaXplorer 2.0.0 beta5
eLearningforce Components + Bridges:
  • Synch users  + CB
  • Bridges (SMF, PhpBB, JvB)
  • Subscription Pro/Deluxe
  • SingleSign-On, both components.
  • Multisites site manager – can’t synchronize users
  • LMS forum mambot.
PollXT>> Fixed
astatsPRO 1.0.0 component >> patch

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Wed Jul 25, 2007 7:24 am
by Geraint
Joomfish 1.7 will be subject to autologouts in the backend.

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Wed Jul 25, 2007 10:02 am
by Gerlof
eXtplorer 2.0.0 beta5 (formerly known as joomlaXplorer 2.0.0) has the same auto logout problem  :(
joomlaXplorer 1.6.1 works normally  :)

Gerlof

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Wed Jul 25, 2007 11:57 am
by lavsteph
Hello

for the SMF bridge see this topics : http://www.simplemachines.org/community ... pic=184557  :-\

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Wed Jul 25, 2007 12:02 pm
by happy_noodle_boy
Does anyone have any idea where and why this is occuring?

Seems to affect JCE in the Admin backend only.

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Wed Jul 25, 2007 12:06 pm
by leolam
lavsteph wrote: for the SMF bridge see this topics :
please lets keep this a list.... this was already posted on the forum here

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Wed Jul 25, 2007 12:09 pm
by Rolf
Joomfish @version 1.7 - $Revision: 14 $
Frontend:
Fatal error: Cannot instantiate non-existent class: mldatabase in /home/httpd/hosts/srv05192/html/mambots/system/jfdatabase.systembot.php on line 53
i solved that on line 53 with replacing the // (comment) with @
@require_once( $mosConfig_absolute_path '/components/com_joomfish/includes/joomfish.class.php' );

then came:
Fatal error: Call to a member function on a non-object in /home/httpd/hosts/srv05192/html/modules/mod_jflanguageselection.php on line 52
//$langActive = $_JOOMFISH_MANAGER->getActiveLanguages();
i just uncommented this line and the page could load complete in the defaultlanguage at least.

Backend:
none of the administrationsscreens works.
index2.php cant load any of joomfishcomponents.
index2.php?option=com_joomfish  brings me back to "home"

best regards
rolf

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Wed Jul 25, 2007 12:17 pm
by leolam
Rolf wrote: best regards
rolf
Did you read the Text of the thread? Why you dump here a lot of code?

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Wed Jul 25, 2007 12:36 pm
by ziissi
astatsPRO 1.0.0 component

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Wed Jul 25, 2007 12:45 pm
by Rolf
infograf768 wrote: To developers & users
Please list here the extensions you experience problems with in 1.0.13.
It is suggested to all to subscribe to this thread to be kept informed.
of course I did!
Or did I miss the line were stands not to give a bit information about what happens in detail?
or the line: don´t tell the others how to quickfix a known problem?

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Wed Jul 25, 2007 1:09 pm
by leolam
happy_noodle_boy wrote: Does anyone have any idea where and why this is occuring?
Ryan I think this will help you to find something for JCE ?

;)

phpBB Component 1.2.4 RC4

Posted: Wed Jul 25, 2007 4:02 pm
by jhoov
phpBB Component 1.2.4 RC4

can not login anymore

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Wed Jul 25, 2007 4:51 pm
by leolam
jhoov wrote: phpBB Component 1.2.4 RC4
can not login anymore
is that the Bridge and which one?

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Wed Jul 25, 2007 5:52 pm
by jhoov
leolam wrote: is that the Bridge and which one?
It is more than the bridge, it is the modified phpBB that installs into the com_forum directory.  It originally came from http://www.tim-online.nl, but I can't find it there anymore.  Perhaps I need to find a more recent solution. 

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Thu Jul 26, 2007 1:22 am
by leolam
jhoov wrote: It is more than the bridge, it is the modified phpBB that installs into the com_forum directory.  It originally came from http://www.tim-online.nl, but I can't find it there anymore.  Perhaps I need to find a more recent solution. 
That was the one developed by Adam v. Dongen aka websmurf. He has left that company and started for himself http://joomla-addons.org /

I think he has stopped development but you can drop him a line at his site. He is very responsive....(normally ;) )

cheers
Leo

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Thu Jul 26, 2007 4:11 am
by ISchier
Looks like AEC Subscription Manager is incompatible with 1.0.13.

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Thu Jul 26, 2007 5:53 am
by leolam
ISchier wrote: Looks like AEC Subscription Manager is incompatible with 1.0.13.
no its not AEC it's the admin backend from Joomla as far as we see now.

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Thu Jul 26, 2007 8:53 am
by happy_noodle_boy

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Thu Jul 26, 2007 8:56 am
by leolam
happy_noodle_boy wrote: Fix for JCE 1.1.5 - http://forum.joomla.org/index.php/topic ... #msg920232
Kudos Ryan ;) wow fast as usual!

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Thu Jul 26, 2007 5:41 pm
by Pmoney
PollXT 1.22.13
If "cookies enabled" is used in the configuration, when voting, message shows "cookies must be enabled", even if they are enabled.
Short term solution was to disable cookies in the component.
Not sure if this happens in never version (paid) of component either.

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Thu Jul 26, 2007 8:01 pm
by Joomlageek2.0
Is there a downgrade patch to go back to 1.0.12 or do I need to restore from a backup? My backup is a little stale. I hate to lose this much information.

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Thu Jul 26, 2007 10:12 pm
by Geas
JACLPlus v1.0.8

Edited: JCAPlus v1.0.12 - there's an update for chartered members to JACPlus v1.0.13 <- this one claims to work on J! .13 - didn't test it. Thanks leolam for the reply (a few msgs down)

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Fri Jul 27, 2007 2:33 am
by sableholic
Pmoney wrote: PollXT 1.22.13
If "cookies enabled" is used in the configuration, when voting, message shows "cookies must be enabled", even if they are enabled.
Short term solution was to disable cookies in the component.
Not sure if this happens in never version (paid) of component either.
I haven't tested this but I saw on their site this fix:
http://www.joomlaxt.com/forum/view-5978.html#2843

Event Calendar 1.6.4 Looses Login

Posted: Fri Jul 27, 2007 2:45 am
by xavierpayne
After upgrading to Joomla 1.0.13 (from 1.0.12). When in the control panel (back end) for the Event Calendar component if I add or update an Event after saving the event *any* further action in the joomla control panel results in being forwarded to the login screen.

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Fri Jul 27, 2007 4:51 am
by leolam
Geas wrote: JACLPlus v1.0.8
you need to upgrade :
JACLPlus Pro v1.0.13 Component for Joomla! 1.0.13 Stable

Re: 1.0.13 compatibility- CB 1.0.2•JCE 1.1.5

Posted: Fri Jul 27, 2007 9:34 am
by Raffù
infograf768 wrote: The 2 I am sure of for now.

Community Builder 1.0.2

JCE 1.1.5
JCE 1.1.6 now available (and working)

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Fri Jul 27, 2007 9:59 am
by ziissi
astatsPRO 1.0.0 component (backend authentication problem) fix can be downloaded from
http://www.joomlaportal.de/joomla-kompo ... post473205

However, the forum is in German language and you need to register to obtain the patch.

Patch fixes the following file
administrator/components/com_astatspro/includes/functions.inc.php

Re: List of extensions needing upgrading for 1.0.13 compatibility

Posted: Fri Jul 27, 2007 5:08 pm
by eboy
Hot property

When i have upgraded to version 1.0.13 registration of hot property brokers have been incorrectly