Page 1 of 1

Migrating from v1.0 to v.1.5? 1.6? 1.7? wait?

Posted: Sun Jul 24, 2011 9:50 am
by Steinspecht
Hello all,

my website runs under v1.0. My provider says this is now creating problems and I should migrate to a higher version. He runs php v5.3.3. under Debian Squeeze. I don't know what the problems are.

From what I see in this forum, some people are on v1.5 and prefer to wait until 1.8 is out. Some others say 1.6 is short term and would migrate to 1.7.

Hence I ask knowledgeable people here for a recommendation. Which Joomla version is comfortable under php v5.3.3. under Debian Squeeze?

Thanks and best regards,
Steinspecht

Re: Migrating from v1.0 to v.1.5? 1.6? 1.7? wait?

Posted: Sun Jul 24, 2011 9:57 am
by Tonie
Problem is probably that Joomla 1.0 shows error when running on PHP 5.3.x. My advice would be to migrate to 1.5 right now, then wait for 1.8 to come out and migrate from 1.5 to 1.8 once 1.8.1 has been released.

Re: Migrating from v1.0 to v.1.5? 1.6? 1.7? wait?

Posted: Sun Jul 24, 2011 12:57 pm
by Steinspecht
Thanks!

Any different opinion ?

Re: Migrating from v1.0 to v.1.5? 1.6? 1.7? wait?

Posted: Wed Jul 27, 2011 4:55 am
by pattaya
Wouldn't it be better to migrate from 1.0 to 1.7?

I have some sites in the same situation

Re: Migrating from v1.0 to v.1.5? 1.6? 1.7? wait?

Posted: Thu Oct 13, 2011 1:04 pm
by beededea
There is no need to migrate to 1.5 if you just want to keep your site going. Just find a secure specialist host that supports Joomla 1.0 sites with the correct version of PHP. I have found one and they are fine.

All/most/many of the errors that an upgrade to PHP causes can be fixed in any case.

If you are going to upgrade then do so for better reasons than just keeping site going... When you have enough of them then do upgrade. New functionality, new look and feel &c. My suggestion would be to upgrade to 1.5.23 and wait until 2.5 arrives. When it is mature, only then think of migrating.