PHP GHI to PHP CLI

Joomla version 1.0 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
pirinalia
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Tue Jun 19, 2007 3:02 pm
Contact:

PHP GHI to PHP CLI

Post by pirinalia » Tue Nov 08, 2011 2:42 pm

Hi,
Actually I Have joomla 1.5.23 in a host with php cgi. I am trying to move to a new dedicated server that has php cli. (My host said that it is more insecure but it is faster, actually we have performance problems so I decided to maintain php cli.
The problem is that file permissions are the same as before but it seems that there are a lot of problems, all config file appears as unwritable and some components fail due to permisssions
I can set permissions to 7777, but it is not good idea.

If anybody can show any light on these, It will be really apreciated.

Thanks in advance,
Marc

 
prowords
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Thu Feb 16, 2012 8:27 pm

Re: PHP GHI to PHP CLI

Post by prowords » Thu Feb 16, 2012 8:50 pm

I had the same thing happen to one of my clients recently. The only way I could get everything to work was to change the files to 0777 permissions, which I knew wasn't a secure long term solutions. So this is what I did to fix the issue:

1) Installed a newer version of Joomla onto the new server (for some reason the newer PHP on the new server caused permission issues with the older Joolma version).

2) Kept the older version of Joomla on the older server and slowly transferred everything to the newer Joomla server.

3) In the end everything worked and they not only had a new server but also a newer version of Joomla.

Hope this helped.

 

Locked

Return to “Upgrading - 1.0.x”