Upgrade 1.0 to 2.5?

Joomla version 1.0 is end-of-life and are no longer supported. Please use Joomla 3.x instead.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
youthman
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Thu Apr 25, 2013 4:28 am

Upgrade 1.0 to 2.5?

Post by youthman » Sat Jun 29, 2013 4:57 am

I'm pretty new to Joomla and I see my client is running 1.0. Their site is http://www.ampmdoorservice.com/. It looks really "dated" in design and I'm sure Joomla 2.5 or 3.0 has MUCH more to offer them.

Looks like Joomla is now on 2.5. I would think there would be significant reasons to upgrade to the latest version.

Few questions:

1) Where can I find instructions on how to upgrade? It doesn't appear there is an Upgrade button like in Wordpress so is this done manually?

2) Where can I find info on the differences between say 1.0 and 2.5. I would need to be able provide my client with the benefits of 2.5 over 1.0.

User avatar
mjparadac
Joomla! Ace
Joomla! Ace
Posts: 1820
Joined: Mon Oct 29, 2012 3:58 pm

Re: Upgrade 1.0 to 2.5?

Post by mjparadac » Sun Jun 30, 2013 3:30 am

Hello youthman
Have you thought to make the site from scratch using the new version of joomla? To avoid any problems that may occur.
About to update Joomla 1.0, these threads are similar topics:
http://forum.joomla.org/viewtopic.php?t=757631
http://forum.joomla.org/viewtopic.php?t=774324
http://forum.joomla.org/viewtopic.php?t=806492
We recommend that you backup your site before upgrading.

Here you can find information on the versions of Joomla: http://docs.joomla.org/Beginners

Regards,
Joomla Community Ambassador for A2 Hosting | A2 Hosting - Our speed, your success | https://www.a2hosting.com/joomla-hosting

youthman
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Thu Apr 25, 2013 4:28 am

Re: Upgrade 1.0 to 2.5?

Post by youthman » Sun Jun 30, 2013 3:33 am

Thanks for the reply and for the links. I will check them out.

I had not considered doing a fresh install and importing the database. That probably would be the best approach since there is such a huge gap between 1.0 and 3.0.


Locked

Return to “Upgrading - 1.0.x”