Page 1 of 1

Need to upgrade from 1.0.15

Posted: Thu Feb 13, 2014 6:00 pm
by marksfish
Hi. My site has been running Joomla for many years now with no problems, so I never felt the need to upgrade. Recently however the site has been hacked with directories, eval code (whatever that is) and hacked config files.

I feel the need to upgrade the site now, not sure to what version, but reading the help requests already on upgrading, shows lots of failed links and tools. Is it not possible to now upgrade a site please? Don't really want to start again and lose all my indexed pages.

Thanks

Mark

Re: Need to upgrade from 1.015

Posted: Thu Feb 13, 2014 6:37 pm
by toivo
Depending on the complexity of the site, migration to a later, supported and more secure version will take some work. Maintaining the SEO with indexed pages is of course important. Data export and import like getting the users across can be simple but some extensions like templates may not have an upgrade path but have to be replaced. Any possible custom modifications will need to be checked, upgraded and tested, too.

Re: Need to upgrade from 1.015

Posted: Thu Feb 13, 2014 7:08 pm
by marksfish
I previously upgraded a couple of my sites a few years back, but struggled if i'm honest. The templates weren't compatible and I did have a problem with the component that produced SEF url's. I have taken the plunge and signed for a temporary "trial" account for 3.2, so will see how I get on with that. No point in beating my head against a brick wall attempting to upgrade if it is more trouble than it's worth.

It's not a brilliant site, only my personal hobby website.

Mark