Níveis de acesso não funcionam corretamente

Moderator: ariadneduvessa

Locked
ilsandes
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Mon Jul 14, 2014 3:21 pm

Níveis de acesso não funcionam corretamente

Post by ilsandes » Wed Jul 06, 2016 3:29 pm

Olá, pessoal!

Realizei a criação de um grupo de usuários na área administrativa do site por conta de novas pessoas que irão começar a inserir conteúdo no meu site, entretanto, como são pessoas não habituadas com o uso de CMS, estava restringindo o acesso a diversas extensões instaladas. Entretanto, não sei o que aconteceu, que agora tudo está configurado para acesso permitido apenas ao Super Admin (com cadeado mesmo) e nada do que eu faço consegue mudar isso.

Alguém pode me dar uma luz?

Agradeço antecipadamente.

User avatar
Helvecio
Joomla! Explorer
Joomla! Explorer
Posts: 399
Joined: Wed Oct 10, 2007 2:29 pm
Location: Rio de Janeiro - Brazil
Contact:

Re: Níveis de acesso não funcionam corretamente

Post by Helvecio » Fri Jul 22, 2016 5:11 pm

Esse grupo que você criou é filho de Public?
Helvecio "Elvis" da Silva
Graphic and Web Designer
Joomla Website Developer
http://hlvc.design

ilsandes
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Mon Jul 14, 2014 3:21 pm

Re: Níveis de acesso não funcionam corretamente

Post by ilsandes » Mon Aug 15, 2016 4:26 pm

Olá, Helvécio.

No momento, sim, mas eu já o criei como filho de outros grupos de usuários também. Agora o problema mudou um pouco, depois de alguns testes que realizei...

Os demais grupos estão com os acessos normais, de acordo com o que eu configuro, exceto ao Gerenciador de Menus e Gerenciador de Mídias. Agora, apenas o grupo "Super Users" e "Administrators" estão com acesso a tudo. O Administrators porque está como Super User.

O curioso é que nas configurações globais o grupo Administrators não tem autorização de Super User, mas mesmo assim ele surge com todas estas permissões no Gerenciador de Menus, e eu não consigo sequer retirá-las, porque mesmo negando ele continua com as permissões.

Não tenho ideia do que está acontecendo.

User avatar
Helvecio
Joomla! Explorer
Joomla! Explorer
Posts: 399
Joined: Wed Oct 10, 2007 2:29 pm
Location: Rio de Janeiro - Brazil
Contact:

Re: Níveis de acesso não funcionam corretamente

Post by Helvecio » Mon Aug 15, 2016 6:20 pm

Lembrando que existem GRUPOS de Acesso e NÌVEIS de Acesso, os ítens do administrador que podem ser visualizados devem ter o NÍVEL DE ACESSO Special.

Leia esse artigo que escrevi onde detalho como melhor organizar a ACL no Joomla.
http://blog.helvecio.com/2012/05/24/joo ... k-end.html

Boa sorte!
Helvecio "Elvis" da Silva
Graphic and Web Designer
Joomla Website Developer
http://hlvc.design

livia_marques
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Thu Oct 27, 2016 4:55 am
Contact:

Re: Níveis de acesso não funcionam corretamente

Post by livia_marques » Thu Oct 27, 2016 5:12 am

Helvecio wrote:Lembrando que existem GRUPOS de Acesso e NÌVEIS de Acesso, os ítens do administrador que podem ser visualizados devem ter o NÍVEL DE ACESSO Special.

Leia esse artigo que escrevi onde detalho como melhor organizar a ACL no Joomla.
http://blog.helvecio.com/2012/05/24/joo ... k-end.html

Boa sorte!
Helvecio, ótimo artigo. Está super detalhado e me ajudou muito aqui. Obrigada! :)

User avatar
Helvecio
Joomla! Explorer
Joomla! Explorer
Posts: 399
Joined: Wed Oct 10, 2007 2:29 pm
Location: Rio de Janeiro - Brazil
Contact:

Re: Níveis de acesso não funcionam corretamente

Post by Helvecio » Thu Oct 27, 2016 12:09 pm

Por nada Livia! Fico feliz em saber que foi de ajuda.
Helvecio "Elvis" da Silva
Graphic and Web Designer
Joomla Website Developer
http://hlvc.design


Locked

Return to “Segurança”