[FIXED] - Joomla, editors, and Firefox 1.5 beta 2

tijs
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 106
Joined: Mon Aug 29, 2005 7:59 pm

[FIXED] - Re: Joomla, editors, and Firefox 1.5 beta 2

Post by tijs » Fri Dec 02, 2005 2:08 pm

Ok I hope developers take note of this. I heard there is a 1.0.5 version planned so this would be a good opportunity to update TineMCE, thus fixing the Firefox problem.
Last edited by Jinx on Wed Dec 07, 2005 1:04 am, edited 1 time in total.

User avatar
TheAnt
Joomla! Explorer
Joomla! Explorer
Posts: 352
Joined: Wed Aug 31, 2005 7:43 am
Location: Milano - Italy

Re: Joomla, editors, and Firefox 1.5 beta 2

Post by TheAnt » Fri Dec 02, 2005 2:15 pm

eric_c

please, can you specify if all the directory downloaded fron tinymce must be copied into the mosce dir or only the jscripts one

eric_c
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Nov 01, 2005 12:19 pm

Re: Joomla, editors, and Firefox 1.5 beta 2

Post by eric_c » Fri Dec 02, 2005 2:17 pm

I've update my demo site with the update (as described above) and that worked fine, the next site (production) with mambelfish (as the big difference) and that one doesn't work. Also the editor isn't working anymore in Internet Explorer.

random
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 222
Joined: Sat Sep 24, 2005 5:47 pm
Contact:

Re: Joomla, editors, and Firefox 1.5 beta 2

Post by random » Fri Dec 02, 2005 2:25 pm

I am not sure what the new Tinymce has to do with it because if you add a new profile you can edit with any existing editor. This works for me and several others, here is something I found about getting your extensions to work, I have not tried it yet.

1. At the location bar, enter: about:config. This will show you a list of Firefox internal preferences.
2. Right-click on the list, select New > String
Enter “app.extensions.version” (without quotes) for the preference name.
3. Then, enter “1.0” (without quotes) as the value for app.extensions.version.
4. Restart Firefox 1.5, then enable those disabled Firefox extensions.
5. Restart Firefox 1.5 again to active the extensions. Done.

eric_c
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Tue Nov 01, 2005 12:19 pm

Re: Joomla, editors, and Firefox 1.5 beta 2

Post by eric_c » Fri Dec 02, 2005 2:28 pm

TheAnt wrote: eric_c

please, can you specify if all the directory downloaded fron tinymce must be copied into the mosce dir or only the jscripts one

Only the jscripts dir.

User avatar
TheAnt
Joomla! Explorer
Joomla! Explorer
Posts: 352
Joined: Wed Aug 31, 2005 7:43 am
Location: Milano - Italy

Re: Joomla, editors, and Firefox 1.5 beta 2

Post by TheAnt » Fri Dec 02, 2005 6:45 pm

Random, what do you mean with another profile? how can I try on mac osx?

random
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 222
Joined: Sat Sep 24, 2005 5:47 pm
Contact:

Re: Joomla, editors, and Firefox 1.5 beta 2

Post by random » Sat Dec 03, 2005 1:11 pm

Not sure how to add another profile on Mac but you have to locate your profile directory on Windows it is
in run you type

"C:\Program Files\Mozilla Firefox\firefox\firefox.exe" -p


Iwould assume it is similarto this

User avatar
Jinx
Joomla! Champion
Joomla! Champion
Posts: 6569
Joined: Fri Aug 12, 2005 12:47 am
Contact:

Re: Joomla, editors, and Firefox 1.5 beta 2

Post by Jinx » Wed Dec 07, 2005 1:04 am

Just wanted to inform you all that we have just updated TinyMCE to version 2.0.1 in the 1.0 and 1.1 branches. I preformed a small test on Windows XP and everything seems to be running smoothly.
Johan Janssens - Joomla Co-Founder, Lead Developer of Joomla 1.5

http://www.joomlatools.com - Joomla extensions that just work

User avatar
TheAnt
Joomla! Explorer
Joomla! Explorer
Posts: 352
Joined: Wed Aug 31, 2005 7:43 am
Location: Milano - Italy

Re: Joomla, editors, and Firefox 1.5 beta 2

Post by TheAnt » Wed Dec 07, 2005 2:22 pm

Well, what about a MosCE update now?

User avatar
Tonie
Joomla! Master
Joomla! Master
Posts: 16584
Joined: Thu Aug 18, 2005 7:13 am

Re: Joomla, editors, and Firefox 1.5 beta 2

Post by Tonie » Wed Dec 07, 2005 2:29 pm

MosCE also makes use of the TinyMCE WYSIWYG program, but is not developerd by Joomla core dev team. Ryan (the creator of MosCE) is hard at work to incorporate TinMCE and lots of other nice changes into MosCE. It's a one man job, but a fine one at that.

User avatar
TheAnt
Joomla! Explorer
Joomla! Explorer
Posts: 352
Joined: Wed Aug 31, 2005 7:43 am
Location: Milano - Italy

Re: Joomla, editors, and Firefox 1.5 beta 2

Post by TheAnt » Wed Dec 07, 2005 2:35 pm

Yes, it is a wonderful component! I wish to get the new one very soon because at this moment I can't upgrade to firefox 1.5 until I can't use the backend of some sites of mine.

User avatar
peteratomic
Joomla! Apprentice
Joomla! Apprentice
Posts: 40
Joined: Tue Sep 27, 2005 6:59 pm
Contact:

Re: [FIXED] - Joomla, editors, and Firefox 1.5 beta 2

Post by peteratomic » Tue Dec 27, 2005 9:45 pm

I tried reinstalling the Tiny MCE files as suggested and mosCE still doesn't work.

The Intro Text box is blocked out--can't edit or add text there, but only in the main text body below it.

Using Mac version of Firefox 1.5 and Joomla 1.05.

ElgertS
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 145
Joined: Fri Oct 14, 2005 4:44 pm
Location: Atlanta GA
Contact:

Re: [FIXED] - Joomla, editors, and Firefox 1.5 beta 2

Post by ElgertS » Thu Feb 02, 2006 12:47 pm

I just installed Firefox 1.5.0.1 on Mac OS X 10.4.4 and I am finally able to edit articles with the mosCE editor.

User avatar
kaizen
Joomla! Explorer
Joomla! Explorer
Posts: 294
Joined: Fri Aug 26, 2005 5:05 am
Location: Pennsylvania, USA
Contact:

Re: [FIXED] - Joomla, editors, and Firefox 1.5 beta 2

Post by kaizen » Mon Feb 20, 2006 4:27 pm

ElgertS wrote: I just installed Firefox 1.5.0.1 on Mac OS X 10.4.4 and I am finally able to edit articles with the mosCE editor.
Sadly this isn't the case with FF 1.5.0.1 on the Windows platform.
random wrote: I am not sure what the new Tinymce has to do with it because if you add a new profile you can edit with any existing editor. This works for me and several others, here is something I found about getting your extensions to work, I have not tried it yet.

1. At the location bar, enter: about:config. This will show you a list of Firefox internal preferences.
2. Right-click on the list, select New > String
Enter "app.extensions.version" (without quotes) for the preference name.
3. Then, enter "1.0" (without quotes) as the value for app.extensions.version.
4. Restart Firefox 1.5, then enable those disabled Firefox extensions.
5. Restart Firefox 1.5 again to active the extensions. Done.
This *did* work for me, though I don't understand what random meant about "enabling those disabled extensions" in step 4; I simply restarted FF after creating the new config string and entry and it worked again.  Wouldn't have even known about this ifit weren't for a new client who's editing on a Mac.  I'll tell him to try updating to the .01 release and see what his results are.
Robert Anthony Pitera
West of East, Inc. - http://www.westofeast.com - Taking technology in new directions™


Locked

Return to “Q&T 1.0.x Resolved - Archived”