Page 2 of 2

Re: [MEDIUM:INFO REQ: 1.0.11] Joomla 1.0.11 Installation Error

Posted: Wed Nov 15, 2006 7:30 am
by Robin
Sorry, no more access to a Windows NT server.
I do, but unable to replicate, anyone else has more info?

Re: [MEDIUM:INFO REQ: 1.0.11] Joomla 1.0.11 Installation Error

Posted: Wed Nov 22, 2006 7:29 pm
by RobS
Does anyone having anything to add to this thread?  I would like to get it resolved if possible but nobody seems interested in it anymore.  I will wait 5 days and then if no response, moving it to resolved as nobody in Q&T can replicate it.

Re: [MEDIUM:INFO REQ: 1.0.11] Joomla 1.0.11 Installation Error

Posted: Fri Nov 24, 2006 6:56 am
by ptlee
Well, I get the "restricted access" message after I install (installation was ok, no problems accessing admin page), and try to get onto the page. So I substituted the same line in index.php in the joomla root and got this

Array ( ) 1

My setup
WAMP on Windows XP pro
Apache 2.0.59
php 4.4.4
mysql 4.1.21

Hope this helps

removing the line and I get this error

Fatal error: Call to undefined function: mosshowhead() in C:\Program Files\Apache Group\Apache2\htdocs\cms01\index.php on line 12

Please help.

I don't have such problems in my BSD box.

Thanks.

cheers,
ptlee

Re: [MEDIUM:INFO REQ: 1.0.11] Joomla 1.0.11 Installation Error

Posted: Fri Nov 24, 2006 7:16 am
by ptlee
Ok, so I went and check this thread after I got that fatal error message

http://forum.joomla.org/index.php?topic=50129.msg303825

Turns out I solved it by changing my 'unzipping' process a little, seem to solve the corrupted file problem, and solved my initial problem as well!

What I did different
problematic method:
zip app: LzArc 3.5
from the zip window, I selected all files and dragged it into my desired directory. Voila, installation was ok, BUT I had problems accessing the index.php main page.

Ok method:
zip app: Lzarc 3.5
using the same zip client, I extracted all files to another directory, and there was this file that was 'duplicate', selected overwrite (see attached capture)
Voila, everything went through smoothly.

Conclusion? Some corrupted files in the unzipping process?

Hope this helps.

I'm done for now.

-ptlee-

Re: [MEDIUM:INFO REQ: 1.0.11] Joomla 1.0.11 Installation Error

Posted: Tue Nov 28, 2006 5:11 pm
by RobS
What information we have points to the problem coming from file corruption issues while unpacking and no more information being offered.  Moving to resolved.

Re: [MEDIUM:INFO REQ: 1.0.11] Joomla 1.0.11 Installation Error

Posted: Mon Dec 18, 2006 8:36 am
by justhemp
I gave up on trying to install 1.0.11.  Besides the 'Restricted Access' message I can never get past Step 2.  Undefined variables in Offline.php, permissions problems with database - some of this my hosts fault, they do not allow creating databases from anywhere except their V-Deck panel (yes, I host with IPowerwerb).

I tried to install 1.0.10 - not much better.  Several errors with Offline.php.

Facts:
FreeBSD host123.ipowerweb.com 4.8-RELEASE-p24 FreeBSD 4.8-RELEASE-p24 #0: Mon i386
Apache release 10333100
mysql Ver 12.22 Distrib 4.0.18
PHP 4.4.1

Arrrrgh!!!

I know I'm not being real verbose with my problems.  Fact is, I've been trying for 2 days to install this thing, and I'm very very very very frustrated.  Too bad about this, I like Joomla and use it elsewhere.  Never had a problem until I hit this install.

Re: [MEDIUM:INFO REQ: 1.0.11] Joomla 1.0.11 Installation Error

Posted: Mon Dec 18, 2006 1:35 pm
by spignataro
justhemp wrote: I gave up on trying to install 1.0.11.  Besides the 'Restricted Access' message I can never get past Step 2.  Undefined variables in Offline.php, permissions problems with database - some of this my hosts fault, they do not allow creating databases from anywhere except their V-Deck panel (yes, I host with IPowerwerb).

I tried to install 1.0.10 - not much better.  Several errors with Offline.php.

Facts:
FreeBSD host123.ipowerweb.com 4.8-RELEASE-p24 FreeBSD 4.8-RELEASE-p24 #0: Mon i386
Apache release 10333100
mysql Ver 12.22 Distrib 4.0.18
PHP 4.4.1

Arrrrgh!!!

I know I'm not being real verbose with my problems.  Fact is, I've been trying for 2 days to install this thing, and I'm very very very very frustrated.  Too bad about this, I like Joomla and use it elsewhere.  Never had a problem until I hit this install.



You have to create your database first through your control panel. You do not create it through the installer on Joomla!. This issue is related to not being able to get past the installation.

I dont have access to the server that I had many issues on and thus can not report back - since I have moved everything.

Re: [MEDIUM:INFO REQ: 1.0.11] Joomla 1.0.11 Installation Error

Posted: Mon Dec 18, 2006 5:43 pm
by RobS
justhemp wrote: I gave up on trying to install 1.0.11.  Besides the 'Restricted Access' message I can never get past Step 2.  Undefined variables in Offline.php, permissions problems with database - some of this my hosts fault, they do not allow creating databases from anywhere except their V-Deck panel (yes, I host with IPowerwerb).

I tried to install 1.0.10 - not much better.  Several errors with Offline.php.

Facts:
FreeBSD host123.ipowerweb.com 4.8-RELEASE-p24 FreeBSD 4.8-RELEASE-p24 #0: Mon i386
Apache release 10333100
mysql Ver 12.22 Distrib 4.0.18
PHP 4.4.1
On another note, I would seriously recommend that you try a different hosting provider.  I don't know much about IPowerWeb but if the server info you posted above is correct, you host is using a version of PHP with several security issues in it.  That is not a host I would feel good about giving my money to.

Re: [MEDIUM:INFO REQ: 1.0.11] Joomla 1.0.11 Installation Error

Posted: Sun Mar 04, 2007 3:38 pm
by erichorne
I was experiencing the problem... I added the traceback as suggested and it pointed me to installation/index.php line 18.

I fixed this by adding the following line to that file immediately after the header comments and before the first line of PHP code:

Code: Select all

define( '_VALID_MOS', 1 );
I saw this in Joomla 1.0.12 on a Fedora Core 6 system running Apache 2.2.3 and PHP 5.1.6 and MySQL 5.0.27

Hope this helps!

-Eric

Re: [MEDIUM:INFO REQ: 1.0.11] Joomla 1.0.11 Installation Error

Posted: Sun Sep 23, 2007 9:37 pm
by miloskorac
spignataro wrote: On any machine I try to install Joomla 1.0.11 on it fails by displaying "Restricted access"

It seems that the string

Code: Select all

// no direct access
defined( '_VALID_MOS' ) or die( 'Restricted access' );
Needs to be taken out of version.php to resolve this issue. Please update the files for others.
Well If you post a solution, don't you think that you should give a better explanation, as where is version.php etc