[MEDIUM:FIXED:1.0.11] Static Content Preview: "You are not authorized.."

User avatar
Sean
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Thu Aug 18, 2005 6:38 pm
Location: Pelham, NH USA
Contact:

[MEDIUM:FIXED:1.0.11] Static Content Preview: "You are not authorized.."

Postby Sean » Wed Aug 30, 2006 3:10 pm

I upgraded all my Joomla sites from 1.0.10 to 1.0.11 and I'm now getting "You are not authorized to view this resource" errors when clicking Preview while editing Static Content items. Clicking Preview on non-Static Content items works; I only receive the error when clicking Preview for Static Content items. Verified on multiple Joomla 1.0.11 sites (http://www.trunkmonkey.com, http://www.trunkmonkeyracing.com, http://www.clutchdrop.com).

No errors are getting generated in access_log or error_log and I have not yet modified .htaccess to include the new rewrite rules to block out some common exploits.

Any ideas?

vhost.conf file for my Plesk vhost (was working before upgrade)

Code: Select all

[root@colo1 httpdocs]# cat ~trunkmonkeyracin/conf/vhost.conf
<Directory /var/www/vhosts/trunkmonkeyracing.com/httpdocs>
    php_admin_value open_basedir "/var/www/vhosts/trunkmonkeyracing.com/httpdocs:/var/www/vhosts/trunkmonkeyracing.com/var/tmp:/tmp:/var/tmp"
    php_admin_value session.save_path "/var/www/vhosts/trunkmonkeyracing.com/var/tmp"
    php_admin_value upload_tmp_dir "/var/www/vhosts/trunkmonkeyracing.com/var/tmp"
</Directory>


.htaccess file for http://www.trunkmonkeyracing.com (was working before upgrade)

Code: Select all

# Web Configuration

RewriteEngine on
Options FollowSymLinks

RewriteCond %{HTTP_HOST} !^www.trunkmonkeyracing.com$ [NC]
RewriteRule (.*) http://www.trunkmonkeyracing.com/$1 [R=permanent,L]

RewriteRule ^component/option,com_akostaff http://www.trunkmonkeyracing.com/content/view/129/83/ [R=permanent,L]
RewriteRule ^content/blogcategory/21/60/ http://www.trunkmonkeyracing.com/content/blogcategory/21/79/ [R=permanent,L]

# Joomla Configuration
#
# http://forum.joomla.org/index.php/topic,31813.msg179443.html

RewriteRule ^(content/|component/) index.php


Image
Last edited by Robin on Fri Sep 08, 2006 10:35 am, edited 1 time in total.
Signature rules: Literal URLs only - viewtopic.php?f=8&t=65

Alexyjones
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Thu Aug 31, 2006 8:17 am

Re: Preview: "You are not authorized to view this resource" after 1.0.11 upgrade

Postby Alexyjones » Thu Aug 31, 2006 8:26 am

Unfortunately I'm having the same issues.
When clicking Preview in the static content section I get "You are not authorized to view this resource."
The link format of the preview button is: "http://www.xxx.com/administrator/index2.php?option=com_typedcontent&task=edit&hidemainmenu=1&id={Number}#"

For other content, where it works, I get the following links:
"http://www.xxx.com/administrator/index2.php?option=com_content§ionid=0&task=edit&hidemainmenu=1&id={Number}#"

I don't exactly know what would help to fix it, just ask me.
Thanks
Last edited by Alexyjones on Thu Aug 31, 2006 8:29 am, edited 1 time in total.

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: Preview: "You are not authorized to view this resource" after 1.0.11 upgrade

Postby Robin » Thu Aug 31, 2006 10:28 am

[TAGGED: Q&T] Tagged for personal review.

@ Sean and Alex,

I'll do some basic testing, see if I can confirm this issue. If so, I'll move this to the Q&T forum so we can follow up on it.

Regards Robin

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: Preview: "You are not authorized to view this resource" after 1.0.11 upgrade

Postby Robin » Thu Aug 31, 2006 10:41 am

Hi,

Tested and confirmed. I have created a bug report: http://forge.joomla.org/sf/go/artf5779?nav=1

Will move this topic to the Q&T forum for follow up.

Regards Robin

User avatar
Sean
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Thu Aug 18, 2005 6:38 pm
Location: Pelham, NH USA
Contact:

Re: Preview: "You are not authorized to view this resource" after 1.0.11 upgrade

Postby Sean » Thu Aug 31, 2006 2:36 pm

RobInk wrote:Tested and confirmed. I have created a bug report: http://forge.joomla.org/sf/go/artf5779?nav=1

Will move this topic to the Q&T forum for follow up.


Awesome, thanks!
Signature rules: Literal URLs only - viewtopic.php?f=8&t=65

User avatar
Predator
Joomla! Ace
Joomla! Ace
Posts: 1827
Joined: Wed Aug 17, 2005 10:12 pm
Location: Germany-Bad Abbach
Contact:

Re: [ADDED TRACKER] Static Content Preview: "You are not authorized.." after upg

Postby Predator » Thu Aug 31, 2006 6:41 pm

Fixed in SVN by facedancer
The "Humor, Fun and Games" forum has  more than 2500 Posts, so why not build a "Humor, Fun and Games Working" Group?
.....
Malicious tongues say we have this WG right from the start, they call it core team :D

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [ADDED TRACKER] Static Content Preview: "You are not authorized.." after upg

Postby Robin » Thu Aug 31, 2006 8:22 pm

Hi,

I will be updating all Q&T topics tomorrow. I will add fixes to the known issue list as well.

Regards Robin

User avatar
Chipmunk
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Tue Aug 22, 2006 3:21 pm
Contact:

Re: [ADDED TRACKER] Static Content Preview: "You are not authorized.." after upg

Postby Chipmunk » Tue Sep 05, 2006 2:21 pm

Hi there!

I have the same issue using Joomla! 1.0.11 and a possibly related one:  the preview of non-static content item works but the wrong template is applied.  When I preview non-static content items, the first template in the list of templates is used and not the default one.

If there is a fix available like hinted previously by Robin, where can I find it?

Have fun!
http://squirrelchess.com: A beginner's journey into the complex world of chess.

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [ADDED TRACKER] Static Content Preview: "You are not authorized.." after upg

Postby Robin » Tue Sep 05, 2006 2:37 pm

Hi,

The fix should be available in SVN. I think it's the first file here: http://forge.joomla.org/integration/vie ... m=exsy1002

You can click that link, there will be a download link as well. My advice would be to wait for an official patch/release though. These fixes have not been tested yet.

User avatar
Chipmunk
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Tue Aug 22, 2006 3:21 pm
Contact:

Re: [ADDED TRACKER] Static Content Preview: "You are not authorized.." after upg

Postby Chipmunk » Tue Sep 05, 2006 2:46 pm

Robin:
thanks for the fast reply!  I guess I will go with your advice to wait for an official patch, though.  After all, the preview is not terribly important.
http://squirrelchess.com: A beginner's journey into the complex world of chess.

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [MEDIUM:ADDED TRACKER:1.0.11] Static Content Preview: "You are not authorize

Postby Robin » Fri Sep 08, 2006 10:35 am

Fixed in SVN by facedancer


Fix tested by Q&T, approved and working. Articact was already closed, also closing forum topic and moving to Resolved.

skiordie
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Sun Sep 25, 2005 11:35 am

Re: [MEDIUM:FIXED:1.0.11] Static Content Preview: "You are not authorized.."

Postby skiordie » Wed Nov 15, 2006 12:19 pm

Hi,

how can I get this patch? Registration did not work on souce forge so I have no access to the patch! Can anyone help?

Thank you!
Tom

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [MEDIUM:FIXED:1.0.11] Static Content Preview: "You are not authorized.."

Postby Robin » Wed Nov 15, 2006 9:12 pm

Hi Tom,

See if the attached file solves your problem, I downloaded the latest contentwindow.php and zipped it for you.
You should unzip and upload to /administrator/popups/

Regards Robin
You do not have the required permissions to view the files attached to this post.

skiordie
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Sun Sep 25, 2005 11:35 am

Re: [MEDIUM:FIXED:1.0.11] Static Content Preview: "You are not authorized.."

Postby skiordie » Wed Nov 15, 2006 9:53 pm

Hi!

Thank you for your help. I finally got the files from Sourceforge...seems their Registration Mail is very slow. So I finally got it.

Maybe your file will help other users for a quicker solution to this issue.

Till then,
Tom

User avatar
trevor4370
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 113
Joined: Fri Oct 14, 2005 5:26 am

Re: [MEDIUM:FIXED:1.0.11] Static Content Preview: "You are not authorized.."

Postby trevor4370 » Thu Jan 11, 2007 7:53 am

Running Joomla 1.0.12 update from 1.0.11, and I have this problem "You are not authorised to view this resource" when I try and preview the Item. It is not a static page ........ any ideas?

Maybe because it is an updated 1.0.11?????? - Should I overwrite all the files with a full version 1.0.12?

evanr76
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Mon Dec 04, 2006 12:39 pm

Re: [MEDIUM:FIXED:1.0.11] Static Content Preview: "You are not authorized.."

Postby evanr76 » Thu Jan 18, 2007 3:18 am

Experiencing this issue as well after upgrade to 1.0.12 from 1.0.11 (non-static content previewing is broken)

thinkweb
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Apr 25, 2007 4:01 pm
Location: Sydney, Australia
Contact:

Re: [MEDIUM:FIXED:1.0.11] Static Content Preview: "You are not authorized.."

Postby thinkweb » Wed Apr 25, 2007 4:07 pm

Joomla forge is down so I can't try and access the fix mentioned above.

This is a "me too" message. Joomla v 1.12. User can view preview pop-up window while editing content but after a random number of previews they get the message "You are not authorised to view this resource."
Thinkweb Consulting, Sydney Australia
www.thinkweb.com.au
Web Design, CMS, SEO, SEM, e-commerce, web application development, web analytics.

thinkweb
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Wed Apr 25, 2007 4:01 pm
Location: Sydney, Australia
Contact:

Re: [MEDIUM:FIXED:1.0.11] Static Content Preview: "You are not authorized.."

Postby thinkweb » Sun Apr 29, 2007 3:23 pm

Quick update. I didn't notice the file attachement in RobInk's post. Damned small icon and text!

Uploaded fix and based on a quick test it seems to resolve the problem. Thanks!
Thinkweb Consulting, Sydney Australia
www.thinkweb.com.au
Web Design, CMS, SEO, SEM, e-commerce, web application development, web analytics.


Return to “Q&T 1.0.x Resolved - Archived”

Who is online

Users browsing this forum: No registered users and 1 guest