[MEDIUM:FIXED: 1.0.11] Letterman - A subscribe message could not be sent

Locked
Justin.Swan
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Sep 06, 2006 1:02 am

[MEDIUM:FIXED: 1.0.11] Letterman - A subscribe message could not be sent

Post by Justin.Swan » Wed Sep 06, 2006 2:30 am

Hi all,

Are there any known bugs, issues or solutions for this? I can't find anything mentioned anywhere.
Letterman version (mod and com) are 1.2.3

Description:
I've just upgraded a site from Mambo to Joomla 1.0.9 then to 1.0.11. I am having problems with the Letterman module giving me the message 'A subscribe message could not be sent' when trying to subscribe to the newsletter.

Reported on:
Joomla 1.0.11

Classification:
Medium?

Affected functions:
Newsletter subscription - Letterman 1.2.3

Related files:
Not familiar enough with structure of Joomla to know which files are related.

Steps to replicate:
Enter into letterman module - subscription area, an email address, submit - message comes up, entry is added to database ok but not able to send a confirmation email?

Analysis:
Confirmed, three different email addresses, on sendmail and phpmail, have checked that sendmail is using the write path, have tried RG_EMULATION as 1 and 0.

Proposed fix(es):
???

Topic / Artifact ID:
http://www.hinterlandgrapevine.com

System info:
?? How much sys info do you need?
I'll post if required but not sure I want to give out so much info...

Kind regards, Justin
Last edited by Robin on Mon Oct 16, 2006 11:52 am, edited 1 time in total.

Steve_B
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Mon Nov 28, 2005 3:41 pm

Re: Letterman - A subscribe message could not be sent

Post by Steve_B » Wed Sep 06, 2006 6:38 am

I can confirm the same issue after upgrading to v. 1.0.11 and with both Letterman versions 1.22 and 1.23

Looking for a solution.  Will report back if I make any headway...

Steve

Justin.Swan
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Sep 06, 2006 1:02 am

Re: Letterman - A subscribe message could not be sent

Post by Justin.Swan » Wed Sep 06, 2006 10:27 am

Thanks Steve_B, I can confirm it again. Have just upgraded my own personal site from 1.0.8 to 1.0.11. Same problem.

friesengeist
Joomla! Guru
Joomla! Guru
Posts: 842
Joined: Sat Sep 10, 2005 10:31 pm

Re: Letterman - A subscribe message could not be sent

Post by friesengeist » Wed Sep 06, 2006 11:33 am

Seams actually to be a bug from the latest security changes to the mosMail function, i'm looking into it...
We may not be able to control the wind, but we can always adjust our sails

Steve_B
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Mon Nov 28, 2005 3:41 pm

Re: Letterman - A subscribe message could not be sent

Post by Steve_B » Wed Sep 06, 2006 4:46 pm

After looking at the mosmail function in the joomla.php file it appears that this function is returning a false value.  My understanding of preg_match is sparse at best so I'm not sure where the problem might be. 

Obviously removing the JosIsValidEmail calls is a security issue.  I'll keep digging and post if I figure anything out.

Steve

kbross
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Sep 06, 2006 4:16 am

Re: Letterman - A subscribe message could not be sent

Post by kbross » Fri Sep 08, 2006 12:39 am

I have not tried this yet, but perhaps the following thread will be useful:

http://virtuemart.net/index.php?option= ... ic=21331.0

Hope this helps.

Kevin

kbross
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Sep 06, 2006 4:16 am

Re: Letterman - A subscribe message could not be sent

Post by kbross » Fri Sep 08, 2006 1:01 am

kbross wrote: I have not tried this yet, but perhaps the following thread will be useful:

http://virtuemart.net/index.php?option= ... ic=21331.0

Hope this helps.

Kevin
I have tested, and the above fix from the developer worked for me with Joomla 1.0.11.

Kevin

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: Letterman - A subscribe message could not be sent

Post by Robin » Fri Sep 08, 2006 10:07 am

[TAGGED: Q&T] Status > Under review

Justin.Swan
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Sep 06, 2006 1:02 am

Re: [MEDIUM: UNDER REVIEW: 1.0.11] Letterman - A subscribe message could not be

Post by Justin.Swan » Mon Sep 11, 2006 4:35 am

That fixed it. Thx!

Steve_B
Joomla! Apprentice
Joomla! Apprentice
Posts: 17
Joined: Mon Nov 28, 2005 3:41 pm

Re: [MEDIUM: UNDER REVIEW: 1.0.11] Letterman - A subscribe message could not be sent

Post by Steve_B » Mon Sep 11, 2006 5:25 am

It seems that Sören's patch in the above listed link does resolve the issue!  The use of the additional variables corrects the problem.

Thanks!

Justin.Swan
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Sep 06, 2006 1:02 am

Re: [MEDIUM: UNDER REVIEW: 1.0.11] Letterman - A subscribe message could not be sent

Post by Justin.Swan » Mon Sep 11, 2006 5:50 am

Here's the file and instructions for those of you wanting a quick fix...
You do not have the required permissions to view the files attached to this post.

friesengeist
Joomla! Guru
Joomla! Guru
Posts: 842
Joined: Sat Sep 10, 2005 10:31 pm

Re: [MEDIUM: UNDER REVIEW: 1.0.11] Letterman - A subscribe message could not be

Post by friesengeist » Sun Sep 17, 2006 1:53 am

Just as a cross reference:
I've opened up a tracker artifact: http://forge.joomla.org/sf/go/artf5986
We may not be able to control the wind, but we can always adjust our sails

brandypuff
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Tue Sep 05, 2006 2:35 pm

Re: What about mkPostman? Same issue

Post by brandypuff » Thu Sep 21, 2006 2:17 am

mkPostman is the followon to Letterman. I implemented the changes for letterman into mkpostman.php but still getthe error about not being able to send email. anyone got mkpostman working with the latest Joomla?

brandypuff

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [MEDIUM: UNDER REVIEW: 1.0.11] Letterman - A subscribe message could not be

Post by Robin » Thu Sep 21, 2006 6:27 pm

Q&T Note; status changed to ADDED TRACKER

http://forge.joomla.org/sf/go/artf5986

inthedistance
Joomla! Apprentice
Joomla! Apprentice
Posts: 25
Joined: Sat Apr 08, 2006 4:02 am

Re: [MEDIUM:ADDED TRACKER: 1.0.11] Letterman - A subscribe message could not be

Post by inthedistance » Tue Sep 26, 2006 5:41 am

Hey all, in need of some help here.

The links above don't work and I'd like to get the details on this fix. Can someone re-post the instructions to get this back on track?

Many thanks!

Alejo
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 219
Joined: Fri Aug 19, 2005 12:28 pm
Contact:

Re: [MEDIUM:ADDED TRACKER: 1.0.11] Letterman - A subscribe message could not be

Post by Alejo » Thu Oct 12, 2006 5:33 pm

Related to this bug. I don't see where to post this in the bug tracker.

Per this post:

http://www.reviewsforjoomla.com/compone ... 5/#msg1385

To comply with new requirements for the mosMail function, there were two global variables left out in the /components/com_messages/messages.class.php file in the send function. This prevents the email notifications to work when a new admin message is received.
https://www.jreviews.com/joomla directory and reviews system for Joomla and WordPress

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [MEDIUM:ADDED TRACKER: 1.0.11] Letterman - A subscribe message could not be

Post by Robin » Thu Oct 12, 2006 6:14 pm

Hi Alejo,
To comply with new requirements for the mosMail function, there were two global variables left out in the /components/com_messages/messages.class.php file in the send function. This prevents the email notifications to work when a new admin message is received.
This is fixed in 1.0.12.

Regards Robin

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [MEDIUM:ADDED TRACKER: 1.0.11] Letterman - A subscribe message could not be

Post by Robin » Mon Oct 16, 2006 11:52 am

Fix for artifact (http://forge.joomla.org/sf/go/artf5986) has been tested and confirmed as working. Marking topic as FIXED, moving to Resolved.

bipula
Joomla! Apprentice
Joomla! Apprentice
Posts: 20
Joined: Tue Aug 14, 2007 4:04 am

Re: [MEDIUM:FIXED: 1.0.11] Letterman - A subscribe message could not be sent

Post by bipula » Thu Aug 30, 2007 5:47 am

hello
i have same problem but with joomla 1.0.13. when I upgraded from 1.0.7 to 1.0.13 I got this error that the subscribe message could not be sent. any patch for this?

xicopires
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Mon Jan 29, 2007 12:15 pm

Re: [MEDIUM:FIXED: 1.0.11] Letterman - A subscribe message could not be sent

Post by xicopires » Fri Sep 14, 2007 8:59 pm

Same problem here...


Locked

Return to “Q&T 1.0.x Resolved - Archived”