[LOW:TRACKER 6752:1.0.11] mms:// is not resolving on the menus.

Locked
vampmaster
Joomla! Intern
Joomla! Intern
Posts: 97
Joined: Wed Oct 12, 2005 1:59 am
Location: Mexico - Transylvania
Contact:

[LOW:TRACKER 6752:1.0.11] mms:// is not resolving on the menus.

Post by vampmaster » Tue Sep 26, 2006 4:15 pm

Hello.

I've just made the upgrade to 1.0.11 last week and now i have a big problem. When I put a link to a mms:// site, it wont do it. It used to but now it sends me to http://www.universal1460.com/mms:// instead of mms:...

it seems it's not recognizing the mms:// as a valid protocol (i know some of us don't like windows but that is taking things to the next level).

Thanks,

Elliot J. Balanza
Last edited by Robin on Tue Nov 14, 2006 1:34 pm, edited 1 time in total.
Live Long and Prosper.

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: mms:// is not resolving on the menus.

Post by Robin » Wed Sep 27, 2006 2:06 pm

Hi Elliot,

Can you provide me with a valid mms url so I can test this?

Thanks and regards, Robin

vampmaster
Joomla! Intern
Joomla! Intern
Posts: 97
Joined: Wed Oct 12, 2005 1:59 am
Location: Mexico - Transylvania
Contact:

Re: mms:// is not resolving on the menus.

Post by vampmaster » Wed Sep 27, 2006 5:01 pm

mms://65.167.217.30:81/envivo
that is a valid mms addy.

go to http://www.universal1460.com/index.php, if you click on the girl on the right side that says "Señal en vivo" you will be able to hear the station.

if you try the señal en vivo from the left pane (main menu) you will notice it opens a new window and adds the http://www.universal1460.com/ to the mms command.

I'm working on the top menu with a forwarder right now.

Thanks for your support.

EJB
Live Long and Prosper.

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: mms:// is not resolving on the menus.

Post by Robin » Fri Sep 29, 2006 9:23 am

Thanks for the url. I just tested it and see that the live_site is added to the link. I'll have to do some digging and furher testing, if this is a bug, I'll move the topic to our Q&T forum and take it from there.

User avatar
vamba
Joomla! Guru
Joomla! Guru
Posts: 668
Joined: Thu Aug 18, 2005 2:56 pm
Location: Pontecosi
Contact:

Re: mms:// is not resolving on the menus.

Post by vamba » Fri Sep 29, 2006 11:58 am

Issue confirmed also in svn 5190 [1.0.12]
live test site here http://test.jmovies.eu/index.php
Member of the Italian Joomla Translation Team Since Sept.1th 2005

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: mms:// is not resolving on the menus.

Post by Robin » Fri Sep 29, 2006 1:45 pm

Thanks Marco, for testing this as well.

User avatar
vamba
Joomla! Guru
Joomla! Guru
Posts: 668
Joined: Thu Aug 18, 2005 2:56 pm
Location: Pontecosi
Contact:

Re: mms:// is not resolving on the menus.

Post by vamba » Fri Sep 29, 2006 1:59 pm

;)
Unfortunally no much free time for Q&T
....but when possible to be helpfull........ i'm here and ready to help
Member of the Italian Joomla Translation Team Since Sept.1th 2005

vampmaster
Joomla! Intern
Joomla! Intern
Posts: 97
Joined: Wed Oct 12, 2005 1:59 am
Location: Mexico - Transylvania
Contact:

Re: mms:// is not resolving on the menus.

Post by vampmaster » Fri Sep 29, 2006 4:36 pm

so just for my information, I should post it to q&t or what should I do?.

Elliot J. Balanza
Live Long and Prosper.

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: mms:// is not resolving on the menus.

Post by Robin » Fri Sep 29, 2006 7:58 pm

Hi Elliot,

I'll move the topic to Q&T so we can review this and determine if this is a bug or not.

vampmaster
Joomla! Intern
Joomla! Intern
Posts: 97
Joined: Wed Oct 12, 2005 1:59 am
Location: Mexico - Transylvania
Contact:

Re: [LOW:UNDER REVIEW:1.0.11] mms:// is not resolving on the menus.

Post by vampmaster » Wed Oct 04, 2006 6:53 pm

So has anyone have had the chance to verify this?

Vamp
Live Long and Prosper.

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [LOW:UNDER REVIEW:1.0.11] mms:// is not resolving on the menus.

Post by Robin » Thu Oct 05, 2006 5:51 am

So far it's been verified by at least one other Q&T member. I'll need to check his comments on this and take it from there. Thanks for your patience.

User avatar
RobS
Joomla! Ace
Joomla! Ace
Posts: 1367
Joined: Mon Dec 05, 2005 10:17 am
Location: New Orleans, LA, USA
Contact:

Re: [LOW:UNDER REVIEW:1.0.11] mms:// is not resolving on the menus.

Post by RobS » Thu Oct 26, 2006 7:16 am

I think that this is going to be another easy fix.  Try this, edit includes/sef.php.  Look for line ~530 that will look like the first section of code below and modify it to look like the second section of code.  Then try to create a link of mss:// type and see if it works correctly.  I would appreciate it if someone running OpenSEF or something like that could test this to make sure it doesn't break those components.  I tested it with core SEF and it seemed to work fine. 

Code: Select all

// array list of non http/https	URL schemes
$url_schemes 	= explode( ', ', _URL_SCHEMES );
$url_schemes[] 	= 'http:';
$url_schemes[] 	= 'https:';
Change it to:

Code: Select all

// array list of non http/https	URL schemes
$url_schemes 	= explode( ', ', _URL_SCHEMES );
$url_schemes[] 	= 'http:';
$url_schemes[] 	= 'https:';
$url_schemes[] 	= 'mms:';
Rob Schley - Open Source Matters
Webimagery - http://www.webimagery.net/ - Professional Consulting Services
JXtended - http://www.jxtended.com/ - Free and Commercial Joomla! Extensions

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [LOW:UNDER REVIEW:1.0.11] mms:// is not resolving on the menus.

Post by Robin » Thu Oct 26, 2006 8:45 am

Rob,

I installed OpenSEF 2.0.0. RC5 SP2 and changing looking at the newly created menu item with mms link I get the following with OpenSEF enabled:

http://localhost/joomla-dev-10/mms://65 ... :81/envivo

Is was indeed working correct with Core SEF. Going to have a look at the OpenSEF files if I can find an explanation to this.

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [LOW:UNDER REVIEW:1.0.11] mms:// is not resolving on the menus.

Post by Robin » Thu Oct 26, 2006 9:09 am

Hi,

If you look at OpenSEF file /administrator/components/com_sef/sef.functions.php you find code at line ~422:

Code: Select all

				} else if ( ( strpos( $string, 'http' ) !== 0 )
					&& ( strpos( $string, 'https' ) !== 0 )
					&& ( strpos( $string, 'ftp' ) !== 0 )
					&& ( strpos( $string, 'file' ) !== 0 )
					&& ( strpos( $string, 'mailto' ) !== 0 )
					&& ( strpos( $string, 'javascript' ) !== 0 ) ) {
Adding the following line also solves the issue of adding live_site to the mms link in OpenSEF:

Code: Select all

					&& ( strpos( $string, 'mms' ) !== 0 )
Question now is, do we go ahead with this fix? If you ask me we should. But...look at the url prefixes in Opensef (ftp, file etc), should we add those as well? And not just mms?

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [LOW:TRACKER 6752:1.0.11] mms:// is not resolving on the menus.

Post by Robin » Tue Nov 14, 2006 1:34 pm

Q&T Note; bug confirmed and added to tracker; http://forge.joomla.org/sf/go/artf6752?nav=1

User avatar
Predator
Joomla! Ace
Joomla! Ace
Posts: 1827
Joined: Wed Aug 17, 2005 10:12 pm
Location: Germany-Bad Abbach
Contact:

Re: [LOW:TRACKER 6752:1.0.11] mms:// is not resolving on the menus.

Post by Predator » Thu Nov 16, 2006 3:29 am

I will add mms to OpenSEF and would suggest to add the others to Joomla! sef as well, did add those due to some user requests which have those links and no probs reported since months.

Will add now first mms to SVN, for the rest some more thoughts or feedbacks ;)
Last edited by Predator on Thu Nov 16, 2006 3:34 am, edited 1 time in total.
The "Humor, Fun and Games" forum has  more than 2500 Posts, so why not build a "Humor, Fun and Games Working" Group?
.....
Malicious tongues say we have this WG right from the start, they call it core team :D

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [LOW:TRACKER 6752:1.0.11] mms:// is not resolving on the menus.

Post by Robin » Thu Nov 16, 2006 6:56 am

Marko,

The ftp, mailto and file look very common to me so I see no reason myself to add them to the Joomla! sef file. Anyone else has an opinion on this?

friesengeist
Joomla! Guru
Joomla! Guru
Posts: 842
Joined: Sat Sep 10, 2005 10:31 pm

Re: [LOW:TRACKER 6752:1.0.11] mms:// is not resolving on the menus.

Post by friesengeist » Thu Nov 16, 2006 12:57 pm

Marko, I've nothing against adding it. Actually, it's already there, in joomla.php, line 107.

Code: Select all

// Non http/https URL Schemes
$url_schemes = 'data:, file:, ftp:, gopher:, imap:, ldap:, mailto:, news:, nntp:, telnet:, javascript:, irc:';
DEFINE( '_URL_SCHEMES', $url_schemes );
We may not be able to control the wind, but we can always adjust our sails

User avatar
Predator
Joomla! Ace
Joomla! Ace
Posts: 1827
Joined: Wed Aug 17, 2005 10:12 pm
Location: Germany-Bad Abbach
Contact:

Re: [LOW:TRACKER 6752:1.0.11] mms:// is not resolving on the menus.

Post by Predator » Thu Nov 16, 2006 1:12 pm

friesengeist wrote: Marko, I've nothing against adding it. Actually, it's already there, in joomla.php, line 107.

Code: Select all

// Non http/https URL Schemes
$url_schemes = 'data:, file:, ftp:, gopher:, imap:, ldap:, mailto:, news:, nntp:, telnet:, javascript:, irc:';
DEFINE( '_URL_SCHEMES', $url_schemes );
Funny the guy who add it there missed the sef.php :) , shall i add all to the sef.php?
The "Humor, Fun and Games" forum has  more than 2500 Posts, so why not build a "Humor, Fun and Games Working" Group?
.....
Malicious tongues say we have this WG right from the start, they call it core team :D

friesengeist
Joomla! Guru
Joomla! Guru
Posts: 842
Joined: Sat Sep 10, 2005 10:31 pm

Re: [LOW:TRACKER 6752:1.0.11] mms:// is not resolving on the menus.

Post by friesengeist » Thu Nov 16, 2006 1:48 pm

Predator wrote: Funny the guy who add it there missed the sef.php :) , shall i add all to the sef.php?
Hugh? It's already in there, in sef.php :)

Code: Select all

$url_schemes 	= explode( ', ', _URL_SCHEMES );
No need to define it twice ;)
We may not be able to control the wind, but we can always adjust our sails

User avatar
Predator
Joomla! Ace
Joomla! Ace
Posts: 1827
Joined: Wed Aug 17, 2005 10:12 pm
Location: Germany-Bad Abbach
Contact:

Re: [LOW:TRACKER 6752:1.0.11] mms:// is not resolving on the menus.

Post by Predator » Thu Nov 16, 2006 1:56 pm

Ah missed that :D so better to add mms there instead of adding it to the sef.php.
The "Humor, Fun and Games" forum has  more than 2500 Posts, so why not build a "Humor, Fun and Games Working" Group?
.....
Malicious tongues say we have this WG right from the start, they call it core team :D

User avatar
Predator
Joomla! Ace
Joomla! Ace
Posts: 1827
Joined: Wed Aug 17, 2005 10:12 pm
Location: Germany-Bad Abbach
Contact:

Re: [LOW:TRACKER 6752:1.0.11] mms:// is not resolving on the menus.

Post by Predator » Thu Nov 16, 2006 2:02 pm

Ok added mms in joomla.php line 106
The "Humor, Fun and Games" forum has  more than 2500 Posts, so why not build a "Humor, Fun and Games Working" Group?
.....
Malicious tongues say we have this WG right from the start, they call it core team :D

User avatar
miki89
Joomla! Explorer
Joomla! Explorer
Posts: 397
Joined: Wed Jan 04, 2006 3:28 pm
Location: Milan, Italy

Re: [LOW:TRACKER 6752:1.0.11] mms:// is not resolving on the menus.

Post by miki89 » Thu Nov 16, 2006 4:27 pm

Tested the fix and it works ;)
Imagination is more important than knowledge... (Albert Einstein)

User avatar
RobS
Joomla! Ace
Joomla! Ace
Posts: 1367
Joined: Mon Dec 05, 2005 10:17 am
Location: New Orleans, LA, USA
Contact:

Re: [LOW:TRACKER 6752:1.0.11] mms:// is not resolving on the menus.

Post by RobS » Thu Nov 16, 2006 4:32 pm

Thanks guys, sorry for pointing you in the wrong direction Marko  :-[

I will close the artifact now that it has been tested.
Rob Schley - Open Source Matters
Webimagery - http://www.webimagery.net/ - Professional Consulting Services
JXtended - http://www.jxtended.com/ - Free and Commercial Joomla! Extensions

User avatar
Predator
Joomla! Ace
Joomla! Ace
Posts: 1827
Joined: Wed Aug 17, 2005 10:12 pm
Location: Germany-Bad Abbach
Contact:

Re: [LOW:TRACKER 6752:1.0.11] mms:// is not resolving on the menus.

Post by Predator » Thu Nov 16, 2006 4:49 pm

RobS wrote: Thanks guys, sorry for pointing you in the wrong direction Marko  :-[

I will close the artifact now that it has been tested.
No was ok to point me in the wrong direction i can change it now also in OpenSEF by using _URL_SCHEMES there, totally forgot this DEFINE part in the joomla.php :D
The "Humor, Fun and Games" forum has  more than 2500 Posts, so why not build a "Humor, Fun and Games Working" Group?
.....
Malicious tongues say we have this WG right from the start, they call it core team :D

User avatar
RobS
Joomla! Ace
Joomla! Ace
Posts: 1367
Joined: Mon Dec 05, 2005 10:17 am
Location: New Orleans, LA, USA
Contact:

Re: [LOW:TRACKER 6752:1.0.11] mms:// is not resolving on the menus.

Post by RobS » Fri Nov 17, 2006 7:11 am

Q&T Note; Status> Fixed for next Release.

Moving to Resolved sub-forum.
Rob Schley - Open Source Matters
Webimagery - http://www.webimagery.net/ - Professional Consulting Services
JXtended - http://www.jxtended.com/ - Free and Commercial Joomla! Extensions

vampmaster
Joomla! Intern
Joomla! Intern
Posts: 97
Joined: Wed Oct 12, 2005 1:59 am
Location: Mexico - Transylvania
Contact:

Re: [LOW:TRACKER 6752:1.0.11] mms:// is not resolving on the menus.

Post by vampmaster » Tue Dec 12, 2006 9:54 pm

Thanks for your efforts guys.

Vamp
Live Long and Prosper.


Locked

Return to “Q&T 1.0.x Resolved - Archived”