Page 1 of 1

[UNCONFIRMED] PHP 5.1.4 related errors media manager and XHTML Suite.

Posted: Wed Jun 14, 2006 4:14 pm
by althoffm
Description:

PHP 5.1.4 related errors media manager and XHTML Suite.

MEDIA MANAGER
========================

Warning: unlink(***//***//***\images/stories\106_0629.JPG)
[function.unlink]: No such file or directory in ***:\***\***\***\administrator\components\com_media\admin.media.php on line 99

094 function delete_file( $listdir ) {
095 $delFile = makeSafe( mosGetParam( $_REQUEST, 'delFile', '' ) );
096 $fullPath = COM_MEDIA_BASE . $listdir . DIRECTORY_SEPARATOR . stripslashes( $delFile );
097
098 if (file_exists( $fullPath )) {
099 unlink( $fullPath );
100 }
101 }

XHTML SUITE HTML EDITOR
========================

XHTML Suite is a third party component but we had no problems running it on Joombla 1.08 and after the upgrade running on Joombla 1.09 using PHP 4.4.2, After our ISP upgraded us to PHP 5.1.4, will contact also created of component.

Warning: mkdir() [function.mkdir]: No such file or directory in ***:\***\***\***\components\com_htmlarea3_xtd-c\popups\ImageManager\images.php
on line 73

Warning: chmod() [function.chmod]: No such file or directory in ***:\***\***\***\components\com_htmlarea3_xtd-c\popups\ImageManager\images.php
on line 74

67 function create_folder() {
68 global $BASE_DIR, $IMG_ROOT, $refresh_dirs;
69 $folder_name = $_GET['foldername'];
70 if(strlen($folder_name) >0) {
71 $folder = $BASE_DIR.$IMG_ROOT.$folder_name;
72 if(!is_dir($folder) && !is_file($folder)) {
73 mkdir($folder,0777);
74 chmod($folder,0777);
75 $refresh_dirs = true;
76 }
77 }
78 }

I have asked our ISP to temporary set is back to PHP 4.4.2 to rule out other problems and the problems resolved, but then our newsfeeds wound work. http://forum.joomla.org/index.php/topic,67201.0.html

Reported on:
Joomla! 1.0.9 Stable [ Sunshine ] 05 June 2006 16:00 UTC

Classification:
Medium.

Affected functions:
Media manager third party component XHTML Suite.

Related files:
Media manager old should have been solved http://forum.joomla.org/index.php/topic,7581.0.html
XHTML Suite none found on both Joombla and XHTML Suite forum.

Steps to replicate:

Media manager:

* Upload image
* Delete image from within image manager.

Analysis:
No other comments.

Proposed fix(es):.

None.

Topic / Artifact ID:
None.

System info:

PHP built On:  Windows NT net3-nl-iis-14 5.0 build 2195 
PHP Version:  5.1.4 
Web Server:  Microsoft-IIS/5.0 
Joomla! Version:  Joomla! 1.0.9 Stable [ Sunshine ] 05 June 2006 16:00 UTC

Re: [UNDER REVIEW] PHP 5.1.4 related errors media manager and XHTML Suite.

Posted: Fri Jun 16, 2006 7:26 am
by Robin
Hi althoffm,

Thanks for the report. I/We will need to do basic tests to see if we can confirm the issue. Probably gonna take some extra time since most of us do not have access to a Windows/IIS setup.

Regards Robin

Re: [UNDER REVIEW] PHP 5.1.4 related errors media manager and XHTML Suite.

Posted: Fri Oct 27, 2006 6:13 am
by Robin
Q&T Note; tested on below stated webserver. Unable to confirm this issue on latest stable release 1.0.11. Marking topic UNCONFIRMED and moving to Superseded.

PHP built On:  Windows NT 5.2 build 3790
Database Version: 5.0.22-community-nt
PHP Version: 5.1.4
Web Server: Microsoft-IIS/6.0
WebServer to PHP interface: cgi-fcgi
Joomla! Version: Joomla! 1.0.11 Stable [ Sunbow ] 28 August 2006 20:00 UTC
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0