[ADDED TRACKER] Successfully Saved Item: {title} ... slashes not stripped...

Slapyo
Joomla! Apprentice
Joomla! Apprentice
Posts: 32
Joined: Thu Oct 13, 2005 11:25 pm
Contact:

[ADDED TRACKER] Successfully Saved Item: {title} ... slashes not stripped...

Postby Slapyo » Thu Jul 06, 2006 1:19 am

Description:
After saving content, slashes are not stripped from the quotes where it says "Successfully Saved Item: {title}" For example, if I saved content with the title of:

"Hello World"

Upon saving it, the next screen would show this:

\"Hello World\"

Nothing major, just noticed it.

Reported on:
1.0.9

Classification:

Steps to replicate:
- Login to Administrator area
- Click Add New Content
- Create title with a " in it
- Add some bogus content
- Click Save

Analysis:

Proposed fix(es):
Not sure about an exact line of code, but should just require a stripslashes.

edited: I meant slashes need to be stripped from quotes, not quotes need to be stripped.
Last edited by Predator on Thu Aug 31, 2006 6:27 pm, edited 1 time in total.

User avatar
RobS
Joomla! Ace
Joomla! Ace
Posts: 1367
Joined: Mon Dec 05, 2005 10:17 am
Location: New Orleans, LA, USA
Contact:

Re: Successfully Saved Item: {title} ... quotes not stripped from title

Postby RobS » Thu Jul 06, 2006 3:21 am

I can confirm this is still the case in J! 1.0.10.  If you enter the title, including quotation marks, "Hello World" and then save the content item the save notification will display: Successfully Saved Item: \"Hello World\".  The slashes should not be displayed.  It isn't that the quotes should be stripped, it is that the slash marks should be stripped.
Last edited by RobS on Thu Jul 06, 2006 3:23 am, edited 1 time in total.
Rob Schley - Open Source Matters
Webimagery - http://www.webimagery.net/ - Professional Consulting Services
JXtended - http://www.jxtended.com/ - Free and Commercial Joomla! Extensions

jmstacey
Joomla! Fledgling
Joomla! Fledgling
Posts: 3
Joined: Fri Mar 03, 2006 6:53 pm

Re: [ADDED TRACKER] Successfully Saved Item: {title} ... slashes not stripped...

Postby jmstacey » Sat Jul 08, 2006 10:18 pm

This also occurs when you're saving changes. To reproduce follow the exact same steps except click Apply instead of Save on the last step.

This is on 1.0.10

User avatar
last_exile
Joomla! Apprentice
Joomla! Apprentice
Posts: 19
Joined: Tue Jun 13, 2006 7:33 pm
Location: Western Isles Scotland
Contact:

Re: [ADDED TRACKER] Successfully Saved Item: {title} ... slashes not stripped...

Postby last_exile » Sat Jul 08, 2006 10:49 pm

Same story with single quotes
"Coming together is a beginning.  Keeping together is progress.  Working together is success. - Henry Ford"

Linux Daily Community Portal
http://www.linuxdaily.org.uk

User avatar
vamba
Joomla! Guru
Joomla! Guru
Posts: 668
Joined: Thu Aug 18, 2005 2:56 pm
Location: Pontecosi
Contact:

Re: [ADDED TRACKER] Successfully Saved Item: {title} ... slashes not stripped...

Postby vamba » Sat Jul 22, 2006 2:17 pm

last_exile wrote:Same story with single quotes

Confirm

An italian user message me this configuration
MySQL - 5.0.20-Debian_0bpo1

    * Protocl: 10
    * Server: sql.nuovagiuntaombra.it via TCP/IP
    * char set MySQL: UTF-8 Unicode (utf8)

   
phpMyAdmin - 2.8.0.2

    * MySQL version client: 4.0.24

He have notice a problem with a menu item like this L'aquila
showed like this L\'Aquila
Member of the Italian Joomla Translation Team Since Sept.1th 2005

User avatar
Predator
Joomla! Ace
Joomla! Ace
Posts: 1827
Joined: Wed Aug 17, 2005 10:12 pm
Location: Germany-Bad Abbach
Contact:

Re: [ADDED TRACKER] Successfully Saved Item: {title} ... slashes not stripped...

Postby Predator » Thu Aug 31, 2006 6:27 pm

Fixed in SVN
The "Humor, Fun and Games" forum has  more than 2500 Posts, so why not build a "Humor, Fun and Games Working" Group?
.....
Malicious tongues say we have this WG right from the start, they call it core team :D

User avatar
Robin
Joomla! Master
Joomla! Master
Posts: 15753
Joined: Thu Aug 18, 2005 10:41 am

Re: [ADDED TRACKER] Successfully Saved Item: {title} ... slashes not stripped...

Postby Robin » Mon Oct 16, 2006 2:39 pm

Q&T Note; Moving to superseded issues forum

nanobi
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sun Dec 03, 2006 2:34 am
Location: NY
Contact:

Re: [ADDED TRACKER] Successfully Saved Item: {title} ... slashes not stripped...

Postby nanobi » Mon Jan 01, 2007 11:09 pm

Predator wrote:Fixed in SVN


Would you be able to clarify.  I read that SVN refers to Subversion server, but I don't really understand how this works or what exactly I'm supposed to do to get rid of the slash.  I am using Joomla 1.0.11.


Return to “Superseded Issues - Archive”

Who is online

Users browsing this forum: No registered users and 2 guests