Page 1 of 1

Cannot send email from "Contact Us" on website

Posted: Thu Jan 31, 2008 7:57 am
by dzhao
Hello,

I don't know why I cannot send email from "Contact Us" on website, but everything looks like ok, including the message after sending. but I cannot receive that message.

By the way, last year, it is ok, I don't know which setting I did.

Thanks

Re: Cannot send email from "Contact Us" on website

Posted: Thu Jan 31, 2008 9:33 am
by infograf768
Try tweaking the settings for mail in Global Configuration

Re: Cannot send email from "Contact Us" on website

Posted: Thu Jan 31, 2008 10:41 am
by dzhao
Thank you for your reply and suggestion

Now
setting:

Mailer: Sendmail
Mail From: xxx
From Name: xxx
Sendmail path:/usr/sbin/sendmail
SMTP Auth: No
SMTP User: (blank)
SMTP Pass: (blank)
SMTP Host: localhost


Any suggestion?

Thanks

Re: Cannot send email from "Contact Us" on website

Posted: Thu Jan 31, 2008 11:17 am
by infograf768
Use smtp instead of sendmail
Use your isp smtp instead of local host

Re: Cannot send email from "Contact Us" on website

Posted: Thu Jan 31, 2008 11:34 am
by dzhao
Thanks

If I setup SMTP, I need contact ISP firstly, but just now I chose "php email function", it is working. I don't remember which one I chose last year, I also don't know whether I changed options last year.

I guess, maybe after update from 1.0.12 to 1.0.13, the setting (Mail) back to original setting.

Anyway, now it is ok, and many thanks for your reply

Dong

Re: Cannot send email from "Contact Us" on website

Posted: Thu Jan 31, 2008 1:17 pm
by infograf768
Great!
PHP mail, if working, is even simpler.

BTW, otherwise, it's not necessary to contact your isp for the smtp server. Just use the same smtp as for your mail application.

Re: Cannot send email from "Contact Us" on website

Posted: Wed Feb 06, 2008 9:38 am
by qwerty79
I also have this problem. Try to search solution in this forum but still cannot.

My problem is, I cant send email to the contact in the contact us.
When use PHP Mailer, I get "Please make sure all the ......".
When I use SMTP and Sendmail, everything look find with message "Thank you for your email" but I didn't receive the message.

But in JCal Pro, I can receive email for notification of new event. I use smtp for the componet. And it work.

Also test the php mail function by creating a new file test.php

Code: Select all

<?php
require("class.phpmailer.php");
$mail = new PHPMailer();
$mail->IsSMTP(); // telling the class to use SMTP
$mail->Host = "smtp.****.com"; // SMTP server
$mail->From = "username@sender.com";
$mail->AddAddress("usernamel@receiver.com");

$mail->Subject = "first mailing";
$mail->Body = "hi ! \n\n this is First mailing I made myself with PHPMailer !";
$mail->WordWrap = 50;

if(!$mail->Send())
{
   echo "Message was not sent";
   echo "Mailer Error: " . $mail->ErrorInfo;
}
else
{
   echo "Message has been sent";
}
?>
It worked, I receive the message.

But why contact us can't work?

Re: Cannot send email from "Contact Us" on website

Posted: Wed Feb 06, 2008 9:52 am
by dzhao
Since last time (your Contact Us email worked), whether you update your Joomla or not?

"Contact Us" component has php function, why you write yourself, this is for Contact Us, yor your own function?

Re: Cannot send email from

Posted: Thu Feb 14, 2008 3:07 am
by qwerty79
No, my Contact US never work.
The code is just to test the phpmail. I got it somewhere in the forum. So, my phpmailer is working but not Contact Us. I also test with Sendmail and also SMTP. But still I can't receive any email.

Re: Cannot send email from

Posted: Sat Feb 16, 2008 2:47 am
by sketec
I'm having the same problem. It was working at some point, but I noticed today when I was doing some design/content changes that the contact us page wasn't working. I don't even get a 'thank you for your email' page anymore. I wonder if this is a godaddy problem?

Re: Cannot send email from

Posted: Sat Feb 23, 2008 4:29 pm
by badurally
I Have a similar problem.
I cannot receive emails from contact us when i use info@my-domain.com but works when i use email@gmail.com.
Can anyone help me?

Thx

Re: Cannot send email from

Posted: Sat Feb 23, 2008 5:26 pm
by sketec
I found the cause of my issue. It was sh404SEF doing something with the contact page, so I put the contact page in 'custom redirects' instead of 'SEF URL's' and everything is working fine now. Relevant settings follow: Mailer: SMTP Server, Mail From: account@domain.com, SMTP Auth: No, SMTP Host: localhost

Re: Cannot send email from

Posted: Sat Nov 27, 2010 2:22 am
by aashishbisht
I have tested it on many websites, the contact us page works however if I put the Google Mail App domain email id, it never works. If I put the general GMail id or yahoo id, it works fine. I am really not sure why joomla contact us form doesn't not send the mails to the Google mail app email ids or on another note it could be a problem with the Google Mail App that it doesn't accept any email coming from the site.

Re: Cannot send email from

Posted: Thu May 26, 2011 3:05 am
by trusting
One solution that helps is to set up a domain address that forwards to the gmail address. That solved the main problem for me.

Now I'm trying to figure out why the "E-mail a copy of this message to your own address." function doesn't work. :(

Re: Cannot send email from

Posted: Thu May 26, 2011 11:28 am
by infograf768
trusting wrote:One solution that helps is to set up a domain address that forwards to the gmail address. That solved the main problem for me.

Now I'm trying to figure out why the "E-mail a copy of this message to your own address." function doesn't work. :(
These are obsolete 1.0 forums.

Which version of Joomla are you using?

Re: Cannot send email from

Posted: Thu May 26, 2011 1:51 pm
by trusting
Ah, sorry. I found the thread via search (after searching for hours through other threads and sites) and didn't notice the category. Since it had a post from about 6 months ago, I figured it was relatively current.

I'm using Joomla 1.5.23.

Teresa

Re: Cannot send email from

Posted: Tue May 31, 2011 10:18 am
by peterpiper
I have two contacts: emails sent to one of them arrive; email sent to the other do not; both 'copy to sender' functions work; I have tried sendmail and PHP Mail Function; same results

upgrading to 2.5.6 and up

Posted: Sat Jan 25, 2014 5:59 pm
by roake
This is what worked for me
Hopes it helps someone out and maybe save you a couple days of headache.



Replace phpmailer from library w/ version 2.5.2

Enter mail settings as follows (Global Config >>> Server )
Mail Settings
Mailer* - SMTP
From email - UREMAIL@URDOMAIN.COM
From Name - URNAMEGOESHERE
Sendmail Path - /usr/sbin/sendmail (DEFAULT)
SMTP Authentication - NO
(MAY NOT BE NECESSARY)
SMTP Security - SSL
SMTP Port * - 465
SMTP Username - URUSERNAME@URDOMAIN.COM
SMTP Password - ***********
SMTP Host - LOCALHOST