Page 1 of 1

System requirements and "next generation" versions

Posted: Mon Feb 13, 2006 5:45 am
by aaran
Hi,

I have noticed that the Joomla systems requirements have what I consider to be a common shortfall for documented system requirements.
Like may other WAMP/LAMP applications they need to be more specific with the PHP and Apache versions that the product supports.  In particular is Joomla supported on the PHP5 platform?  The same level of specification is required for Apache 2.0 and MySQL 5 products.  What I like to refer to as "next generation" versions.

Searching through the forums I can find anecdotal evidence that it is supported on PHP5 but with some issues.  It would be great if the System Requirements specified the exact versions.  Maybe a recommended version would also be a good idea.  I don't know if the development team have a specific platform they do QA/testing on but that would make a good starting point for preferred version.

I recommend this so users don't download a MySQL version released after the build of Joomla and discover the bugs the development haven't tested against.

Regards,

Aaran Stent

PS.  The rest of the documentation is first class, well done!

Re: System requirements and "next generation" versions

Posted: Fri Feb 24, 2006 4:11 am
by Michelle Bisson
Thank you for your comments!