Keyword expansion in svn not working

If you have any 'mechanical' forge related issues/suggestions, pop them in here.

Moderator: RussW

Forum rules
Locked
User avatar
spacemonkey
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 201
Joined: Fri Aug 12, 2005 7:50 pm
Location: Turin, Italy
Contact:

Keyword expansion in svn not working

Post by spacemonkey » Thu Apr 19, 2007 9:41 pm

When adding svn keywords like $Id:$ to svn, I notice that they are not getting expanded. Is there a setting that I must do for each project, or is there a better way of making keyword expansion work in svn?

Example:

http://joomlacode.org/gf/project/jmemca ... iew=markup

 
User avatar
Schlu
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 135
Joined: Sun Oct 23, 2005 4:01 pm
Location: Freiburg / Tettnang
Contact:

Re: Keyword expansion in svn not working

Post by Schlu » Fri Apr 20, 2007 11:29 am

Did you set the keywords property to your files and modified your subversion config file?

Code: Select all

### Set enable-auto-props to 'yes' to enable automatic properties
### for 'svn add' and 'svn import', it defaults to 'no'.
### Automatic properties are defined in the section 'auto-props'.
enable-auto-props = yes

### Section for configuring automatic properties.
[auto-props]
### The format of the entries is:
###   file-name-pattern = propname[=value][;propname[=value]...]
### The file-name-pattern can contain wildcards (such as '*' and
### '?').  All entries which match will be applied to the file.
### Note that auto-props functionality must be enabled, which
### is typically done by setting the 'enable-auto-props' option.
*.txt = svn:keywords=Id
*.php = svn:keywords=Id
schlu

User avatar
Jonah
Joomla! Explorer
Joomla! Explorer
Posts: 299
Joined: Thu Aug 18, 2005 6:02 pm
Contact:

Re: Keyword expansion in svn not working

Post by Jonah » Fri Apr 20, 2007 1:31 pm

the keywords are replaced client side then?  So the repository remains unaware of the keywords, is that correct?
trinitywebhosting.com - Free Joomla! websites for churches and non-profits.

User avatar
Schlu
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 135
Joined: Sun Oct 23, 2005 4:01 pm
Location: Freiburg / Tettnang
Contact:

Re: Keyword expansion in svn not working

Post by Schlu » Fri Apr 20, 2007 1:49 pm

Yepp, they will be replaced during the export. Think I misunderstood the question. Would be interesting to know this also.

 

Locked

Return to “JoomlaCode.org”