Error Committing to JoomlaCode from Eclipse (Fixed)

If you have any 'mechanical' forge related issues/suggestions, pop them in here.

Moderators: RussW, ChiefGoFor

Locked
User avatar
PtrNrs
Joomla! Explorer
Joomla! Explorer
Posts: 355
Joined: Sat Jul 05, 2008 3:56 am
Location: Melbourne, Australia
Contact:

Error Committing to JoomlaCode from Eclipse (Fixed)

Post by PtrNrs » Mon Mar 23, 2009 11:05 pm

I have just created a new project in JoomlaCode (http://joomlacode.org/gf/project/jix/) and successfully imported from the Jix SVN trunk (http://joomlacode.org/svn/jix) into an Eclipse project. So far so good. I didn't know whether to import the trunk or the whole lot but that's another question . . .

I inserted my component in the Eclipse project and then hit Team->Commit. I don't know whether to use anonymous & no password or my JoomlaCode username & password. I tried both anyway - both failed.

In the course of my trial and error (but mostly the latter), I got either of these errors

Code: Select all

RA layer request failed
svn: Commit failed (details follow):
svn: OPTIONS of '/svn/jix/trunk': Could not read status line: An established connection was aborted by the software in your host machine.
 (http://joomlacode.org)
but more often

Code: Select all

Authorization failed
svn: Commit failed (details follow):
svn: CHECKOUT of '/svn/jix/!svn/ver/1/trunk': authorization failed (http://joomlacode.org)
I have seen a thread or two on this topic but they used a command line version of SVN. It would be wonderful to get an Eclipse solution.
Last edited by PtrNrs on Wed Mar 25, 2009 12:11 am, edited 1 time in total.
Pete Nurse, Jix Software
http://www.jix.com.au
Jix: The Joomla Import Export & Update Utility

User avatar
PtrNrs
Joomla! Explorer
Joomla! Explorer
Posts: 355
Joined: Sat Jul 05, 2008 3:56 am
Location: Melbourne, Australia
Contact:

Re: Error Committing to JoomlaCode from Eclipse

Post by PtrNrs » Tue Mar 24, 2009 8:17 pm

Using Tortoise SVN now, I get the following error message(s):-
Command: Commit
Adding: D:\xampp\htdocs\Jix\.project
Error: Commit failed (details follow):
Error: Server sent unexpected return value (501 Method Not Implemented) in response to
Error: PROPFIND request for '/svn/jix/!svn/wrk/4703481b-7d2f-bf4e-9247-8d34e1c7528f/trunk/.project'
Finished!:
Any ideas?
Pete Nurse, Jix Software
http://www.jix.com.au
Jix: The Joomla Import Export & Update Utility

User avatar
PtrNrs
Joomla! Explorer
Joomla! Explorer
Posts: 355
Joined: Sat Jul 05, 2008 3:56 am
Location: Melbourne, Australia
Contact:

Re: Error Committing to JoomlaCode from Eclipse

Post by PtrNrs » Tue Mar 24, 2009 10:09 pm

And using the command line version of SVN (using Ian's advice at http://forum.joomla.org/viewtopic.php?f=406&t=151422), it worked. I guess that means it's no longer strictly a JoomlaCode problem but . . .

I hope it doesn't mean I have to use the CLI version of SVN for the rest of my life ;)
Pete Nurse, Jix Software
http://www.jix.com.au
Jix: The Joomla Import Export & Update Utility

User avatar
PtrNrs
Joomla! Explorer
Joomla! Explorer
Posts: 355
Joined: Sat Jul 05, 2008 3:56 am
Location: Melbourne, Australia
Contact:

Re: Error Committing to JoomlaCode from Eclipse (Fixed)

Post by PtrNrs » Wed Mar 25, 2009 12:14 am

I seem to have fixed my problem by upgrading from subclipse 1.4 to subclipse 1.6.

Commit now functions correctly.

Could it have been an SVN incompatability between Eclipse & JoomlaCode?
Pete Nurse, Jix Software
http://www.jix.com.au
Jix: The Joomla Import Export & Update Utility


Locked

Return to “JoomlaCode.org”