Solved: New menus not conforming to template?

Please see sticky inside.
Locked
SpaceHiker
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Mon Jul 02, 2007 5:38 am

Solved: New menus not conforming to template?

Post by SpaceHiker » Wed Jul 04, 2007 4:45 am

Hi, I don't see this mentioned anywhere else and I'm thinking it's something easy that I'm overlooking.

I've installed Joomla 1.5 beta2 with the rhuk_milkyway template.

Anyway, the main menu appears fine, just the way the template is supposed to display it.

When I go to create a NEW menu however, the new menu doesn't look anything like the main menu, in that it doesn't have the colored border, or the same font sizes, etc... It just looks like a generic menu.

I thought it might have something to do with the "menu style" parameters in the Module Manager, but it turns out that it doesn't.

Any idea what I'm doing wrong, or is this a bug?

Thanks!
Last edited by SpaceHiker on Wed Jul 04, 2007 6:29 pm, edited 1 time in total.

 
SpaceHiker
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Mon Jul 02, 2007 5:38 am

Re: New menus not conforming to template?

Post by SpaceHiker » Wed Jul 04, 2007 4:59 am

Also, I have noticed in the code what the problem is, but I'm still not sure why it is happening.

If you view source for the page, you will see that the main menu (the one that works) is in a

The other menus, that do not work, are in a

I can't figure out why that is happening.
Last edited by SpaceHiker on Wed Jul 04, 2007 6:34 pm, edited 1 time in total.

SpaceHiker
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Mon Jul 02, 2007 5:38 am

Re: New menus not conforming to template?

Post by SpaceHiker » Wed Jul 04, 2007 6:28 pm

SOLVED!

FYI...

For the menus to look correct, you have to Edit the module settings for that particular menu, go into Advanced Parameters, then in "Module Class Suffix" you have to add "_menu"

It's clunky but it's just a beta, I'm sure it won't do this in the stable release!

 

Locked

Return to “Joomla! 1.5 BETA 2”