Opps! I enabled system cache.

Please see sticky inside.
Locked
ChevinBrown
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Fri Dec 15, 2006 11:34 pm

Opps! I enabled system cache.

Post by ChevinBrown » Fri Jul 06, 2007 7:28 pm

I just published the system cache component, and now I get this:
Fatal error: Call to a member function on a non-object in /homepages/12/d153033563/htdocs/ScienceHillBand/Joomla/plugins/system/cache.php on line 51

How do I fix this?!!

 
KhakiMan
Joomla! Intern
Joomla! Intern
Posts: 76
Joined: Wed Aug 16, 2006 11:55 pm
Location: Glen Ellen, CA

Re: Opps! I enabled system cache.

Post by KhakiMan » Fri Jul 06, 2007 7:34 pm

I did this too... It's an easy fix. 

Open the cache.php file and comment out the offending line.  Joomla Admin will allow you to access.  Then go in and unplubish System Cache and remove the edit to cache.php.

Christian

ChevinBrown
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Fri Dec 15, 2006 11:34 pm

Re: Opps! I enabled system cache.

Post by ChevinBrown » Fri Jul 06, 2007 7:36 pm

where is the cache.php file? and what is the offending line?

KhakiMan
Joomla! Intern
Joomla! Intern
Posts: 76
Joined: Wed Aug 16, 2006 11:55 pm
Location: Glen Ellen, CA

Re: Opps! I enabled system cache.

Post by KhakiMan » Fri Jul 06, 2007 7:39 pm

Download the cache.php file via FTP.  You'll find the file in this location (/ScienceHillBand/Joomla/plugins/system/cache.php), based on your error.

Open your favorite HTML editor, hopefully it displays line numbers.  Browse down to line 51 and comment out that line.  A double-slash will take care of it.  //

You also might need to comment out line 109 too... that's what fixed it for me.

Try to login to Joomla Admin again.

ChevinBrown
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Fri Dec 15, 2006 11:34 pm

Re: Opps! I enabled system cache.

Post by ChevinBrown » Fri Jul 06, 2007 7:46 pm

Superb!  Thanks KhakiMan.

 

Locked

Return to “Joomla! 1.5 BETA 2”