1.5 RC1 templates

Please see sticky inside.
crockett
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Wed Sep 14, 2005 11:29 am

1.5 RC1 templates

Postby crockett » Sun Jul 22, 2007 7:05 am

Will older templates say for instance rocket themes vortex work with 1.5 RC1 ?

Also is RC1 still considered not stable for a live site or still not suggested?

I'm about to start working on a few new sites and I'd like to go ahead and start with 1.5, so I don't have to change change stuff later. Is it stable enough to use now that RC1 is out?

Ubertreffen
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Sun Jul 22, 2007 8:43 am

Re: 1.5 RC1 templates

Postby Ubertreffen » Sun Jul 22, 2007 9:08 am

They say don't use 1.5 beta for live production sites so I wouldn't.

Now about the templates, they will most likely work with the 1.5 stable when it comes out because of the way they are coding the new 1.5 to have it work with older joomla versions mods, templates, etc...

aimforgrowth
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 103
Joined: Mon May 14, 2007 4:10 am

Re: 1.5 RC1 templates

Postby aimforgrowth » Sun Jul 22, 2007 9:26 am

Crockett, from all of my reading in the forums, (these forums), I've been told not to use BETA 2 in production, but that I should feel very comfortable with using RC1.  Take a look around, and you'll read the same.

hazman

Re: 1.5 RC1 templates

Postby hazman » Sun Jul 22, 2007 2:38 pm

Hello, Beta2 templates work in RC1. I installed it today and tried some.

About using RC1 in a live site, I would not suggest that just yet. Give it some time to become much more stable.

User avatar
svenl
Joomla! Ace
Joomla! Ace
Posts: 1032
Joined: Mon Oct 17, 2005 1:50 pm
Location: Närke, Sweden
Contact:

Re: 1.5 RC1 templates

Postby svenl » Sun Jul 22, 2007 2:42 pm

When a new program are in beta mode. They still can do larger changes to the code in it. That means that if you do someting for yourself it might not work in the next beta release due to code changes.

When RC1 now is out they won't do any larger code changes anymore. Now they only looking into bug fixes, security issues etc. That means that your personal implimitations will work in RC2, stable release etc.

The "biggest" problem to start use 1.5 in a live site is that not all components are ready for it.

/S
8)
-
Sanningen finns där ute, har du sökt efter ditt svar?
var svaret bra och löste ditt problem? Glöm då inte att ändra ditt första inlägg till löst (Solved)

crockett
Joomla! Apprentice
Joomla! Apprentice
Posts: 47
Joined: Wed Sep 14, 2005 11:29 am

Re: 1.5 RC1 templates

Postby crockett » Sun Jul 22, 2007 3:46 pm

Ok thanks everyone for the replies. Being these are new sites and likely wont have much traffic right off the bat, I think I'll go ahead and give 1.5 rc1 a try. I'll just stay away from the nightly builds until it's stable. I'll be good to go as long as all the basic functions work as the sites I'm working on won't need any specific mods for now. I just need basic sites for now with just custom templates, about the only mod I'll need is one of the SE friendly URL set ups.

I just need to gt the sites up to start getting their placement in the SE's for some new games that are being released later this year and early next. So I don't expect a bunch of traffic right away. I just hate the idea of getting everything set up and about the time they start getting traffic the new release will likely be stable. So I'd end up having to upgrade to the 1.5 release.

I guess wort that can happen is something does work  :laugh:

User avatar
willebil
Joomla! Guru
Joomla! Guru
Posts: 764
Joined: Thu Aug 18, 2005 12:06 pm
Location: Netherlands

Re: 1.5 RC1 templates

Postby willebil » Sun Jul 22, 2007 4:02 pm

RC1 can be used on production sites.

All templates can be used. When you use an 1.0.x template on a default RC1 installation a warning about enabling the legacy mode will be rendered. You can use 1.0.x templates by enabling the legacy mode. This can be done in the plugin manager, choose system plugings and enable the legacy plugin. In the top of you admin screen a legacy icon will appear.

Templates are considered 100% backward compatible in 1.5.


Return to “Joomla! 1.5 BETA 2”

Who is online

Users browsing this forum: No registered users and 1 guest