AllVideos Plugin v2.0: THE all-in-one video management solution

Discuss the development and implementation of Joomla! bots/Plugins here.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
aamert
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Dec 21, 2006 6:35 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by aamert » Thu Jan 18, 2007 12:32 am

thanks for this allvideos plugin. unfortunately i cant make it to work.
i have tried a file local on my server as well as you tube vvideo.
nothing would display.
the content is published as well as the plugin/mambot?

i have skimmed thru this thread but couldn't find the solution to my problem.
one thing though, do i have to worry about the mambot order for version 2.4?

my content site is.... 
http://www.aamerjaved.com/index.php?opt ... 8&Itemid=2

rigth now there is a [youtube] video that should be playing on there while its not
Last edited by aamert on Thu Jan 18, 2007 12:35 am, edited 1 time in total.

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Thu Jan 18, 2007 12:47 am

Just checked and everything is OK. See screenshot attached...  ;)
You do not have the required permissions to view the files attached to this post.
Fotis Evangelou / JoomlaWorks

aamert
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Thu Dec 21, 2006 6:35 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by aamert » Thu Jan 18, 2007 1:17 am

Shoot - I thought about it after posting that message,,I think this place has blocked video streaming..sorryy but thanks for checking

BWJenkins
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sun Jun 11, 2006 5:57 am

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by BWJenkins » Thu Jan 18, 2007 4:09 am

Yes...A Poster Frame on a DVD is a still of a single frame from somewhere in the clip.  It's what you see on a chapters preview that helps you decide what chapter you want to watch.

Thanks!

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Thu Jan 18, 2007 1:50 pm

BWJenkins wrote: Yes...A Poster Frame on a DVD is a still of a single frame from somewhere in the clip.  It's what you see on a chapters preview that helps you decide what chapter you want to watch.

Thanks!
Sorry, not for the moment.  :D
Fotis Evangelou / JoomlaWorks

nam207
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Sun Jan 14, 2007 5:05 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by nam207 » Sun Jan 21, 2007 12:50 pm

Quick question: Is the mambot has anti-leech feature? If I upload using my own server?

Sorry if this has been asked before.

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Sun Jan 21, 2007 12:56 pm

Nope!

You need to arrange that from your server! Ask your hosting company how to do that!

Plus you could do this with htaccess files etc. but this needs some searching.  ;)
Fotis Evangelou / JoomlaWorks

nam207
Joomla! Apprentice
Joomla! Apprentice
Posts: 16
Joined: Sun Jan 14, 2007 5:05 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by nam207 » Sun Jan 21, 2007 11:31 pm

fotisevangelou wrote: Nope!

You need to arrange that from your server! Ask your hosting company how to do that!

Plus you could do this with htaccess files etc. but this needs some searching.  ;)
I know about server htaccess anti-leech stuff, but it never be a good solution. If leechers know the link, they can just post in other forums to download.

I've heard a PHP scrambling/obfuscate so that visitor could never get the real URL, do you guys plan to adding that feature? I'd willing to pay a fee if it works out for my needs, which is really not a lot :).

I've tested out and so far it works with [youtube] perfectly, thank you for a great mod.

dealmaker
Joomla! Apprentice
Joomla! Apprentice
Posts: 45
Joined: Sat Dec 09, 2006 6:29 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by dealmaker » Mon Jan 22, 2007 3:37 am

I am planning to use AllVideos to display video in a 3rd party component.  But this page in the component is not a Content item.  It just echo {[youtube]}sdkfjskjf{/[youtube]}, no video.  I created a content item just for testing purpose, AllVideos display the video in that testing content item.  So, it seems that it's strictly because the page of my component is not a content item.
How to go around it?
Thanks.

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Thu Jan 25, 2007 7:23 pm

You can hack the component. But it would help more if you could share with the rest, what component is that!  :D

I have started a thread for such hacks here:
http://forum.joomla.org/index.php/topic,118475.0.html
Fotis Evangelou / JoomlaWorks

User avatar
kai920
Joomla! Guru
Joomla! Guru
Posts: 542
Joined: Sun Sep 04, 2005 3:59 pm
Location: Hong Kong

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by kai920 » Thu Feb 01, 2007 4:12 pm

Hi fotisevangelou,

I have a video (MPG) on the frontpage of http://www.bibleleague.hk but it does not play. The Mpeg is about 6MB... is it because it's too big?

thanks.

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Sat Feb 03, 2007 12:29 am

Yeap. You actually wait the video to download. So next time, prefer to use some "streamable" video filetype, like FLV or MOV (better quality and less size)...  :D
Fotis Evangelou / JoomlaWorks

User avatar
kai920
Joomla! Guru
Joomla! Guru
Posts: 542
Joined: Sun Sep 04, 2005 3:59 pm
Location: Hong Kong

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by kai920 » Sat Feb 03, 2007 3:09 am

Thanks! Will do that

baloo
Joomla! Intern
Joomla! Intern
Posts: 57
Joined: Mon Mar 06, 2006 8:30 am

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by baloo » Sat Feb 03, 2007 4:36 pm

First of all, great plugin.

Is there anyway to correct the Align function ?  When I embed a video into a content article, the aligment doesn't work like {mosimage} where the text wraps around the image.  With allvideos, the video will align, say, right, but the text of the article begins beneath the video.  Is there anyway to warp the video with text ?

atombee
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Sun Jul 30, 2006 7:22 am

Re: mp3s not playing from local folder

Post by atombee » Sat Feb 03, 2007 11:08 pm

Hi-

I've been using AllVideos to display my [youtube] videos ... it's great. but i need to play an mp3 (as opposed link to download) and I set up "audio" folder in /images/stories/ as directed ... uploaded mp3 ... made content item with proper code ... player shows up, but no sound comes out.

http://www.sunpopblue.com/index.php?opt ... &Itemid=12

do I need to set something in the php so that joomla knows to serve an mp3? i recall something about that, but can't remember where it is.

thank you! great mambot!

User avatar
FerretLife
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 157
Joined: Thu Aug 25, 2005 8:35 pm

Re: mp3s not playing from local folder

Post by FerretLife » Sun Feb 04, 2007 4:38 pm

atombee wrote: Hi-

I've been using AllVideos to display my [youtube] videos ... it's great. but i need to play an mp3 (as opposed link to download) and I set up "audio" folder in /images/stories/ as directed ... uploaded mp3 ... made content item with proper code ... player shows up, but no sound comes out.

http://www.sunpopblue.com/index.php?opt ... &Itemid=12

do I need to set something in the php so that joomla knows to serve an mp3? i recall something about that, but can't remember where it is.

thank you! great mambot!
I just took a look at your source. Here is the file you are trying to play:
images/stories/audio/embryonic.mp3.mp3
Since I doubt you called the mp3 embryonic.mp3.mp3, you probably used the mambot wrong. Change the code to {mp3}embryonic{/mp3} instead of {mp3}embryonic.mp3{/mp3} and it should work fine.

atombee
Joomla! Apprentice
Joomla! Apprentice
Posts: 31
Joined: Sun Jul 30, 2006 7:22 am

Re: Mp3's not playing

Post by atombee » Sun Feb 04, 2007 8:01 pm

Thank you - that worked!

great plug-n!!

Knox

User avatar
wjg
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sun Sep 18, 2005 11:58 am

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by wjg » Mon Feb 05, 2007 10:18 pm

act242 wrote: Thank you for a great plugin.  Overcame earlier stupidity and the plugin is working swimmingly well.

I have three different sizes (width and height, not length) of videos that I am putting up.  How do I format the class in order to accomodate these three different video sizes?
found this post, which hits my problem also. unfortunatly it was not answered. Is there any solution?

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Mon Feb 05, 2007 11:44 pm

You can't at the moment, at least not "natively". But using some "funky" CSS you can achieve this. Are you up to this to explain?  :pop
Fotis Evangelou / JoomlaWorks

User avatar
wjg
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Sun Sep 18, 2005 11:58 am

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by wjg » Tue Feb 06, 2007 2:09 pm

fotisevangelou wrote: You can't at the moment, at least not "natively". But using some "funky" CSS you can achieve this. Are you up to this to explain?  :pop
i'd be very pleased if you could post some of this funky css code. thanks for your help in advance!!

okouliko
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Mon Nov 27, 2006 3:40 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by okouliko » Wed Feb 07, 2007 12:21 pm

First, this is by far the greatest plugin for joomla, especialy for those (me f.e.) who are newbies.
Just one question. When i stream a local .flv video and trying to play it in fullscreen mode the video streches and covers the whole screen.
Can i do something so the video retaines it's original dimensions....?
Thanks.

User avatar
pinchepunk
Joomla! Intern
Joomla! Intern
Posts: 74
Joined: Thu Oct 20, 2005 2:20 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by pinchepunk » Thu Feb 08, 2007 12:45 am

Not displaying in my left module

This is strange but the Allvideos will not display in my left module? You will hear the audio but you do not see anything.  ???

However, it works in all the other modules... any idea of what I might be doing wrong?  :(

my page is http://www.enchufate.com/index.php
Last edited by pinchepunk on Thu Feb 08, 2007 12:47 am, edited 1 time in total.

User avatar
FerretLife
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 157
Joined: Thu Aug 25, 2005 8:35 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by FerretLife » Thu Feb 08, 2007 4:06 am

pinchepunk wrote: Not displaying in my left module

This is strange but the Allvideos will not display in my left module? You will hear the audio but you do not see anything.  ???

However, it works in all the other modules... any idea of what I might be doing wrong?  :(

my page is http://www.enchufate.com/index.php
I can see and hear it. I guess you figured it out?

User avatar
pinchepunk
Joomla! Intern
Joomla! Intern
Posts: 74
Joined: Thu Oct 20, 2005 2:20 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by pinchepunk » Thu Feb 08, 2007 4:22 pm

FerretLife wrote:
pinchepunk wrote: Not displaying in my left module

This is strange but the Allvideos will not display in my left module? You will hear the audio but you do not see anything.  ???

However, it works in all the other modules... any idea of what I might be doing wrong?  :(

my page is http://www.enchufate.com/index.php
I can see and hear it. I guess you figured it out?

strange... no, i haven't figured it out. I've now tried on two different machines and you hear it but you can't see it in the Left Module. But, it works fine in other modules. Anyone else have any luck or suggestions?

User avatar
FerretLife
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 157
Joined: Thu Aug 25, 2005 8:35 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by FerretLife » Fri Feb 09, 2007 4:08 am

I do see it at the top of the left column, under the video header. I tried both at home and work, in both IE and Firefox. When I opened your site in IE, I didn't see it at first just heard it. Then I refreshed the page, and it was visible. Very odd.

User avatar
FerretLife
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 157
Joined: Thu Aug 25, 2005 8:35 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by FerretLife » Fri Feb 09, 2007 4:10 am

After posting my last message I saw someone else who started a new thread with what sounds like the same problem you are having.
http://forum.joomla.org/index.php/topic,139631.0.html

User avatar
pinchepunk
Joomla! Intern
Joomla! Intern
Posts: 74
Joined: Thu Oct 20, 2005 2:20 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by pinchepunk » Fri Feb 09, 2007 4:28 am

Thanks, i'll check that other forum... i got home and tried on a third machine and the opposite happened for me. I was able to see the video just fine at first and then I refreshed to test it and NO video after the refresh! Uggg.... again, this seems to only happen in the left module.

Since I'm testing different modules if anyone visits the site now they will probably see video in other modules but there IS something the left just that it may not show for you. And the other modules are just copies i assigned to different module positions. So if anyone has any idea why its not showing up on the left, please let me know.

Thanks for the help!  :)
Last edited by pinchepunk on Fri Feb 09, 2007 4:33 am, edited 1 time in total.

ctcampbell
Joomla! Fledgling
Joomla! Fledgling
Posts: 2
Joined: Wed Jan 10, 2007 9:20 pm

Re: AllVideos Plugin v2.0 + iJoomla Magazine

Post by ctcampbell » Fri Feb 09, 2007 4:43 pm

To quote from Rob at iJoomla:  It doesn't work with video.  Anyone wrestling with it save yourself some time and uninstall.  Bummer, but true.

sparrish
Joomla! Fledgling
Joomla! Fledgling
Posts: 4
Joined: Sat Oct 15, 2005 6:00 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by sparrish » Fri Feb 09, 2007 6:56 pm

Hi there!  Let me start by saying that this is a really great plugin!  I have a question, though.  Is there a way to pass flashvars to the swf player using this plugin?  I don't mind hacking the code, just want to be able to pass an image parameter to the swf player with a filename based on the name of the video file being played.  Thanks for any help that you can provide.

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Sun Feb 11, 2007 1:14 am

This feature will come in 2.5...  :pop
Fotis Evangelou / JoomlaWorks


Locked

Return to “Plugins/Mambots”