AllVideos Plugin v2.0: THE all-in-one video management solution

Discuss the development and implementation of Joomla! bots/Plugins here.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
Locked
richardfv
Joomla! Intern
Joomla! Intern
Posts: 72
Joined: Wed Mar 15, 2006 4:51 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by richardfv » Tue Oct 10, 2006 9:00 pm

i am looking forward to get a good surprise :) mean while i converted to swf but i will prefer users to have the controls and dont have to wait for the loading
Thank you

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Tue Oct 10, 2006 9:09 pm

richardfv wrote: i am looking forward to get a good surprise :) mean while i converted to swf but i will prefer users to have the controls and dont have to wait for the loading
Thank you
Well, it seems that there will be no need to wait for a fix on the FLV player. I already found a new one and tomorrow I'll be releasing the new version...  :D
Fotis Evangelou / JoomlaWorks

blunderpup
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Fri Jun 09, 2006 3:03 pm

Difficulty with multiple mp3 files on one page

Post by blunderpup » Wed Oct 11, 2006 11:14 am

This plugin is really nice but I've come across an issue and am not sure if its something goofy on my site or a limitation in the plugin. I've created an article with 15 mp3 files listed on the page with the 15 players in two cells of a table. When I check the html in the JCE editor everything looks proper but when the page loads in IE or FF and I check the source, for the last 5 or 6 files the same source mp3 file is listed and, of course, the wrong file then plays for all of those links.

Is there a limit to the number of mp3 files that can appear on one page? If not, any other ideas? Thanks so much

BP

richardfv
Joomla! Intern
Joomla! Intern
Posts: 72
Joined: Wed Mar 15, 2006 4:51 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by richardfv » Wed Oct 11, 2006 11:50 am

where will the new version be released?

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Wed Oct 11, 2006 12:09 pm

I'll keep you posted on the new release.

As for the MP3 player, I guess it might have some limitations, since it uses an SWF file (the player). But I have not checked for sure...
Fotis Evangelou / JoomlaWorks

blunderpup
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Fri Jun 09, 2006 3:03 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by blunderpup » Thu Oct 12, 2006 2:35 am

Is there anyway to make a video or mp3 auto play when the document is opened? I did not see anything on this in the documentation. Thanks or your help.

BP

act242
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Tue Aug 29, 2006 2:00 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by act242 » Thu Oct 12, 2006 3:29 am

I know I have to be missing something, but I do not know what it is.

I put the following code in a static content:

{flv}SOLITUDErendered{/flv}


I have published the bot, and also gone "inside" the bot at the mambots list and clicked save.

I have made sure that the video is located in the images/stories/videos folder.

The only thing that shows up on the page is:
{flv}SOLITUDErendered{/flv}


Is there another bot or something that I need to install?  Or must I do something other than simply typing that code into the content?

Thanks!

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Thu Oct 12, 2006 8:04 am

This means that 2 things happen:

1. You haven't published the plugin
2. You are using versions 1.0.x

Please download the latest version 2.1 from the official site.
Fotis Evangelou / JoomlaWorks

act242
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Tue Aug 29, 2006 2:00 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by act242 » Thu Oct 12, 2006 1:34 pm

One of these days I will realize that the grey matter between the ears is there for a purpose!!

Thanks for getting back to me.  I did indeed have the old version installed.  Followed your directions, got everything up, and it works perfectly!

Thanks for a great plugin.  The ease of use shows just how much work you put into it!

User avatar
FerretLife
Joomla! Enthusiast
Joomla! Enthusiast
Posts: 157
Joined: Thu Aug 25, 2005 8:35 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by FerretLife » Thu Oct 12, 2006 6:18 pm

blunderpup wrote: Is there anyway to make a video or mp3 auto play when the document is opened? I did not see anything on this in the documentation. Thanks or your help.

BP
Hello fotisevangelou!

You were able to help me with the autostart on wmv files, and I'm hoping you have an answer for this. Are the paramiters for autostart for mp3's regulated through the swf and not through your plugin? Can it be changed? Thank you.

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Thu Oct 12, 2006 8:48 pm

An autostart feature will be added on 2.2, soon to be published...
Fotis Evangelou / JoomlaWorks

blunderpup
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Fri Jun 09, 2006 3:03 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by blunderpup » Thu Oct 12, 2006 11:08 pm

I will anxiously await 2.2. Thanks so much.

BP

Bukshot
Joomla! Apprentice
Joomla! Apprentice
Posts: 15
Joined: Sun Oct 15, 2006 3:05 am
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by Bukshot » Sun Oct 15, 2006 3:45 am

I was doing some testing and noticed that when trying to view a video in IE 6 it doesn't work, even with all the latest Windows Updates.  Works fine for me in Firefox though.

Heres a link if it helps any http://warhammervideos.com/videos/trail ... ailer.html
http://www.CriticalMuscle.com

blunderpup
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Fri Jun 09, 2006 3:03 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by blunderpup » Sun Oct 15, 2006 8:47 pm

Thank link works fine for me in IE6. Did you make some changes since the original post.

sc00bs
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Mon Oct 16, 2006 1:27 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by sc00bs » Mon Oct 16, 2006 2:40 pm

Installation Instructions for Newbies ???

Hi Guys

I am a newbie (allvideo & Joomla) and want to know if there is are installation instructions for allvideo that I can get hold of somewhere?

I have installed version 2.1 but am unable to get it to work and I am probably doing something stupid.  :-[

I successfully installed the plug in under the installers,mambots option on the menu, I then published it in the Mambots, Site Mambots menu where the plug in appeared.

Then to the bit I am not sure about :'(, to use the plug in, I assume that I need to add it to one of the Menu's. I went to menu, mainmenu, new, component, but am unable to locate the all video as an option to install. What is it that I am doing wrong, anybody care to put me out of my misery  :D

Thanks

JohnB

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Mon Oct 16, 2006 4:12 pm

sc00bs wrote: Installation Instructions for Newbies ???

Hi Guys

I am a newbie (allvideo & Joomla) and want to know if there is are installation instructions for allvideo that I can get hold of somewhere?

I have installed version 2.1 but am unable to get it to work and I am probably doing something stupid.  :-[

I successfully installed the plug in under the installers,mambots option on the menu, I then published it in the Mambots, Site Mambots menu where the plug in appeared.

Then to the bit I am not sure about :'(, to use the plug in, I assume that I need to add it to one of the Menu's. I went to menu, mainmenu, new, component, but am unable to locate the all video as an option to install. What is it that I am doing wrong, anybody care to put me out of my misery  :D

Thanks

JohnB
Full instructions are INSIDE the plugin's parameters page!  ;)
Fotis Evangelou / JoomlaWorks

sc00bs
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Mon Oct 16, 2006 1:27 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by sc00bs » Mon Oct 16, 2006 7:31 pm

Thanks for the suggestion fotisevangelou, I have been to to Mambots, site mambots and clicked on "allvideo plugin" I however get a message "restricted access" when I do so.

I assume that this is where I should be lookng at when you say "Full instructions are INSIDE the plugin's parameters page!"

Any suggestions?

JohnB

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Mon Oct 16, 2006 7:46 pm

It's an issue caused by Joomla 1.0.11

See this post for a solution:
http://forum.joomla.org/index.php/topic,99636.0.html
Fotis Evangelou / JoomlaWorks

sc00bs
Joomla! Apprentice
Joomla! Apprentice
Posts: 11
Joined: Mon Oct 16, 2006 1:27 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by sc00bs » Mon Oct 16, 2006 8:28 pm

Yeehaaa, its working!!

Thank you for your help

JohnB

mikesalaz
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Sun Oct 15, 2006 3:52 am

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by mikesalaz » Tue Oct 17, 2006 2:28 am

First: Great Plugin and I sincerely appreciate your work.

I have AllVideos working here:
http://www.musculardevelopment.com/cont ... w/208/129/

Works great in Firefox, but it's intermitent in IE.

My problem is, I am trying to get an image to show up before the video plays. I created the image here:
http://www.musculardevelopment.com/imag ... /tv/tv.jpg

and in the Mambot parameters, I entered the following:
images/stories/tv/tv.jpg

Yet, the image will not show up.

Thank you,

Mike

And check out my soon to be released Radio Show Portion of the site:
http://www.musculardevelopment.com/cont ... on/21/124/

destept
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Jul 18, 2006 5:28 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by destept » Tue Oct 17, 2006 7:43 am

Hello,

Is it possible to change the default folder (audio/video) to a link, located on another server (another address) ?!


Thanks in advace!

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Tue Oct 17, 2006 10:03 am

You need to change the php code on the main .php file!

What type (format) of videos are we talking about?
Fotis Evangelou / JoomlaWorks

act242
Joomla! Apprentice
Joomla! Apprentice
Posts: 9
Joined: Tue Aug 29, 2006 2:00 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by act242 » Wed Oct 18, 2006 2:05 am

Thank you for a great plugin.  Overcame earlier stupidity and the plugin is working swimmingly well.

I have three different sizes (width and height, not length) of videos that I am putting up.  How do I format the class in order to accomodate these three different video sizes?


Thanks!

mikesalaz
Joomla! Apprentice
Joomla! Apprentice
Posts: 7
Joined: Sun Oct 15, 2006 3:52 am

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by mikesalaz » Wed Oct 18, 2006 2:49 am

mikesalaz wrote: First: Great Plugin and I sincerely appreciate your work.

I have AllVideos working here:
http://www.musculardevelopment.com/cont ... w/208/129/

Works great in Firefox, but it's intermitent in IE.

My problem is, I am trying to get an image to show up before the video plays. I created the image here:
http://www.musculardevelopment.com/imag ... /tv/tv.jpg

and in the Mambot parameters, I entered the following:
images/stories/tv/tv.jpg

Yet, the image will not show up.

Thank you,

Mike

And check out my soon to be released Radio Show Portion of the site:
http://www.musculardevelopment.com/cont ... on/21/124/
Since I got no response with the image issue, I went into the php file and found a mistake in the code.

To add an image file. look for:
&image=images/stories/".$video_image."

and change to:
&image=".$video_image."\"

There are two instances, so look for both.

Mike

PS: If you want a sample, look here:
http://www.musculardevelopment.com/cont ... w/205/129/

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Wed Oct 18, 2006 7:45 am

mikesalaz wrote:
mikesalaz wrote: First: Great Plugin and I sincerely appreciate your work.

I have AllVideos working here:
http://www.musculardevelopment.com/cont ... w/208/129/

Works great in Firefox, but it's intermitent in IE.

My problem is, I am trying to get an image to show up before the video plays. I created the image here:
http://www.musculardevelopment.com/imag ... /tv/tv.jpg

and in the Mambot parameters, I entered the following:
images/stories/tv/tv.jpg

Yet, the image will not show up.

Thank you,

Mike

And check out my soon to be released Radio Show Portion of the site:
http://www.musculardevelopment.com/cont ... on/21/124/
Since I got no response with the image issue, I went into the php file and found a mistake in the code.

To add an image file. look for:
&image=images/stories/".$video_image."

and change to:
&image=".$video_image."\"

There are two instances, so look for both.

Mike

PS: If you want a sample, look here:
http://www.musculardevelopment.com/cont ... w/205/129/
There is no mistake in the code, please do not mislead users.

The images/stories is there to "force" users to put pictures inside that folder so that they won't stumble in permission issues if they decide to have another folder myimages/this_summer.  ;)

This may be open source, but never think for a moment that nothing hasn't been thought of...
Fotis Evangelou / JoomlaWorks

blunderpup
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Fri Jun 09, 2006 3:03 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by blunderpup » Wed Oct 18, 2006 10:22 am

I'm having difficulties with all flash players and flv video in IE. I've been using AllVideos but have tried several others. Everything works well in Firefox but in IE a page refresh or revisit will render the flash player nonexistent. I'm using the Mobius theme from RocketTheme and suspect some conflict, perhaps in different css files but frankly, I'm really ignorant about what or how that might occur.

I guess my question is have you seen any similar reports on IE use? I repeat, I don't think this is a problem with AllVideos but thought you might have seen something like it before.

bp

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Wed Oct 18, 2006 1:01 pm

Yes, I have. Perhaps you should check the z-index(es) in your site's css file to make sure that no div overlaps the layer on which the player exists. Also enable the transparency in the plugin.
Fotis Evangelou / JoomlaWorks

wglenncamp
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Tue Oct 10, 2006 5:39 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by wglenncamp » Wed Oct 18, 2006 2:15 pm

First of all, thanks for a wonderful mambot!!!!

Is there any way to make this work in joomlaboard?

fotisevangelou
Joomla! Ace
Joomla! Ace
Posts: 1421
Joined: Sun Jan 22, 2006 6:27 pm
Contact:

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by fotisevangelou » Wed Oct 18, 2006 2:51 pm

It shouldn't be difficult, I have already tried this on VirtueMart! But you need to "hack" some of Joomlaboard's files...  ;)
Fotis Evangelou / JoomlaWorks

blunderpup
Joomla! Apprentice
Joomla! Apprentice
Posts: 13
Joined: Fri Jun 09, 2006 3:03 pm

Re: AllVideos Plugin v2.0: THE all-in-one video management solution

Post by blunderpup » Wed Oct 18, 2006 3:07 pm

fotisevangelou wrote: Yes, I have. Perhaps you should check the z-index(es) in your site's css file to make sure that no div overlaps the layer on which the player exists. Also enable the transparency in the plugin.
I've verified that transparency is enabled. I've absolutely no css experience except since running Joomla and then my edits have been restricted to minimal items. In my theme's css I find this as the only reference to z-index:

Code: Select all

#access {
	position: absolute;
	z-index: 10000;
	top: 22px;
	right: 185px;
	width: 200px;
	height: 21px;
	overflow: hidden;
I'm not sure what that means but am googling now. Can you give me quick idea what this means and how to check for a conflict?

bp


Locked

Return to “Plugins/Mambots”