CB Public Mailing plugin Error upon install

Discuss the development and implementation of Joomla! bots/Plugins here.

Moderator: General Support Moderators

Forum rules
Forum Rules
Absolute Beginner's Guide to Joomla! <-- please read before posting, this means YOU.
Forum Post Assistant - If you are serious about wanting help, you will use this tool to help you post.
nycstude
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sun Dec 30, 2007 11:52 pm

CB Public Mailing plugin Error upon install

Postby nycstude » Sun Jan 06, 2008 6:50 pm

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'plug_publicmail_install' was given in /home/nycstude/public_html/administrator/components/com_comprofiler/library/cb/cb.installer.php on line 817

This error showed up after I installed...(although the install was successful.)
What should I do?

(Background note: I've been having issues with my permissions; my host recently set up a cronjob for chown for all my Joomla directories; somehow it missed public_html/components/com_profiler/plugin and all subfolders, but I made them world writable for the install to work; would this error have something to do with my permissions for /administrator or is this another issue? If it is a permissions issue, what should the permissions be?)

Thanks!

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: CB Public Mailing plugin Error upon install

Postby Kampp » Wed Feb 27, 2008 10:43 am

Hi

I created the plugin... :)

This is the third situation with this I hear. It seems that installation fails due to specific webhost settings. My guess is that it has to do with settings about error handeling and displying errors.

A new (AND MUCH) improved version of the CB public mail plugin is allmost finnished. The only thing that is holding it back is that the next version of CB (1.2) is needed as it fixes a bug that enables Captcha to work.

The additions in the new version is:
// Bugs fixed because of change in CB from $userid to $user->id
// Added cloack protection of the users emails in the form.
// Added two extra standard text fields that can be switched on if needed for additional information. This content is also stored in the database is activated.
// Added the feature of showing the plugin/form ONLY to visitors that are not logged in.
// Added the posebility of choosing the length of the subject field.
// Added the posebility of choosing the size of the indputboxes.
// Added the feature of choosing what to show the owner when visiting own profile.


The final two items for this release is the installer problem and captcha.
I will post here again when it has been fixed and ready for download...

Cheers, Kampp
http://www.toolmaster.dk - Danish Joomla Services!

nycstude
Joomla! Apprentice
Joomla! Apprentice
Posts: 8
Joined: Sun Dec 30, 2007 11:52 pm

Re: CB Public Mailing plugin Error upon install

Postby nycstude » Thu Feb 28, 2008 12:37 am

Thank you!

Looking forward to that post...

elcaro
Joomla! Fledgling
Joomla! Fledgling
Posts: 1
Joined: Tue Feb 19, 2008 4:20 pm

Re: CB Public Mailing plugin Error upon install

Postby elcaro » Sat Mar 08, 2008 5:11 pm

I just mailed Kampp as I was getting the exact same error. Very relieved to hear your reply, Kampp.
Waiting eagerly for updates...

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: CB Public Mailing plugin Error upon install

Postby Kampp » Sun Mar 09, 2008 11:58 am

Currently I am waiting for the new version of CB (version 1.2) that is due in about 2 weeks. The reason for this is that there are some things that can't work before that. Just to let you know ;)

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: CB Public Mailing plugin Error upon install

Postby Kampp » Wed Mar 19, 2008 9:42 am

Hi all...

As you may know CB 1.2 has been posponed a bit. Read the full story here: http://www.joomlapolis.com/content/view/5147/1/
It says at the bottom "CB 1.2 is planned for release in April 2008.".

Because of this will I see if I can find the time to release another version that fixes the install error and the other parts allready mentioned in the post above. The only thing missing then is the Captcha function and native Joomla 1.5.

Cheers, Kampp
http://www.toolmaster.dk - Danish Joomla Services!

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: CB Public Mailing plugin Error upon install

Postby Kampp » Wed Mar 19, 2008 12:17 pm

Well... I decided to do it now and skip the Captcha for next version.

Attached (in my post below this one) is the new version 1.1 of the CB Public Mail :laugh: It will also be available from Joomlapolis, but is not yet! This version fixes the Install problem!
It needs Legacy Mode to work in Joomla 1.5 (like the current version of CB)

Please report any bugs back to me and do a translation if you can! We have English, Danish and Dutch.
Last edited by Kampp on Wed Mar 19, 2008 4:37 pm, edited 1 time in total.
http://www.toolmaster.dk - Danish Joomla Services!

luo
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Mar 19, 2008 4:04 pm

Re: CB Public Mailing plugin Error upon install

Postby luo » Wed Mar 19, 2008 4:18 pm

Hii Thomas,
thank you,you solved the problem,after install.
But, I have some bugs (look below) and more important is,that the the form of cb_publicmail doesn't show me..so I couldn't use it.

Notice: Undefined index: mailName in C:\xamp\htdocs\euroinzercia\components\com_comprofiler\plugin\user\plug_cbpublicmail\publicmail.php on line 294

Notice: Undefined index: mailMail in C:\xamp\htdocs\euroinzercia\components\com_comprofiler\plugin\user\plug_cbpublicmail\publicmail.php on line 295

Notice: Undefined index: mailSubject in C:\xamp\htdocs\euroinzercia\components\com_comprofiler\plugin\user\plug_cbpublicmail\publicmail.php on line 296

Notice: Undefined index: mailExtra1 in C:\xamp\htdocs\euroinzercia\components\com_comprofiler\plugin\user\plug_cbpublicmail\publicmail.php on line 297

Notice: Undefined index: mailExtra2 in C:\xamp\htdocs\euroinzercia\components\com_comprofiler\plugin\user\plug_cbpublicmail\publicmail.php on line 298

Notice: Undefined index: mailText in C:\xamp\htdocs\euroinzercia\components\com_comprofiler\plugin\user\plug_cbpublicmail\publicmail.php on line 299

Notice: Undefined index: sendCopy in C:\xamp\htdocs\euroinzercia\components\com_comprofiler\plugin\user\plug_cbpublicmail\publicmail.php on line 300


Please ,do you know why?
Thank you

BR
luo

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: CB Public Mailing plugin Error upon install

Postby Kampp » Wed Mar 19, 2008 4:39 pm

Hi Luo

Ahh yes, I remember your errors now. They are not that common. Please see if this version fixes your problem. :geek:

Cheers, Kampp

A new version has been created - see below!
Last edited by Kampp on Thu Mar 20, 2008 3:19 pm, edited 1 time in total.
http://www.toolmaster.dk - Danish Joomla Services!

luo
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Mar 19, 2008 4:04 pm

Re: CB Public Mailing plugin Error upon install

Postby luo » Wed Mar 19, 2008 6:02 pm

Hi Thomas,
Thank you for quickly response,I installed and setup it,after that I tried every combination to sending a mail:

1.unreg.user send mail to unreg.user
(mail is required in registration,but how this mail it can be using in the your form?When I tried this choose,show me admin email?)
2.unreg.user send mail to reg.user
3.reg.user send mail to unreg.user
3.reg.user send mail to reg.user

but wihout result?:)

BR
Luo

luo
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Mar 19, 2008 4:04 pm

Re: CB Public Mailing plugin Error upon install

Postby luo » Thu Mar 20, 2008 1:10 pm

Hello Thomas,
I using a jreviews component,but it works directly with content item,do you think,that it could be a problem why it doesn't work for me?

Thank for your reply.

Best regards
Luo

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: CB Public Mailing plugin Error upon install

Postby Kampp » Thu Mar 20, 2008 1:17 pm

It cant be ruled out that it is the problem. I have fixed some minor bugs, but they are not in relation to this. All my tests shows that sending emails work. It uses the php mail function. Please check if this is available on your webhost.

The other error you got that is fixed is also something that the webhost controls in general.

At the moment the only problem is that it sends 2 emails. I am not sure if this is because of the code or Joomla/CB yet. A new version will be up when this is fixed.
http://www.toolmaster.dk - Danish Joomla Services!

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: CB Public Mailing plugin Error upon install

Postby Kampp » Thu Mar 20, 2008 3:24 pm

Attached is a new version. In all my tests it sends two mails everytime. I am not sure what is the cause og this yet or if anyone else has the problem. I have only testet it on Joomla 1.5, CB 1.1, "Legacy Mode".

The way I see it at the moment is that your webhost is a bit strange when it comes to setup. Please confirm the situation with the php "mail" function.
You do not have the required permissions to view the files attached to this post.
http://www.toolmaster.dk - Danish Joomla Services!

luo
Joomla! Apprentice
Joomla! Apprentice
Posts: 5
Joined: Wed Mar 19, 2008 4:04 pm

Re: CB Public Mailing plugin Error upon install

Postby luo » Fri Mar 21, 2008 1:42 pm

Hello Thomas,
sorry for lating.I had to go away.Thank you for new version.
I tested the new version at the joomla 1.0.14 and CB 1.1 with "php mail function" (Php mail function works,becuase after registeration a new user..CB send a mail and this works)..the mail was sent,but when I checked it on the both accounts inbox,no mail was there.Maybe I have to test it on the new version of joomla..?Did you test it at old version of joomla?

BR
Luo

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: CB Public Mailing plugin Error upon install

Postby Kampp » Sun Mar 23, 2008 9:33 pm

The plugin has been tested on Joomla 1.0.14 and works. Please confirm that it is not caught by you spam filter?

randev
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Sat May 03, 2008 6:48 pm

Re: CB Public Mailing plugin Error upon install

Postby randev » Sun Jun 15, 2008 7:22 pm

Thank you for the updated Public Mail plugin that removed the error on install. I am using Joomla 1.5.3 with CB 1.2 RC and I installed your Public Mail plugin. If go to Tab Management it shows that the Public Mail tab should be displaying but it does not when I look at the user profile details. If I click on the words Public Mail to edit the parameters I get brought to a page that has no Save button, so no way to save my changes. The Tab Details section has many options, but the Parameters section on the right says "Direct Access to this location is not allowed." Any tips on how I can get this working so unregistered users can email registered users? Thanks.

randev
Joomla! Apprentice
Joomla! Apprentice
Posts: 6
Joined: Sat May 03, 2008 6:48 pm

Re: CB Public Mailing plugin Error upon install

Postby randev » Sun Jun 15, 2008 8:58 pm

I figured out that I had never turned on the legacy plugin in Joomla, now the Parameters appear correctly. Any update on when a version with CAPTCHA support will be available?

User avatar
jasellyn
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Jun 29, 2008 1:46 am

CB Public Mailing plugin Error

Postby jasellyn » Sun Sep 07, 2008 7:07 pm

Hi,

I was thrilled to see that the Public Mail plugin was available for 1.5 Native. I'm using 1.5.3 and when I install the plugin, it goes fine (I was not in Legacy Mode), but when I went to publish the plugin, I received the error "Direct Access to this location is not allowed" and had to remove the plugin for my site to work. I was never able to get into the parameters at all. Just to try it, I did install the plugin using Legacy and I had no issues at all with parameters or publishing the plugin--however, as soon as I disabled Legacy mode, it was back to the error.

Am I missing something? The extension description shows that this is a 1.5 Native plugin so I assumed it did not have to be installed or run under Legacy.

Any suggestions?

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: CB Public Mailing plugin Error upon install

Postby Kampp » Tue Sep 09, 2008 4:40 pm

Hi everyone

Finnaly the last round of testing has been completed. There has been some mixup on the Joomlapolis site where they used the old version of the Public Mail. This now almost fixed as they need to confirm my changes.

Attached (below) is the natvie 1.5 version that supports Captcha and has better security etc.:

Cheers, Kampp
Last edited by Kampp on Sat Sep 13, 2008 12:27 pm, edited 1 time in total.
http://www.toolmaster.dk - Danish Joomla Services!

User avatar
jasellyn
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Jun 29, 2008 1:46 am

CB Public Mailing plugin - CB 1.2 RC 2?

Postby jasellyn » Tue Sep 09, 2008 10:13 pm

Hi there!

Just a quick question...I tried to install the plugin under Community Builder RC1.2 and received the error:

Plugin version (1.2) different from Community Builder version (1.2 RC 2)

Thoughts? Thanks for this fab plugin!

Ellyn

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: CB Public Mailing plugin Error upon install

Postby Kampp » Thu Sep 11, 2008 5:43 pm

Hi

The bug is confirmed and is being investigated...

Cheers, Kampp
http://www.toolmaster.dk - Danish Joomla Services!

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: CB Public Mailing plugin Error upon install

Postby Kampp » Sat Sep 13, 2008 12:26 pm

Please try this one. ;)
cb_publicmail1.2.zip
You do not have the required permissions to view the files attached to this post.
http://www.toolmaster.dk - Danish Joomla Services!

User avatar
jasellyn
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Jun 29, 2008 1:46 am

Re: CB Public Mailing plugin Error upon install

Postby jasellyn » Sat Sep 13, 2008 4:54 pm

Hiya!

Thanks so much for the hard work on this great plugin...

I installed it and received this error:

Upload showPlugins - Failed
Plugin version (1.2) different from Community Builder version (1.2 RC 2)

I'm using CB 1.2RC2

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: CB Public Mailing plugin Error upon install

Postby Kampp » Sat Oct 11, 2008 11:07 am

Hi

The error has been located. It's a bug in CB.

To make an immediately fix it please open the XML installer in the "Public Mail" plugin and change the tag "<version>1.2</version>" to "<version>1.1</version>".
Please note that you have to remember that the real version installed is 1.2 as the system will not tell you later.
OR simply wait until this has been fixed in CB.

Cheers, Kampp
http://www.toolmaster.dk - Danish Joomla Services!

User avatar
jasellyn
Joomla! Apprentice
Joomla! Apprentice
Posts: 12
Joined: Sun Jun 29, 2008 1:46 am

Re: CB Public Mailing plugin Error upon install

Postby jasellyn » Sat Oct 11, 2008 10:13 pm

Yay! That fixed it PERFECTLY (and I am much to impatient to wait for the bug to be fixed...:D)

Thank you thank you! My users will be thrilled to have their public mail function back!

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: CB Public Mailing plugin Error upon install

Postby Kampp » Fri Jul 08, 2011 9:32 am

Today a new version 1.3 of the Public Mail has been released!

This version 1.3 has many improvements:
  • Optimized the plugin parameters/configuration.
  • Fixed \r\n breaks error in email messages for some servers.
  • Added feature of restricting/limit Public Mail to certain users (crude style).
  • Added BCC feature so admins can receive a copy of all send messages.
  • Added feature of subject prefix for receivers.
  • Added feature of subject prefix for BBC emails.
  • Added a third optional extra field (this means an added column in the database).
  • Added comments to the database log columns for better understanding.
  • Added Swedish language (thanks Panaman).
  • Added German language (thanks Yves Hoppe).
  • Added Spanish language (thanks Julio Quattropani).
  • Added Italian language (thanks Federico Leva).
  • Added Frensh language (thanks MDB Cohen).
  • Added Brazilian Portuguese language (thanks Eduardo H. Sabbi).

Download the new 1.3 version:
You can grab it from the Community Builder website or the Joomla Extensions as soon as it has been approved:
https://www.joomlapolis.com/cb-solution ... ered-users
http://extensions.joomla.org/extensions ... ation/2249

I did a small FAQ:
Q: I can't install. I get the error message: "Error! Could not find a Joomla! XML setup file in the package.".
A: Public Mail is a CB plugin and not a Joomla extension. Please use the CB plugin installer instead of the Joomla installer!!

Q: I still can't install the plugin?
A: First confirm that you are using the CB installer and not the Joomla installer! If you are still experiencing problems it is most likely due to host file or folder permissions. You may need to CHMOD some folders like the "media" and CB "plugins/user/" folder!

Q: Are there any problems in upgrading from version 1.2 to 1.3?
A: Only one! There is a new column (called "mailextra3") in the database table for the new third extra field. This column needs to be created manually! The new files can simply overwrite the old ones in the folder "\components\com_comprofiler\plugin\user\plug_cbpublicmail\". If you haven’t used the log or don't need it you can simply uninstall the plugin and install it again!

Q: I NEED this plugin installed and I have tried everything! Is it possible to do a manual install?
A: Yes it is! Place all the files from the package in a folder in this location: "\components\com_comprofiler\plugin\user\plug_cbpublicmail\". Now you only need to create the one database table (if you need to log emails)! You can find the SQL table you need in the XML installer file and insert it into your database though PhpMyAdmin.

Q: How do I use/view the full database log?
A: There is currently not an interface for that. You need to view the data directly in the database table jos_comprofiler_plug_iplog. You need a database tool, like e.g. PhpMyAdmin. This tool is most often supplied by your webhost, but can also be installed by your self.

Q: Nothing is stored or logged in the database table?
A: First confirm that you have logging activated in the configuration and the database table jos_comprofiler_plug_iplog exists! If so it is most likely due to a wrong table or column collation. It works for sure with "utf8_general_ci". You can change the collation with PhpMyAdmin.

Q: Instead of line breaks I see "\r\n"?
A: This is due to your email system or the host. However this error should have been fixed in Public Mail version 1.3!

Q: Where are the parameters/configuration/settings located?
A: Configuration is located in Community Builders "Tab Management" and not the "Plugin Management".

Q: Can I restrict the usage of Public Mail to a specific user group?
A: Yes, just like any CB plugin under "Tab Management" you can choose who can use/view the plugin.

Q: Can I restrict the use of Public Mail to individual people?
A: Yes, you can do this in the configuration in version 1.3 and up. However it can seem a bit crude to use if you have many users.

Q: The plugin does not work with CAPTCHA if it is placed in a tab?
A: It does in all tests created. The most likely error is therefore that you are using an old version of CAPTCHA or there are some issues with your template or CB template.

Q: I get the error: "Upload showPlugins - Failed. Plugin version (1.2) different from Community Builder version (1.2 RC 2)"?
A: In general this problem is gone if you have updated your CB to the newest version. Same thing goes for Public Mail. If this does not work, then change the "<version>1.2</version>" to "<version>1.1</version>" in the plugin XML installer file.
http://www.toolmaster.dk - Danish Joomla Services!

citydan
Joomla! Intern
Joomla! Intern
Posts: 98
Joined: Mon May 11, 2009 3:00 am
Contact:

Re: CB Public Mailing plugin Error upon install

Postby citydan » Thu Jun 07, 2012 8:23 pm

Hello Kampp

I'm getting an error at the top of my user profiles:

Notice: Undefined variable: curruser in <span>/</span>home<span>/</span>content/22/5879622/html/new2012/components/com_comprofiler/plugin/user/plug_cbpublicmail/publicmail.php on line 94


Joomla 2.5.4
CB 1.8
CB Subs 2.0.1
PHP 5.2.17
MySQL 5.0.77
Ioncube loader on

I was running CB_CAPTCHA 2.2RC4, now it's 2.4 (from the v2.3 download) but it did not fix it
Also have CB PUBLIC MAIL v 1.3
Landscape Architecture Resource
everything useful for landscape architects
http://landscapearchitectureresource.com
jobs | schools | materials | news | firms | lare

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: CB Public Mailing plugin Error upon install

Postby Kampp » Thu Jun 14, 2012 12:16 pm

This is a reported bug. BUT simply turn off the PHP notice errors on the server/host. This should not be on anyway as it gives clues to hackers.
http://www.toolmaster.dk - Danish Joomla Services!

User avatar
Kampp
Joomla! Guru
Joomla! Guru
Posts: 562
Joined: Tue Aug 30, 2005 9:18 am
Location: Denmark
Contact:

Re: CB Public Mailing plugin Error upon install

Postby Kampp » Sat Apr 27, 2013 2:24 pm

:D The next version of Public Mail is here! :D

Here is a list of changes in version 1.4 of Public Mail:
  • Fixed Swedish language file that was not UTF-8 encoded (thanks Sven Jungmar).
  • Fixed language load to strict Joomla 3.0 (also comptable with 2.5).
  • Fixed duplicate return user in send mail function (thanks Patrick from itvault.com).
  • Fixed the stripslashes problem (can result in other errors for other users on other hosts).
  • Removed index.php from action in form as some Joomla 3 sites had problems with this.
  • Rewrote the code for sending mails, for easier future maintinance.
  • Converted all emails to be in HTML format - this should also solve the issues with '/r/n'.
  • Improved many texts and tooltips in configuration.
  • Added full support for Joomla 3.1 (and 2.5, 3.0).
  • Added FAQ text about how emails are sent in the plugin configuration and installer description text.
  • Added Bootstrap class btn-tag to form submit button.
  • Added feature of blocking IP's from sending emails (including text definition in language files).
  • Added feature of sending emails from the site instead of the individual users (set as reply adress).
  • Added SEF URL support (JRoute).

Please download it here or on the Joomla extensions site, or on Joomlapolis.com

Please test is and report any problems back to me. It needs testing!

Also please make a translation of the plugin and send the file to me.
You do not have the required permissions to view the files attached to this post.
http://www.toolmaster.dk - Danish Joomla Services!


Return to “Plugins/Mambots”

Who is online

Users browsing this forum: No registered users and 3 guests